project-navigation
Personal tools

Author Topic: Night side of the Earth transparent when using very low ambient lighting  (Read 3834 times)

Offline Wuzzy

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
The night side of the Earth (3D geoscape) becomes transparent for me if I set the ambient lighting (advanced graphics options) to a very low value. The sky, including sun and moon, shine through the Earth, which looks somehow funny.

ufo02.png shows the battlescape with a non-critical ambient light. The value I used is close to the default value. Nothing wrong here.
ufo04.png show the same battlescape from exactly the same time, viewing position, angle and zoom level but with the lowest possible ambient light value. You clearly see the sun shining through. Also note that the city lights are still visible.

Architecture: IA-32
OS: Linux 3.5.0 (i686)
Distribution: Arch Linux
UFO: AI obtained from: Arch Linux [community] repository
Arch Linux packages installed: ufoai 2.4-2, ufoai-data 2.4-1
Graphics card: NVIDIA GeForce GTX 460
Graphics driver: NVIDIA’s official crappy driver 310.32

How to reproduce:
  • In the advanced video options, set the ambient lighting to a very low value
  • View the 3D battlescape in campaign mode

Can anyone confirm this?
« Last Edit: March 06, 2013, 07:39:39 pm by Wuzzy »

Offline JRandomNoob

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
I can see it on both 2.4 stable and 2.5-dev (Windows nightly from Jan 31). Using Windows XP SP3 & ATI Radeon 4350 (Catalyst 12.6).