project-navigation
Personal tools

Author Topic: RMA - Strange behaviour  (Read 2667 times)

Offline Latino210

  • Squad Leader
  • ****
  • Posts: 161
  • UFORadiant mapper
    • View Profile
RMA - Strange behaviour
« on: November 03, 2012, 03:13:24 pm »
Hi, people.

I am having a problem with a RMA map. I made a map consisting in a tile for the dropship and some scenario, to be put north of a rectangular tile with the map proper. The problem is that sometimes the map is assembled on the contrary, the marines end up facing the south side of the big tile, instead of the north side. Can somebody take a look at the .ump, please?

 
Code: [Select]
// Tiletypes:
// ----------
// a: main
// b: dropship

tile +main
{
10 8

0 b b b b b b b b 0
0 +a +a +a +a +a +a +a +a 0
0 +a +a +a +a +a +a +a +a 0
0 +a +a +a +a +a +a +a +a 0
0 +a +a +a +a +a +a +a +a 0
0 +a +a +a +a +a +a +a +a 0
0 +a +a +a +a +a +a +a +a 0
0 0 0 0 0 0 0 0 0 0
}

tile +craft_drop_firebird
{
10 4

0 0 0 0 0 0 0 0 0 0
0 +b +b +b +b +b +b +b +b 0
0 +b +b +b +b +b +b +b +b 0
0 a a a a a a a a 0
}


assembly default

{
size "8 8"
title "_Fighting Pit"
+main "1 1"
*rm_drop +craft_drop_firebird "1 1"
}

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: RMA - Strange behaviour
« Reply #1 on: November 03, 2012, 03:39:20 pm »
Code: [Select]
// Tiletypes:
// ----------
// 0: this always means there are no restrictions to what could be placed here
// a: main
// b: dropship
// x: do not make a tile with +x for this to work

tile +main
{
10 8

0 b b b b b b b b 0
x +a +a +a +a +a +a +a +a x
x +a +a +a +a +a +a +a +a x
x +a +a +a +a +a +a +a +a x
x +a +a +a +a +a +a +a +a x
x +a +a +a +a +a +a +a +a x
x +a +a +a +a +a +a +a +a x
0 x x x x x x x x 0
}

tile +craft_drop_firebird
{
10 4

0 x x x x x x x x 0
x +b +b +b +b +b +b +b +b x
x +b +b +b +b +b +b +b +b x
0 a a a a a a a a 0
}


assembly default

{
size "8 8"
title "_Fighting Pit"
+main "1 1"
*rm_drop +craft_drop_firebird "1 1"
}

After this it should work as intented.

Offline Latino210

  • Squad Leader
  • ****
  • Posts: 161
  • UFORadiant mapper
    • View Profile
Re: RMA - Strange behaviour
« Reply #2 on: November 03, 2012, 04:25:29 pm »
Thanks.