project-navigation
Personal tools

Author Topic: Ubuntu 12.10: Crash during launch  (Read 10793 times)

Offline Wirelizard

  • Rookie
  • ***
  • Posts: 22
    • View Profile
Ubuntu 12.10: Crash during launch
« on: October 24, 2012, 08:08:43 am »
So I upgraded to Ubuntu 12.10 last night, from 12.04. Not sure why I bothered. 12.10 seems to have given me a shiny new video driver issue, and I can't get my UFO:AI fix either.

See attached screenshot for what I get when I try to launch UFO. I'm using the PlayDeb install as recommended on the Download page, and that worked perfectly in 12.04.

Part of the problem is Ubuntu's craptastic Unity interface, which seems to have buried all the useful setup and configuration utilities somewhere unfindable... I use Unity these days, but only because it's the default, not because I like the damn thing.

Anyone got any ideas? Need my UFO fix!

Offline leadjester

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #1 on: October 27, 2012, 02:53:28 am »
I am having the same sort of issue. Are you by chance using a netbook using an intel chipset? Or other integrated intel video card? They have trash for driver support on linux. I ended up just installing it on my desktop for the time being. Though I much rather have it mobile.

Offline dimanlin

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #2 on: November 07, 2012, 02:53:31 pm »
I am having the same sort of issue.
intel

Offline Wirelizard

  • Rookie
  • ***
  • Posts: 22
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #3 on: November 15, 2012, 04:40:41 am »
I'm running a Shuttle xPC, and it does have some sort of Intel graphics card built-in.

Almost worth re-installing Ubuntu 12.04, as UFO:AI worked perfectly there, presumably the older graphic card drivers were better.

Sod. Thanks, I'll have a rummage through the Ubuntu Forums and elseweb, but it sounds like I might be out of luck with 12.10...

You know, I've already privately nicknamed Ubuntu 12.10 "Ubuntu Vista"... the nickname gets more and more apt!

Offline ffr31

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #4 on: November 28, 2012, 08:02:18 pm »
Hello same issue here.

Launch from terminal and get "Error: Received signal 11." after libraries load.

Offline Zen Clark

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #5 on: January 09, 2013, 12:34:18 am »
I have the same problem. This is the backtrace I got from gdb:

Code: [Select]

#0  0xb31fac4e in rgb565_image () from /usr/lib/i386-linux-gnu/libtxc_dxtn.so
No symbol table info available.
#1  0xb31fdc39 in tx_compress_dxtn ()
   from /usr/lib/i386-linux-gnu/libtxc_dxtn.so
No symbol table info available.
#2  0xb2db4240 in _mesa_texstore_rgb_dxt1 ()
   from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#3  0xb2dd5bed in _mesa_texstore ()
   from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#4  0xb2dd5e63 in ?? () from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#5  0xb2dd60f6 in _mesa_store_teximage ()
   from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#6  0xb30a7a2d in ?? () from /usr/lib/i386-linux-gnu/dri/i965_dri.so
No symbol table info available.
#7  0xb2dc1906 in ?? () from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#8  0xb2dc2b7e in _mesa_TexImage2D ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/i386-linux-gnu/libdricore9.0.0.so.1
No symbol table info available.
#9  0x080fa6cd in R_UploadTexture (data=0xafd79008, width=1024, height=768,
    image=0x9e7d77c <r_images+12284>) at src/client/renderer/r_image.c:328
        scaled = 0xaf978034
        scaledWidth = 1024
        scaledHeight = 1024
        samples = 33776
        i = 786432
        c = 786432
        scan = 0xb007900b ""
        mipmap = qfalse
        clamp = qtrue
        __PRETTY_FUNCTION__ = "R_UploadTexture"
#10 0x080fae42 in R_LoadImageData (name=0xbffff00c "pics/background/mail_bg",
    pic=0xafd79008 "xxx\377yyy\377{{{\377|||\377}}}\377}}}\377~~~\377\177\177\177\377~~~\377}}}\377|||\377xxx\377www\377uuu\377ppp\377nnn\377ooo\377ooo\377ooo\377ooo\377ooo\377ppp\377ooo\377kkk\377fff\377eee\377fff\377ccc\377___\377___\377```\377ccc\377ggg\377kkk\377mmm\377nnn\377nnn\377ppp\377ooo\377kkk\377ggg\377ggg\377ggg\377ggg\377ggg\377eee\377ggg\377hhh\377fff\377jjj\377"..., width=1024,
    height=768, type=it_pic) at src/client/renderer/r_image.c:496
---Type <return> to continue, or q <return> to quit---
        image = 0x9e7d77c <r_images+12284>
        images = 0x9e7a780 <r_images>
        i = 83
        len = 23
        hash = 57
        __PRETTY_FUNCTION__ = "R_LoadImageData"
#11 0x080fb21d in R_FindImage (
    pname=0x971d260 <string.4410+12288> "pics/background/mail_bg", type=it_pic)
    at src/client/renderer/r_image.c:582
        lname = "pics/background/mail_bg\000\206Y\254\267X\360\377\277\275_\022\b`\322q\t\000\020\000\000$B\032\bd\360\377\277\000\000\000\000 \222\000\005d\360\377\277"
        image = 0x0
        surf = 0xabff438
#12 0x08093ffd in UI_LoadImage (name=0xb103ea44 "background/mail_bg")
    at src/client/ui/ui_render.c:76
        image = 0x8123d05 <UTF8_strncpyz+176>
#13 0x080a250a in UI_ImageNodeLoaded (node=0xb103e910)
    at src/client/ui/node/ui_node_image.c:63
        image = 0xb103e910
#14 0x08093167 in UI_ParseNode (parent=0xb103e720, text=0xbffff1c8,
---Type <return> to continue, or q <return> to quit---
    token=0xbffff168,
    errhead=0x81a3da4 "UI_ParseWindow: unexpected end of file (window")
    at src/client/ui/ui_parse.c:1110
        node = 0xb103e910
        behaviour = 0x82aca80 <nodeBehaviourList+4416>
        component = 0x0
        result = qtrue
#15 0x08092d57 in UI_ParseNodeBody (node=0xb103e720, text=0xbffff1c8,
    token=0xbffff168,
    errhead=0x81a3da4 "UI_ParseWindow: unexpected end of file (window")
    at src/client/ui/ui_parse.c:991
        newNode = 0x28
        result = qtrue
#16 0x08093879 in UI_ParseWindow (type=0x94b77c0 <headerType.8245> "window",
    name=0x94b7800 <headerName.8246> "mailclient", text=0xbffff1c8)
    at src/client/ui/ui_parse.c:1336
        errhead = 0x81a3da4 "UI_ParseWindow: unexpected end of file (window"
        window = 0xb103e720
        token = 0x9719220 <com_token> "}"
        result = qtrue
        i = 61
---Type <return> to continue, or q <return> to quit---
#17 0x08058f98 in CL_ParseClientData (
    type=0x94b77c0 <headerType.8245> "window",
    name=0x94b7800 <headerName.8246> "mailclient", text=0xbffff1c8)
    at src/client/cl_main.c:812
        progressCurrent = 1464
#18 0x080d9360 in Com_ParseScripts (onlyServer=qfalse)
    at src/common/scripts.c:3355
        type = 0x94b77c0 <headerType.8245> "window"
        name = 0x94b7800 <headerName.8246> "mailclient"
        text = 0xac94e65 "\n\n\t// ", '=' <repeats 18 times>, "\n\t// text and info\n\t// ", '=' <repeats 18 times>, "\n\n\tstring mailclienthead\n\t{\n\t\tstring\t\t\"_Mailclient\"\n\t\tpos\t\t\t\"355 30\"\n\t\tsize\t\t\"290 30\"\n\t\tcontentalign\tALIGN_CC\n\t\tcolor\t\t\"0 .78 0 1\"\n\t\tfo"...
#19 0x080c43ef in Qcommon_Init (argc=10, argv=0xbffff2d4)
    at src/common/common.c:1205
        s = 0x9721260 <string.4410+28672> "pics/background/irc_bg_rm"
#20 0x08129cb3 in main (argc=10, argv=0xbffff2d4)
    at src/ports/linux/linux_main.c:50
No locals.


Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #6 on: January 09, 2013, 12:36:44 am »
I have the same problem. This is the backtrace I got from gdb:

Crash in the video card driver, we can't help on it.

-geever

Offline Zen Clark

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #7 on: January 09, 2013, 10:38:00 pm »
Crash in the video card driver, we can't help on it.

-geever


I suggestions as to how the driver can be downgraded? The game worked perfectly fine before I went to 12.10.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #8 on: January 09, 2013, 10:48:41 pm »
As it is an Intel GMA, I don't know a good solution.

You can try disabling GLSL shaders by starting ufoai with
Code: [Select]
ufo +set r_programs 0

-geever

Offline Zen Clark

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #9 on: January 09, 2013, 11:15:04 pm »
Disabling the GLSL shaders did not change anything.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #10 on: January 09, 2013, 11:46:50 pm »
Disabling the GLSL shaders did not change anything.

Ok. One more idea I have: try disabling texture compression (as the function names in the stack-trace suggest this is the area where it crashes)

Code: [Select]
ufo +set r_ext_texture_compression 0

-geever

Offline Zen Clark

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #11 on: January 10, 2013, 09:07:55 pm »
Still getting the same 'signal 11' error.

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #12 on: January 10, 2013, 09:32:19 pm »

I suggestions as to how the driver can be downgraded? The game worked perfectly fine before I went to 12.10.

maybe ask that at ubuntuforums.org? I'm pretty sure the people over there would know.

Offline Zen Clark

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #13 on: January 11, 2013, 12:55:41 am »
maybe ask that at ubuntuforums.org? I'm pretty sure the people over there would know.

Thanks for the suggestion; I have now made a thread asking that question and am now waiting for a response.
http://ubuntuforums.org/showthread.php?t=2103636

Offline darksider3

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Ubuntu 12.10: Crash during launch
« Reply #14 on: January 30, 2013, 11:41:20 pm »
Here i have the same problem:
(ufo.log)
Code: [Select]

---- filesystem initialization -----
Adding game dir: /usr/share/ufoai/base
Adding game dir: ./base
Added packfile ./base/0base.pk3 (9 files)
Added packfile ./base/0maps.pk3 (544 files)
Added packfile ./base/0materials.pk3 (45 files)
Added packfile ./base/0media.pk3 (10 files)
Added packfile ./base/0models.pk3 (2015 files)
Added packfile ./base/0pics.pk3 (2114 files)
Added packfile ./base/0shaders.pk3 (26 files)
Added packfile ./base/0snd.pk3 (266 files)
Added packfile ./base/0ufos.pk3 (97 files)
Adding game dir: /home/leon/.ufoai/2.3.1/base
using /home/leon/.ufoai/2.3.1/base for writing
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.21.3 OpenSSL/0.9.8o zlib/1.2.3.4 libidn/1.25 initialized.

------ server initialization -------
added 7 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.14
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1024x600 800x600 640x480 (3)
I: video driver: x11
I: setting mode -1
I: set swap control to 0
I: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 0 multisample buffers
GL_VENDOR: Intel Open Source Technology Center
GL_RENDERER: Mesa DRI Intel(R) 945GME x86/MMX/SSE2
GL_VERSION: 1.4 Mesa 9.0
GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_multitexture GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_NV_vertex_program GL_ARB_depth_texture GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_vertex_program1_1 GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_ARB_half_float_pixel GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_pixel_buffer_object GL_ARB_texture_rectangle GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_rectangle GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_gpu_program_parameters GL_OES_EGL_image GL_ARB_copy_buffer GL_ARB_map_buffer_range GL_EXT_separate_shader_objects GL_ARB_ES2_compatibility GL_ARB_debug_output GL_ARB_draw_elements_base_vertex G./ufo(Sys_Backtrace+0x20)[0x81a753a]
./ufo[0x81a7b04]
[0xb7737400]
/usr/lib/i386-linux-gnu/libtxc_dxtn.so(tx_compress_dxtn+0x399)[0xb59e8c39]
./ufo(Sys_Backtrace+0x20)[0x81a753a]
./ufo(Sys_Error+0x1d)[0x81a7a69]
./ufo[0x81a7b17]
[0xb7737400]
/usr/lib/i386-linux-gnu/libtxc_dxtn.so(tx_compress_dxtn+0x399)[0xb59e8c39]
Error: Received signal 11.

L_ARB_explicit_attrib_location GL_ARB_provoking_vertex GL_ARB_sampler_objects GL_ARB_texture_rgb10_a2ui GL_EXT_provoking_vertex GL_ARB_robustness GL_ARB_texture_storage GL_ARB_invalidate_subdata
Activate texture compression for Intel chips - see cvar r_intel_hack
Set max. texture resolution to 1024 - see cvar r_intel_hack
using GL_ARB_texture_compression
using GL_ARB_texture_non_power_of_two
using GL_ARB_shading_language_100
GLSL Version: 1.20
using GL_ARB_framebuffer_object
max draw buffers: 1
max render buffer size: 2048
max color attachments: 8
max supported lights: 8
max texture units: 8
max texture coords: 8
max vertex attributes: 16
max texture size: detected 2048
...but using 1024 as requested
Using low resolution globe textures as requested.
R_LoadProgram: 'world' loaded.
R_LoadProgram: 'warp' loaded.
R_LoadProgram: 'geoscape' loaded.
R_LoadProgram: 'combine2' loaded.
R_LoadProgram: 'convolve3' loaded.
R_LoadShader: atmosphere_fs.glsl: 0:79(15): error: array index must be < 1
0:79(15): error: type mismatch

R_LoadProgram: atmosphere:
R_LoadShader: simple_glow_fs.glsl: 0:23(15): error: array index must be < 1
0:23(21): error: type mismatch
0:23(21): error: type mismatch
0:24(15): error: array index must be < 1
0:24(19): error: type mismatch
0:24(19): error: type mismatch

R_LoadProgram: simple_glow:
SDL_image version 1.2.10
SDL_ttf version 2.0.9 - we need at least 2.0.7
Couldn't allocate requested number of drawBuffers in R_SetupFramebuffer!

------- sound initialization -------
SDL_mixer version: 1.2.8
... requested audio rate: 44100
... driver: 'alsa'
... audio rate: 44100
... audio channels: 2
Modified render related cvars
glsl restart
R_LoadProgram: 'world' loaded.
R_LoadProgram: 'warp' loaded.
R_LoadProgram: 'geoscape' loaded.
R_LoadProgram: 'combine2' loaded.
R_LoadProgram: 'convolve3' loaded.
R_LoadShader: atmosphere_fs.glsl: 0:79(15): error: array index must be < 1
0:79(15): error: type mismatch

R_LoadProgram: atmosphere:
R_LoadShader: simple_glow_fs.glsl: 0:23(15): error: array index must be < 1
0:23(21): error: type mismatch
0:23(21): error: type mismatch
0:24(15): error: array index must be < 1
0:24(19): error: type mismatch
0:24(19): error: type mismatch
R_LoadProgram: simple_glow:
Can anyone say me, how i can fix that?
--
Edit: Have builded it from sources... The unittest says:
http://pastebin.com/5nryHQES
And the normaly startup:
http://pastebin.com/v2ri2VKU
« Last Edit: January 31, 2013, 12:45:28 am by darksider3 »