project-navigation
Personal tools

Author Topic: Hi, Reporting a bug  (Read 2607 times)

Offline bertram

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Hi, Reporting a bug
« on: February 15, 2013, 05:43:45 pm »
Hi everyone :)

First of all, thanks for this super-duper game. I've been trying it from time to time, and from what I've seen so far, the improvements are numerous!

I would like to report a bug before you do the release but I had an error when clicking on the activation link of the *new* bug tracker. It led me to a 404 error, and the google+ link didn't work either. So I created an account here in order to report it asap :)

The bug happens when I try to enter a battle on a crash site or on a activity signal spot, for instance. Whenever the transporter reaches the site, two options are proposed: Enter or auto-mission. Auto-mission is working fine, but enter leads to a crash with the following log:

2013/02/15 17:21:30 CM_LoadMap: "-military_convoy/mc_ +main +craft_drop_firebird" "-48 -32 0 32 8 0"
2013/02/15 17:21:30 ********************
2013/02/15 17:21:30 ERROR: Couldn't load maps/military_convoy/mc_main.bsp
2013/02/15 17:21:30 ********************
2013/02/15 17:21:31 Shutdown server: Server crashed.
2013/02/15 17:21:31 Unload the game library
2013/02/15 17:21:31 Music: geoscape track changed from Crystan-Geosphere04 to Crystan-Geosphere02.
2013/02/15 17:21:35 Shutdown gametype 'Campaign mode'
2013/02/15 17:21:35 Music: main track changed from Crystan-Geosphere02 to van_theme.
2013/02/15 17:21:37 Wrote config.cfg.
2013/02/15 17:21:37 Wrote keys.cfg

Please note that I'm using latest git that I compile without any local change, and I 'make install'ed it. I have the same crash on both the git version and in the installed version. Is a file missing?

Best regards,

Offline bertram

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Hi, Reporting a bug
« Reply #1 on: February 15, 2013, 06:04:09 pm »
Hi again,

After checking the files there, I did a ln -s to the mc_main.map file but it led to another error about the version number:
ERROR: CM_AddMapTile: military_convoy/mc_main has wrong version number (1769238117 should be 78)

Better wait for a fix, I guess.

Best regards,

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Hi, Reporting a bug
« Reply #2 on: February 15, 2013, 07:58:16 pm »
You have to compile the maps via make maps or download pre-compiled maps via make maps-sync. (The latter is faster, it will run a python tool to fetch bsps.)

-geever

Offline bertram

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: Hi, Reporting a bug
« Reply #3 on: February 15, 2013, 09:19:18 pm »
Hi geever!

That was pretty simple. I feel stupid.  ;D

Thanks a lot. I'll get the bsp and try again.

Best regards,