project-navigation
Personal tools

Author Topic: Problem starting UFO AI Vers. 2.4 - program crashes after start  (Read 13155 times)

Offline Sandro

  • Squad Leader
  • ****
  • Posts: 240
  • Maintenance guy for UFO:AI 3D engine
    • View Profile
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #30 on: July 25, 2012, 10:44:51 pm »
Yes, I understand that. Looks like I've got to take a time-out -- no good ideas what to check next.

But you can search 3D-related forums for the "best drivers for old card" topics -- I've encountered some useful hints there before. Actually, google search for "best drivers for mobility radeon 9700" returns some interesting links. Maybe -- MAYBE -- they will be of help.

OFC, if you try those, don't forget to create system restore point and do a virus check for unofficial downloads :)

Offline Pink_Lollipop

  • Rookie
  • ***
  • Posts: 20
    • View Profile
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #31 on: July 25, 2012, 10:47:49 pm »
Thank you for the support and advices. Cheers. I will try other drivers.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #32 on: July 26, 2012, 08:03:29 am »
You could even try starting with

Code: [Select]
ufo.exe +set r_programs 0

This will disable GLSL shaders, if it starts like that, it's most probably a driver problem (but it is possible that you cannot find a good driver with working shaders at - but least you can play with less fancy graphics)

-geever

Offline homunculus

  • Sergeant
  • *****
  • Posts: 387
    • View Profile
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #33 on: July 26, 2012, 09:40:33 am »
You could even try starting with

Code: [Select]
ufo.exe +set r_programs 0

This will disable GLSL shaders, if it starts like that, it's most probably a driver problem (but it is possible that you cannot find a good driver with working shaders at - but least you can play with less fancy graphics)

-geever
i also guessed it might have something to do with drivers, as i couldn't start a campaign in the stable 2.4 nor in 2.5 dev (windows xp here), until i first started the game in safe mode (used the safe mode from start menu -> programs ...), and after that the game ran also with normal start (i.e. not safe mode), except i needed to set fullscreen again and enable sound once.

Offline Crystan

  • Project Artist
  • Captain
  • ***
  • Posts: 572
  • UFO:AI Lead Sound Artist
    • View Profile
    • http://crysea.cr.funpic.de/
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #34 on: July 26, 2012, 10:07:27 am »
Probably you installed 2.4 over 2.3? If yes - make a clean install.

Offline Pink_Lollipop

  • Rookie
  • ***
  • Posts: 20
    • View Profile
Re: Problem starting UFO AI Vers. 2.4 - program crashes after start
« Reply #35 on: July 26, 2012, 10:17:42 am »
Hello guys,

I just installed a new older graphic card driver for my ATI Radeon Mobility 9700:

ATI Radeon Catalyst Vers. 9.3 (9_3_mobile_xp32_dd_ccc_enu).

The game is starting and working now as far as I can tell. I did not fight a battle yet. Need to set up a campaign. I keep you posted.

Once again, I like to thank all of you for your advice and support. You are doing a great job here!!  :)

UFO AI 2.3 or 2.3.1 is not installed on my computer. I only installed UFO AI 2.4 .