project-navigation
Personal tools

Author Topic: map glitches  (Read 8722 times)

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: map glitches
« Reply #15 on: June 10, 2012, 10:41:23 pm »
city_industry fixed in master. Thanks for reporting.

Nokim

  • Guest
Re: map glitches
« Reply #16 on: June 14, 2012, 10:45:46 pm »
Next time i'll try to check if this ghost disappears. Never tried to turn all soldiers to another direction...
I have tried this... Alien (untargetable, standing, non-reacting) vanished. But when all other aliens where dead game crashed.

All i have got in log (non dev mode):

Team 7's round started!
[STATS] Nokim (Katie Dekkers) kills alien (Mrorg Ok Uhm Uurrp) with Snap Shot of pbeamrifle_ammo (entnum: 136)
[STATS] End of game - Team 1 is the winner
[STATS] Soldier Artur Dixit earned 114 experience points in skill #0 (total experience: 5043). It is now 10 higher.
...STATS-STATS...
[STATS] Soldier Benoit Berg earned 164 experience points in skill #9 (total experience: 13442). It is now 18 higher.
Disconnecting...
Client stream was closed
Remove pending event 15
Error: Mem_CheckSentinels: bad memory header top sentinel [buffer underflow]
free: src/common/common.cpp:#1428


UPD: Somewhere near that alien his needler was on the ground. Alien (with needler in hands too) vanished and so that needler. No corpse left.
« Last Edit: June 15, 2012, 08:47:11 am by Nokim »

Nokim

  • Guest
Re: map glitches
« Reply #17 on: July 08, 2012, 06:24:41 pm »
Map military convoy again...
On pic 1 shown that alien is one cell away from place where he is shown (if target to model 0% chance to hit shown).
On pic 2 shown stuck alien and place where he was actually killed (plasma rifle on the ground) by reaction fire.
Of course game crashed on battle end on freeing something related to that alien (entnum 45), log attached (with developer set).

sssergeee

  • Guest
Re: map glitches
« Reply #18 on: July 11, 2012, 12:13:56 am »
UFO's missions become even more extreme with bugs that throw you to global map: you always thinking of not doing "wrong" action.

system: WinXP x32, videocard: Radeon HD 6900, version: 2.5-dev ia-32 jul 4 2012 win 32 debug.
I am plaing campaing.

In one of Mansion missions globalmap throw out due to wrong passfinding: my soldier attemps to move through area with alien which hadn't been spotted before moving attempt. Soldier usually ends in a textures.

In one of Mansion missions when I have spotted alien/civilian their turn begins and I can wait forever for my turn.

In one of Mansion missions (in some another maps too) soldiers do not react on their command for some time (move points do not reduce. Soldiers can start movement then suddenly stops with no move points reduction) or before I attempt (!) to shoot somewhere by target soldier and move by another.

In rivertown mission globalmap throw out when I attempt to target (!) (not shoot!) alien on the another side of the map