project-navigation
Personal tools

Author Topic: Plea to the comunity to help fix inventory/equipment bugs.  (Read 4007 times)

Hoehrer

  • Guest
Plea to the comunity to help fix inventory/equipment bugs.
« on: April 03, 2006, 05:45:13 pm »
Plea to the comunity to help fix inventory/equipment bugs.

This is a test project i'm trying to start here, so if it doesn't work out because of the lack of participants there isn't 'much' lost but a speedier release of the next (more stable) game. [1]

Requirements

You need to be able to compile from current source (SVN).

List of existing bug reports

I've collected all tracked bugs related to inventory and equipment. I think that some of them are already fixed, but not marked as such.
[ 1462243 ] Battlescape: moving items does not always work correctly
[ 1461639 ] Soldier equipment vanishes on mission retry
[ 1456040 ] Equipment Loss When Mission Start
[ 1435737 ] No inventory
[ 1428944 ] No free inventory space
[ 1428942 ] CL_CollectItems - endless loop

Tasks

To fix these bugs i ask everyone who want them fixed to...
  • find bugs that you have submitted (see list above) and try reproducing them. Please report if they have been fixed in recent svn, and if not if they have changed.
  • choose any of the listed bugs above and try reproducing. Please report if they have benn fixed in recent svn, and if not if they have changed.
  • generally test the equipment and and inventary interface in the base and in the battlescape. Do things you would normally not do and see if they break.
Every bit of information is helpful.
If you run the game with ...
Code: [Select]
./ufo +set developer 1 you'll get more output in the console.[2]  Post it here if possible.
Remember or write down exactly what you did when the bug occured and post it here ort in the correct bug-tracker. Screenshots showing the bug are also welcome.

Werner

[1] Sentence may contain cynism ;)
[2] I still need to check if that is the same with the 'release' version and not only with the 'debug' one.