project-navigation
Personal tools

Author Topic: Radiant OSX fails for me  (Read 3656 times)

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Radiant OSX fails for me
« on: May 12, 2012, 07:14:53 am »
I'd upload the image but there doesn't seem to be any image hosting on this board.

I get a Radiant Runtime Error with a lot of rectangles as the content of the error message.

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Re: Radiant OSX fails for me
« Reply #1 on: May 13, 2012, 08:37:31 pm »
hmm my bad figured it out

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Radiant OSX fails for me
« Reply #2 on: May 13, 2012, 08:39:27 pm »
when do you get the "error" message box?
you will have a radiant logfile in your ~/.ufoai/ directory - can you attach this file here, too please?

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Re: Radiant OSX fails for me
« Reply #3 on: May 13, 2012, 11:02:56 pm »
I get the message box the second I try to launch radiant.

Have I installed it incorrectly? I just downloaded the dmg, ran it, copied out the radiant file to my desktop and double clicked it which results in this error.

I'm not sure I have the radiant logfile either -- what is the filename?
my ufoai directory only has a ufo logfile

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Re: Radiant OSX fails for me
« Reply #4 on: May 14, 2012, 08:59:54 am »
found the radiant log.

Started logging to /Users/reminisce/.ufoai/radiant/radiant.log
Today is: Sun May 13 23:51:05 2012

This is UFORadiant '1.5.0' compiled Jun 17 2010
UFORadiant based on GtkRadiant 1.5 branch
src/tools/radiant/include/modulesystem.h:256
assertion failure: SingletonModuleRef::getTable: type="radiant" version="1" - module-reference used without being initialised
----------------

Stacktrace is not implemented on this plattform

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Radiant OSX fails for me
« Reply #5 on: May 14, 2012, 10:08:03 am »
this is a very old version. i will try to assemble a new one asap and let you know about it

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Re: Radiant OSX fails for me
« Reply #6 on: May 14, 2012, 10:12:34 am »
thanks a lot!

Offline geisthund

  • Squad Leader
  • ****
  • Posts: 103
    • View Profile
Re: Radiant OSX fails for me
« Reply #7 on: June 16, 2012, 08:07:53 am »
Totally forgot to post this : thanks for fixing it mattn!