project-navigation
Personal tools

Author Topic: Can't load my previous saved games after updating to 2.4  (Read 5099 times)

Offline cmmps

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Can't load my previous saved games after updating to 2.4
« on: May 10, 2012, 10:50:00 pm »
Hi there!

I was an addict of the old X-Com game... I found this UFO:AI on Arch Linux repos and got addict again! :D

Well, I was running UFO:AI version 2.3.1 and after a full system update I got the new version 2.4.

I started to see my saved games slots empty. I browsed the ".ufoai" folder and found the folders for versions 2.3.1 and 2.4.
I copied the "save" folder from 2.3.1 to 2.4 and now I see my saved games but I can't load them! Any attempt will bring me back to the start screen.

I took a look on the log file and found an error:
2012/05/10 21:08:11 Invalid base index -1
2012/05/10 21:08:11 ...subsystem 'base' returned false - savegame could not be loaded

I spent a lot of hours on the campaign I was playing... I really hope it is possible to fix this error.

System information:
Processor AMD FX6100 (64bits)
4Gb RAM
Display adapter: NVidia 560GTX with 1Gb
OS: Linux
Distro: Arch Linux
Kernel Version: 3.3.5

Log file and saved games attached...


Kind regards,
Carlos Santos
A new UFO:AI addict! :)


Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #1 on: May 10, 2012, 11:30:17 pm »
afaik savegames are not compatible between releases. If you want to finish your 2.3 games, you probably should reinstall 2.3.

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #2 on: May 10, 2012, 11:33:01 pm »
Oh, did you go from 2.3 to 2.4 via an update (apt-get, ubuntu update manager or the like)? If so, it's rather likely you should reinstall anyway, I found out myself the hard way that it shouldn't have been updated like that - you should reinstall go from one version to another.

Offline Crystan

  • Project Artist
  • Captain
  • ***
  • Posts: 572
  • UFO:AI Lead Sound Artist
    • View Profile
    • http://crysea.cr.funpic.de/
Re: Can't load my previous saved games after updating to 2.4
« Reply #3 on: May 10, 2012, 11:37:57 pm »
afaik savegames are not compatible between releases. If you want to finish your 2.3 games, you probably should reinstall 2.3.

Thats right - 2.3 Savegames are not compatible with 2.4.

Offline cmmps

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #4 on: May 11, 2012, 01:14:03 am »
Hi

Thanks a lot for the information.
It's petty I'm going to loose so many hours of game, but with the new graphics and new items... who cares? I'm starting all over again! ;)

Quote
Oh, did you go from 2.3 to 2.4 via an update (apt-get, ubuntu update manager or the like)?
Dude, I wrote my Linux distro... is Arch Linux...  ;)
I don't like Ubuntu anyway... :P

Thanks again and for the team: Congratulation on 2.4!! Excelent work here! Nice graphics, great animations!
I don't play World of Warcraft for more than a week because of UFO:AI... LOL!!

Kind regards,
Carlos

Offline cmmps

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #5 on: May 11, 2012, 07:41:10 pm »
Nevertheless, does anyone thought about creating a tool to migrate the 2.3 saved games to 2.4?
There should be a way...

I can try to make such tool, all I need is a description of the saved games files.

With whom should I speak to?

Regards,
Carlos

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #6 on: May 11, 2012, 08:05:19 pm »
geever?

Offline solbu

  • Administrator
  • Rookie
  • *****
  • Posts: 30
  • Norwegian translator, Mageia packager
    • View Profile
    • My website
Re: Can't load my previous saved games after updating to 2.4
« Reply #7 on: May 30, 2012, 03:45:11 am »
I can try to make such tool, all I need is a description of the saved games files.
That would be an awesome feature.

May I suggest you use the same license for the tool as the game use, the "GNU GPL version 2 or later". That way it will be included in the various distributions as well. :)

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Can't load my previous saved games after updating to 2.4
« Reply #8 on: May 30, 2012, 09:28:38 am »
From 2.3->2.4 the problem is simply that way too many things has changed, and I couldn't tell you all of them. Even if you made a converter with the ones we find there could be hidden problems which would cause strange behaviour of the game. I'll write a list of breaks we do since 2.4 so I can make such a tool for 2.5.

-geever