project-navigation
Personal tools

Author Topic: installing 2.4-1?  (Read 10861 times)

Offline igor140

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
installing 2.4-1?
« on: April 27, 2012, 05:32:10 am »
so, i'm still an ubuntu newb, but i've been look forward to 2.4 for a while.  i've come to find that playdeb.net is down, which is unfortunate.  i've individually downloaded each of the .deb packages (data, server, music, the "basic", and even the radiant that i don't need), but i can't seem to install them. 

as far as i understand it, i need to first install the servers, then the data, then the music, then the "basic" package... the server tells me it's installed, but not configured.  what does that even mean?  why was this not nearly as complicated with 2.3...?

Offline igor140

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: installing 2.4-1?
« Reply #1 on: April 27, 2012, 05:34:27 am »
it also keeps telling me that it needs libmxml.so.1 but i don't know where this is.  is this part of the -data package?

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: installing 2.4-1?
« Reply #2 on: April 29, 2012, 02:23:53 am »
so, i'm still an ubuntu newb, but i've been look forward to 2.4 for a while.  i've come to find that playdeb.net is down, which is unfortunate.

http://www.webupd8.org/2010/05/getdeb-playdeb-repositories-down-what.html

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: installing 2.4-1?
« Reply #3 on: May 03, 2012, 09:50:53 am »
so is 2.4 official released? because desura and playdeb have 2.3.1 version up not the 2.4 even tho the links from the Download section say 2.4
i was hopping for a .deb file for my ubuntu, but before i compile one myself from sources is there any out there?

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: installing 2.4-1?
« Reply #4 on: May 03, 2012, 10:13:20 am »
so is 2.4 official released? because desura and playdeb have 2.3.1 version up not the 2.4 even tho the links from the Download section say 2.4
i was hopping for a .deb file for my ubuntu, but before i compile one myself from sources is there any out there?

Sorry, not yet, our packager is away ATM.

-geever

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: installing 2.4-1?
« Reply #5 on: May 03, 2012, 10:48:05 am »
no worries:) just checking, il make one myself, tho i dont know where i could upload for ppl to use:)

Offline redaxe90

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: installing 2.4-1?
« Reply #6 on: May 14, 2012, 08:07:30 pm »
The PlayDeb website reports that the version for Ubuntu 12.04 should be up to 2.4-1, but when I try to upgrade, it tells me I have the latest version. Why the disparity of information?

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: installing 2.4-1?
« Reply #7 on: May 14, 2012, 08:45:56 pm »
The PlayDeb website reports that the version for Ubuntu 12.04 should be up to 2.4-1, but when I try to upgrade, it tells me I have the latest version. Why the disparity of information?

upgrading from previous versions not supported, first uninstall completely, then reinstall the latest version from getdeb repos. worked for me.

Offline redaxe90

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: installing 2.4-1?
« Reply #8 on: May 14, 2012, 09:01:26 pm »
Thanks, will try that :)

Offline redaxe90

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: installing 2.4-1?
« Reply #9 on: May 14, 2012, 09:08:28 pm »
After removing UFO:AI from the software center, I got this error message upon trying to reinstall with the latest version

There isn’t a software package called “ufoai” in your current software sources

Any ideas?

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: installing 2.4-1?
« Reply #10 on: May 15, 2012, 12:14:55 am »
where did you get the files, have you previously installed software from getdeb, their repos might not be in your software sources list? do doublecheck.

they also have this small guide, in case you missed it: http://www.playdeb.net/updates/Ubuntu/11.10#how_to_install

edit - do you use synaptic? that might be the easier way to go, since it shows you the package versions, what's already installed and so on in a clearer way. make sure you don't have any 2.3 stuff installed. uforadiant package is needed only if you want to make your own maps.
« Last Edit: May 15, 2012, 12:23:27 am by kurja »

Offline SenorWombat

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
    • Alliteration Ink
Re: installing 2.4-1?
« Reply #11 on: June 09, 2012, 06:30:59 pm »
upgrading from previous versions not supported, first uninstall completely, then reinstall the latest version from getdeb repos. worked for me.

It could also be that they're running a version prior to 11.10.  The current version is not offered for those versions.

Which begs the question:  Is it possible to support those older versions?  I'm running 10.04, and this is one of only two programs I use that don't have a backport of some kind to allow it to run on the (still active LTS) 10.04?

Offline anark10n

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: installing 2.4-1?
« Reply #12 on: June 12, 2012, 04:43:43 pm »
Having trouble with it as well. trying the it from palydeb results in a popup window asking which program to open it with (like the 'open with ... ' dialogue of nautilus). compiling from source results in a black screen before crashing to desktop even if I run the command as root (which results in a shorter list of errors than when i run it as regular user).

Offline kurja

  • Captain
  • *****
  • Posts: 504
    • View Profile
Re: installing 2.4-1?
« Reply #13 on: June 12, 2012, 08:25:26 pm »
Having trouble with it as well. trying the it from palydeb results in a popup window asking which program to open it with (like the 'open with ... ' dialogue of nautilus).

sorry but did you check this first? http://www.playdeb.net/updates/Ubuntu/11.10#how_to_install

Offline anark10n

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: installing 2.4-1?
« Reply #14 on: June 12, 2012, 09:53:56 pm »
sorry but did you check this first? http://www.playdeb.net/updates/Ubuntu/11.10#how_to_install

yes i did, even after updating, nothing doing; but i think that might be down to my update manager acting funny, keeps telling me i have outdated updates no matter how many times i press the 'check' button to get fresh updates.