project-navigation
Personal tools

Author Topic: problem w/ alien base map  (Read 6394 times)

Offline jcjordan

  • Squad Leader
  • ****
  • Posts: 138
    • View Profile
problem w/ alien base map
« on: November 25, 2011, 07:18:17 am »
I'm using build 1320698644 & I've got a problem on my mission to the alien base where it drops back to geoscape when loading the mission. Attached is the console.log w/ the error.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: problem w/ alien base map
« Reply #1 on: November 25, 2011, 07:50:17 am »
thanks for reporting it, there is a bug in the ump file. there is no a_corner_tr map in the alienb theme.

Quote
ERROR: Couldn't load maps/alienb/a_corner_tr.bsp

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress

Offline EventHorizon

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: problem w/ alien base map
« Reply #3 on: March 17, 2012, 03:32:13 pm »
Long time lurker, first time replier here. I am getting this error (ERROR: Couldn't load maps/alienb/a_corner_tr.bsp) when I try to land at alien bases in version 2.4 on the Mar 11 build. The link to SourceForge seems to be showing this issue has been closed but it is showing up here. Please let me know if you need any further information on this error. It recurs when I reload the game. Thanks.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: problem w/ alien base map
« Reply #4 on: March 17, 2012, 03:46:59 pm »
can you please attach your ufoconsole.log (see FAQ for the location)

Offline Kildor

  • Project Artist
  • Captain
  • ***
  • Posts: 757
  • Project mapper and some other stuff`er
    • View Profile
    • http://ufoai.nx0.ru
Re: problem w/ alien base map
« Reply #5 on: March 17, 2012, 04:54:29 pm »
a_corner_tr tile was used in previous version of alienbase map, and it was in 2.3.

Offline EventHorizon

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: problem w/ alien base map
« Reply #6 on: March 18, 2012, 03:25:34 am »
Console log attached. Message is about a third of the way scrolled across on the bottom line. Version: UFO:AI 2.4 dev IA-32 Mar 11 2012 Win32 DEBUG build 1331387238.
« Last Edit: March 18, 2012, 03:30:54 am by EventHorizon »

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: problem w/ alien base map
« Reply #7 on: March 18, 2012, 10:16:09 am »
Console log attached. Message is about a third of the way scrolled across on the bottom line. Version: UFO:AI 2.4 dev IA-32 Mar 11 2012 Win32 DEBUG build 1331387238.

My guess is you installed the 2.4dev over or next to an older version.

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: problem w/ alien base map
« Reply #8 on: March 18, 2012, 11:14:31 am »
@mattn kildor the new alienbase uses ab_ prefix, in the ufoconsole.log its just a_. So the game is reading from an older .ump file.

This might happen if the user installed maybe 2.3.1, extracted the maps.pk3 and installed the 2.4dev afterwards?

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: problem w/ alien base map
« Reply #9 on: March 18, 2012, 12:30:19 pm »
yes - that might be a reason. hard to say - but the installation is broken.

Offline EventHorizon

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: problem w/ alien base map
« Reply #10 on: March 21, 2012, 04:17:18 am »
I used to have 2.3.1 installed. But I uninstalled it before installing 2.4. I don't believe that I ever had both of them installed on my computer at the same time. In fact I believe that there was a semester between uninstalling 2.3.1 and 2.4, but I am not sure of that. Is this something that I can fix or do I just celebrate that I "won" the game, scrub my computer of 2.4, and re-install? Thanks for your help.

Offline ShipIt

  • Project Artist
  • Captain
  • ***
  • Posts: 906
    • View Profile
Re: problem w/ alien base map
« Reply #11 on: March 21, 2012, 07:27:42 am »
... scrub my computer of 2.4 everything related to UFO AI, and re-install? ....

Sorry, but that´s the best way, I think.

Installing UFO AI from the download section is a bit confusing atm, as there is a 2.4 version to be released soon, while developement is 2.5-dev now. Thats up to you, but installing and playing the 2.4 version is very appreciated, as stated in the news page.


Offline jcjordan

  • Squad Leader
  • ****
  • Posts: 138
    • View Profile
Re: problem w/ alien base map
« Reply #12 on: March 21, 2012, 10:28:14 pm »
I was having other map problems & I had a dual install of 2.3.1 as well as the 2.4 dev but I was only playing the 2.4 version. I then deleted both versions including going through my registry like i'd never installed either. Even though the uninstall works some traces are left so regedit is only way to remove all traces. I then installed one of the nightly builds (forget which one offhand right now) & have had no problems since so best bet might be to remove all traces of both the install 2.4