project-navigation
Personal tools

Author Topic: Debian/Ubuntu packages for i386/amd64  (Read 38401 times)

Offline shag

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #15 on: January 19, 2012, 10:58:38 am »
patch is here, although from my experience with my prev patches it will be in git within the next hour :)

https://sourceforge.net/tracker/?func=detail&aid=3475976&group_id=157793&atid=805244

Offline krytek

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #16 on: March 20, 2012, 12:50:52 am »
Hey guys, first post here.
2.4 is amazing so far, thanks guys. Although there is still the resolution change bug from 2.3 (game crashes on start after res change)
a restart after res change solves the problem.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #17 on: March 20, 2012, 06:21:20 pm »
Hey guys, first post here.
2.4 is amazing so far, thanks guys. Although there is still the resolution change bug from 2.3 (game crashes on start after res change)
a restart after res change solves the problem.
:o
Probably you did not play latest version of 2.4 as actual master version (& v2.4 branch) force you to restart the game when changing resolution, so the crash is avoided in all cases.
Please retry with a newer version (or wait a few weeks until v2.4 is finally released).

Offline krytek

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #18 on: March 20, 2012, 10:16:48 pm »
:o
Probably you did not play latest version of 2.4 as actual master version (& v2.4 branch) force you to restart the game when changing resolution, so the crash is avoided in all cases.
Please retry with a newer version (or wait a few weeks until v2.4 is finally released).
The version I got is from March 10th (IIRC)
Just to make sure we're on the same page, when I said "restart" I mean the PC, not the game.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #19 on: April 01, 2012, 01:34:03 am »
You can find fresh .deb packages of our v2.4 Release Candidate for x86 (i386) and x86_64 (amd64) on the download page:

Offline ferralll

  • Rookie
  • ***
  • Posts: 13
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #20 on: April 02, 2012, 09:06:05 pm »
I downloaded, but I got this message from the package installer.
Code: [Select]
Error: Dependency is not satisfiable: libjpeg62 (>= 6b1)
Does that mean that libjpeg62 is to high of a version? Or is there something else wrong?



EDIT:
I am running Ubuntu 10.04
« Last Edit: April 02, 2012, 09:31:26 pm by ferralll »

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #21 on: April 02, 2012, 11:06:06 pm »
I downloaded, but I got this message from the package installer.
Code: [Select]
Error: Dependency is not satisfiable: libjpeg62 (>= 6b1)
Does that mean that libjpeg62 is to high of a version? Or is there something else wrong?



EDIT:
I am running Ubuntu 10.04

This means you need a version of libjpeg62 that is bigger or same like 6b1.
You should be able to find a bigger version in the standard Ubuntu 10.04 repos: https://launchpad.net/ubuntu/lucid/amd64/libjpeg62
Try to install libjpeg62 via package manager.

Offline ferralll

  • Rookie
  • ***
  • Posts: 13
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #22 on: April 02, 2012, 11:44:04 pm »
Hmm...

Nope.  I checked, and I have libjpeg62 installed.  And I still get the same message. 

I tried re-installing it, and I tried restarting it.  But it is still giving the same message.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #23 on: April 03, 2012, 12:37:47 am »
Hmm...

I have created a bug report and assigned it to our volunteer package creator accumulator.
I hope he can help soonish.

https://sourceforge.net/tracker/?func=detail&aid=3514277&group_id=157793&atid=805242

Edit: Seems accumulator moved it to feature requests ?! : http://sourceforge.net/tracker/?func=detail&aid=3514277&group_id=157793&atid=805245

Nevermind, according to this statement new packages have already been uploaded:
http://colabti.org/irclogger/irclogger_log/ufoai?date=2012-04-05#l18

« Last Edit: April 05, 2012, 06:52:13 pm by MCR »

Offline ferralll

  • Rookie
  • ***
  • Posts: 13
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #24 on: April 06, 2012, 12:32:52 am »
Seems like the new build is working.  I am installing it now.  (The libjpeg62 conflict did not re-occur)

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #25 on: April 06, 2012, 12:35:34 am »
Good news :)

Now, please also tell us that it starts, runs and plays better than ever before as well ;)

Offline ferralll

  • Rookie
  • ***
  • Posts: 13
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #26 on: April 06, 2012, 01:09:38 am »
Thanks for all the help MCR and Accumulator

I started it up, and it seems to run fine.  It is a bit slower than 3.2, but then again, I have a slow computer.  I just need to adjust some of the graphics profiles, and re-tool a couple of the keyboard controls.  (The battle map movement is difficult because of the slowness, but I will change that soon.)

But I fooled around with the Geoscape, and did a quick battle, and so far I think it is looking like a great improvement!

I will post if I have any problems.
« Last Edit: April 06, 2012, 11:36:07 pm by ferralll »

Offline wizardelo

  • Rookie
  • ***
  • Posts: 28
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #27 on: April 11, 2012, 08:40:12 am »
installed the latest deb and no dependency problems or other errors occurred. so far it works fine. will post if i find anything that is out of place.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #28 on: April 11, 2012, 02:11:59 pm »
installed the latest deb and no dependency problems or other errors occurred. so far it works fine. will post if i find anything that is out of place.

Good News :)

Offline Duque Atreides

  • Rookie
  • ***
  • Posts: 80
    • View Profile
Re: Debian/Ubuntu packages for i386/amd64
« Reply #29 on: October 15, 2012, 02:51:31 am »