project-navigation
Personal tools

Author Topic: Win 7/64 Crashing after loading tactical screen.  (Read 9493 times)

Offline BrotherWu

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Win 7/64 Crashing after loading tactical screen.
« on: July 10, 2011, 08:26:50 pm »
Any ideas?  I have tried running in XP compatability mode.  Running on a laptop with an Nvidia Quadro FX 880M. 
« Last Edit: July 10, 2011, 08:28:51 pm by BrotherWu »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #1 on: July 10, 2011, 09:26:56 pm »
Any ideas?  I have tried running in XP compatability mode.  Running on a laptop with an Nvidia Quadro FX 880M. 

You should share your ufoconsole.log. It may contain information about the nature of the crash. It is also important which version do you play and how it crashes.

-geever

Offline Kthanid

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #2 on: August 06, 2011, 06:05:48 am »
Same problem.  Windows 7 64-bit crashes at tactical mission start every single time.  Geoscape and base management seemed fine.  Running version 2.3.1.  Not sure where to find my ufoconsole.log (I don't find that file in any of UFO AI's directories).

Offline Kthanid

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #3 on: August 06, 2011, 06:15:08 am »
My bad, here's the end of my ufoconsole.log contents... any good clues to anyone?

2011/08/05 23:00:03 ------- Loading game.dll -------
2011/08/05 23:00:03 not found at 'C:\Users\Kthanid\AppData\Roaming\UFOAI/2.3.1/base'
2011/08/05 23:00:03 found at './base'
2011/08/05 23:00:03 ==== InitGame ====
2011/08/05 23:00:04 SV_AssembleMap: Sequential map assembly in 0 ms
2011/08/05 23:00:04 CM_LoadMap: "-city/city +str_cross +strv_1a +strv_1a +strv_1a +strv_1a +str_cross +str_cross +strh_cwl_1a +strh_1a +strh_1a +strh_cwr_1a +bldl_4x4_2a +strh_cwl_1a +strh_1a +strh_1a +strh_cwr_1a +str_rail_cross +strv_rail_btm2a +craft_drop_firebird +str_rail_cross +strv_rail_btm2a +strv_rail_2a +strv_rail_2a +strv_rail_top2b +str_rail_cross +craft_ufo_harvester +strh_cwl_1a +strh_1a +strh_1a +strh_cwr_1a" "-32 -40 0 -32 -32 0 -32 -24 0 -32 -16 0 -32 -8 0 -32 0 0 -32 40 0 -24 -40 0 -16 -40 0 -8 -40 0 0 -40 0 -24 -32 0 -24 0 0 -16 0 0 -8 0 0 0 0 0 8 -40 0 8 -32 0 8 -24 0 8 0 0 8 8 0 8 16 0 8 24 0 8 32 0 8 40 0 -32 8 0 -24 40 0 -16 40 0 -8 40 0 0 40 0"
2011/08/05 23:00:04 Rerouted for RMA in   0.0s
2011/08/05 23:00:04 checksum for the map '+city': 1357047700
2011/08/05 23:00:05 ufo script checksum 2634771025
2011/08/05 23:00:05 Created AI player (team 0)
2011/08/05 23:00:05 Created AI player (team 7)
2011/08/05 23:00:05 -------------------------------------
2011/08/05 23:00:05 Connecting to localhost...
2011/08/05 23:00:05 connection attempt from loopback connection
2011/08/05 23:00:05 load material file: 'materials/city.mat'
2011/08/05 23:00:11 added light, ambient=0.390625
2011/08/05 23:00:12 Starting the game...
2011/08/05 23:00:12 Kthanid has joined team 1
2011/08/05 23:00:12 music change to PsymongO6 (from karlmacklin_geoscape)
2011/08/05 23:00:13 music change to MarineFireFight (from PsymongO6)
2011/08/05 23:00:15 (player 0) It's team 1's round
2011/08/05 23:00:15 Kthanid has taken control over team 1.
2011/08/05 23:00:16 ********************
2011/08/05 23:00:16 ERROR: Unknown model type in R_DrawEntities entity chain: 0
2011/08/05 23:00:16 ********************
2011/08/05 23:00:16 Shutdown server: Server crashed.
2011/08/05 23:00:16 ==== ShutdownGame ====
2011/08/05 23:00:16 music change to van_geoscape (from MarineFireFight)

Offline Kthanid

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #4 on: August 06, 2011, 06:20:26 am »
Seems this is already reported other times, assuming this is the same bug:  http://sourceforge.net/tracker/?func=detail&aid=3019699&group_id=157793&atid=805242.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #5 on: August 06, 2011, 10:46:43 am »
please retry with 2.4-dev and check whether this error still exists.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #6 on: August 06, 2011, 07:08:57 pm »
does this happen every time you try to load the map? only this map? any map? does it only happen after you performed some specific actions?

Offline Mikemc

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #7 on: August 27, 2011, 11:07:08 am »
Same bug here except this only happens when running Full Screen - Windowed shows no problems with crashing. My monitor is a Curtis 19" multimedia TV and my resolution in Windows 7 64-bit is 1360 x 768.

Offline stuguy909

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #8 on: October 15, 2011, 04:51:34 pm »
I have the same issue.  Windows 7 64bit with ATI Radeon 6800.  Game crashes immediately upon entry to tactical screen, whether it is campaign or skirmish, game crashes. 

Log:
http://www.mediafire.com/?yd82num2csi6g2o

:edit: full screen and windowed mode both crash.
:edit: doesn't matter which map.  any campaign map and any skirmish map causes a crash to Desktop.
« Last Edit: October 18, 2011, 10:29:19 am by stuguy909 »

Offline Lunknumb

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #9 on: November 03, 2011, 07:57:38 pm »
Same problem. Map loads, then boom:

ERROR: Unknown model type in R_DrawEntities entity chain: 0
Shutdown server: Server crashed.

Tried in fullscreen and windowed. Various video settings and resolutions between 1920x1200 and 1024x768 makes no impact.


Unable to reproduce in the latest build due to it locking up immediately after the loading screen with garbage on both the screen and audio until I kill the process.


2.3.1, crash on map: http://pastebin.com/6T2fCQCj
Latest build, startup crash:  http://pastebin.com/NKJ8c32L



« Last Edit: November 03, 2011, 08:13:34 pm by Lunknumb »

Offline Gryppen

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #10 on: November 08, 2011, 04:17:12 am »
Same, crashing on loading tact screen. running v2.3.1, of the 5 times I've loaded the map, it's crashed 3 times with the same ERROR: Unknown model type in R_DrawEntities entity chain: 0

ufoconsole.log

2011/11/08 14:01:53 ------- Loading game.dll -------
2011/11/08 14:01:53 not found at 'C:\Users\Mick\AppData\Roaming\UFOAI/2.3.1/base'
2011/11/08 14:01:53 found at './base'
2011/11/08 14:01:53 ==== InitGame ====
2011/11/08 14:01:53 checksum for the map 'pipes_const': 392839985
2011/11/08 14:01:53 ufo script checksum 2634771025
2011/11/08 14:01:53 Created AI player (team 0)
2011/11/08 14:01:53 Created AI player (team 7)
2011/11/08 14:01:53 -------------------------------------
2011/11/08 14:01:53 Connecting to localhost...
2011/11/08 14:01:53 connection attempt from loopback connection
2011/11/08 14:01:53 load material file: 'materials/pipes_const.mat'
2011/11/08 14:01:53 R_ParseStage: Inverted terrain ceiling and floor values for textures/tex_nature/dirt002
2011/11/08 14:01:54 added light, ambient=0.476837
2011/11/08 14:01:56 Starting the game...
2011/11/08 14:01:56 Mick has joined team 1
2011/11/08 14:01:56 music change to van_mission2 (from karlmacklin_geoscape)
2011/11/08 14:01:56 music change to MarineUrbanWarfare (from van_mission2)
2011/11/08 14:01:57 (player 0) It's team 1's round
2011/11/08 14:01:57 Mick has taken control over team 1.
2011/11/08 14:01:57 ********************
2011/11/08 14:01:57 ERROR: Unknown model type in R_DrawEntities entity chain: 0
2011/11/08 14:01:57 ********************
2011/11/08 14:01:57 Shutdown server: Server crashed.
2011/11/08 14:01:57 ==== ShutdownGame ====
2011/11/08 14:01:57 music change to karlmacklin_geoscape (from MarineUrbanWarfare)

Offline JackyJay

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #11 on: December 01, 2011, 12:18:45 am »
I have the same problem.

Is there any solution available?

Offline JackyJay

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #12 on: December 01, 2011, 01:21:23 pm »
It seems only to occur with in the Full screen mode or when I change the solution.

Offline Kine

  • Rookie
  • ***
  • Posts: 13
    • View Profile
Re: Win 7/64 Crashing after loading tactical screen.
« Reply #13 on: March 16, 2012, 01:47:04 am »
I got pumped up by the news of an XCOM94 remake by Firaxis/Sid Meier so redownloaded UFO:AI to get my juices flowing. A few hours into v2.3.1 however and I had half a dozen crashes. All from tactical layer. Geoscape and bases is fine just the 3D combat is causing me problems.

playing on my laptop with win7 64bit OS and the latest NVIDIA driver. Dont have the log file on here coz I deleted all the files after many reinstalls. But someone mentioned R_DrawEntities and I think I saw that in my logs.

Here's hoping a fix is forthcoming  :'(