project-navigation
Personal tools

Author Topic: UFOAI for Mac???  (Read 14466 times)

Offline Damonicos

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFOAI for Mac???
« Reply #15 on: February 18, 2011, 03:26:29 am »
I found a ufoconsole.log in my /users/username/documents/ufoai-w.4-dev/base
And attached it. Looks like sumthing to do with intro. tho turning the intro off hasnt done anything... =\ ya got me

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: UFOAI for Mac???
« Reply #16 on: February 18, 2011, 07:35:36 am »
change the cvar value from cl_introshown in your config.cfg from 0 to 1. 1 means that the intro.ogm is not played after game startup. and i suppose that our ogm implementation fails on your machine.

Offline Twenty-four

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: UFOAI for Mac???
« Reply #17 on: February 18, 2011, 11:12:17 am »
Now I know some more:
I hadn't had a config.cfg file in the 2.4 dev-version. I had one in the 2.3 version, but in the 2.4 dev-version, on the place where the config.cfg, the stats.log file etc. should be, there was only the ufoconsole.log. Perhaps that's the problem?

I thought myself clever and tried out if it worked with the config.cfg-file from 2.3 with the cl_introshown set to 1. This time, it was on the whole screen and not only in a window, but it crashed the same moment as always.

PS @ Damonicos: Spotlight is the search in your mac. In every Finder-window it's in the upper right corner and it's on the upper right corner of your screen (the magnifying glass).

Offline Damonicos

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFOAI for Mac???
« Reply #18 on: February 18, 2011, 07:42:58 pm »
lol confusing me, what is "cvar" ?
Im finding my Config.cfg in /Users/username/Documents/UFOAI-2.3/base
The Dev Folder (/Users/username/Documents/UFOAI-2.4-dev/base) only contains a ufoconsole.log (Thats it!)
I had cl_introshown set at 1 and it didnt work. I set it to 0 just for the heck of it but nothin happend. I'll try setting it to 1 again and see.

Offline Damonicos

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFOAI for Mac???
« Reply #19 on: February 18, 2011, 07:49:53 pm »
The line seems to have it's "Cvar" set to 1 as shown. No effect on loading.

set cl_introshown "1" a

btw , not sure this will help, but here is a ufoconsole.log for my game that IS "working", tho i think its a few versions back, and doesnt have sound.. Except on the Intro. Intro works great With sound.

@24 Ahhh ok thanks. hehe . Can u tell I havnt been a mac user for very long  :P
« Last Edit: February 18, 2011, 07:58:19 pm by Damonicos »

Offline Twenty-four

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: UFOAI for Mac???
« Reply #20 on: February 18, 2011, 08:26:37 pm »
lol confusing me, what is "cvar" ?
Im finding my Config.cfg in /Users/username/Documents/UFOAI-2.3/base
The Dev Folder (/Users/username/Documents/UFOAI-2.4-dev/base) only contains a ufoconsole.log (Thats it!)
I had cl_introshown set at 1 and it didnt work. I set it to 0 just for the heck of it but nothin happend. I'll try setting it to 1 again and see.


Yes, I have also a config.cfg file there, but I think that's only for 2.3, not for 2.4 dev-version. So it won't change anything if we change cvar in this file because this file is not the right one. Correct me if I'm wrong, but I think it should be like this. I'm only wondering where the config.cfg file for 2.4 dev-version is. Is there none? There should be one but I can't find it, in the folder UFOAI-2.4-dev/base, where it should probably be, is only the ufoconsole.log..

Offline Damonicos

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFOAI for Mac???
« Reply #21 on: February 18, 2011, 09:52:53 pm »
Yea your probably right 24 sounds right anyways. Im assuming the config in the 2.3 folder is being used but thats likely not the case.. where the other config.cfg file is or even if its there is unknown to me =\

Offline kilder

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: UFOAI for Mac???
« Reply #22 on: February 19, 2011, 10:33:49 am »
Good day, sirs!  8)

I have experienced the same problem as the above posters; it gives me exactly the same error —so it seems the cause it's pretty clear— but I also can't find the config.cfg file at all, even searching the invisible files... I'm thinking that the game doesn't create a config.cfg and that's what it says about it at the terminal:

Code: [Select]
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] Adding game dir: /Users/jose/Documents/UFOAI-2.4-dev/base
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] using /Users/~~/Documents/UFOAI-2.4-dev/base for writing
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] executing default.cfg
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] couldn't execute config.cfg
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] ----- network initialization -------
19/02/11 10:23:23 [0x0-0x1c01c].net.sourceforge.UFOAI[154] libcurl/7.21.1 OpenSSL/1.0.0a zlib/1.2.5 libidn/1.19 initialized.

I can provide the full report, if you desire, but it looks a lot like the other reports

So you could either give us foolproof instructions to tinker with default.cfg —which I also haven't found anywhere— or some step-by-step terminal magic, as we seem a bunch of clueless users :)

Thank you for your time; hope my comments are useful :)

Offline proffles

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: UFOAI for Mac???
« Reply #23 on: February 19, 2011, 03:01:00 pm »
Creating a config.cfg file in

   ~/Documents/UFOAI-2.4-dev/base

containing just the line

   set cl_introshown "1" a

Allows it to run fine (tested for about 10 secs) - ufoai will then create a proper config.cfg for you.

For the terminal averse, open textedit cut'n'paste "set cl_introshown "1" a" (without the surround quotes) into an empty file and save as "config.cfg" in your Documents/UFOAI-2.4-dev/base directory.  Terminal users almost certainly know how they can do this more simply.

Offline Twenty-four

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: UFOAI for Mac???
« Reply #24 on: February 19, 2011, 04:00:03 pm »
IT WORKS!
Thanks! Just starting a new campaign an enjoying the new features... ;) Just great!

Offline Damonicos

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: UFOAI for Mac???
« Reply #25 on: February 19, 2011, 04:32:46 pm »
I second that! U Sir, r a genius! Thanks a Bunch, im back in with sound and everything looks fantastic!

Offline dp

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Re: UFOAI for Mac???
« Reply #26 on: February 22, 2011, 11:05:24 pm »
FWIW, I visited http://ufoai.ninex.info/snapshots/ and downloaded ufoai-2.4-dev-macosx-universal.dmg. Although one might expect it to be a universal binary, when I tried to run it on my G4 (PPC) iMac USB 2.0, I immediately got "You can't open the application "UFOAI 2.4-dev.app" because it is not supported on this architecture."

Apparently, it's compiled for Intel only.

PS - OSX 10.5.8
« Last Edit: February 23, 2011, 04:14:58 am by dp »

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: UFOAI for Mac???
« Reply #27 on: February 23, 2011, 08:28:59 am »
Indeed. You are right. I didn't rename it. I don't have a build env for universals set up yet.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: UFOAI for Mac???
« Reply #28 on: March 05, 2011, 02:30:45 pm »
i'm just uploading a new dmg to the snapshots folder at http://ufoai.ninex.info/snapshots - it would be cool to get some feedback (see the intro related bug [cvar cl_introshown] in this thread)

Offline Sturmwind

  • Cannon Fodder
  • **
  • Posts: 1
    • View Profile
Re: UFOAI for Mac???
« Reply #29 on: March 15, 2011, 09:08:03 pm »
Hi!

I just downloaded the v2.4 installer on my first generation Intel iMac and this is the error message I get when I try to open the file:

"You can't open the application UFOAI because it is not supported on this type of Mac."

Any thoughts? What information do you need in addition to troubleshoot?

Thanks,

Martin