project-navigation
Personal tools

Author Topic: Problems with brush definition in blender and input in UFORadiant  (Read 21523 times)

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #45 on: February 26, 2011, 06:01:49 pm »
Guys, I am still stuck. I can compile with the 2.4 ufo2map or the 2.3 one but I cannot run in 2.3 and I can't run 2.4

When's 2.4 coming? :)

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #46 on: February 26, 2011, 06:07:27 pm »
What are the problems you're having? Is it with running your map or the whole game? See here for reporting errors.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #47 on: February 26, 2011, 06:10:24 pm »
i will try to compile ufo2map for you manually - so you can use the latest version from the snapshots directory.
« Last Edit: February 26, 2011, 06:12:35 pm by Mattn »

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #48 on: February 26, 2011, 11:42:02 pm »
here we go: http://mattn.ninex.info/files/ufo2map.exe (thanks BTAxis)

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #49 on: February 27, 2011, 08:24:59 am »
Thank Mattn, tried it, same phenomenon


Well, my problem look like this:
- I have a working release 2.3 installation
- I can use ufo2map 2.3 for making levels
- I cannot use 2.3 ufo2map with my tetrahedrons, as in this thread, mattn explained to me that he did some work on ufo2map (also on ufo?)
- I cannot run 2.4 dev (Item plasblade has invalid parameters) from the nightly releases (my last full download is a while back, about three weeks)
- can run 2.4 ufo2map but do not have console output which bothers me
- the maps I compile with 2.3 ufo2map or 2.4 ufo2map crash UFO2.3 for the below examples

I want to keep a playable release version as well as a dev version for trying out the tetrahedron stuff. Not possible? Problems with Windows APPDATA-Dir?


Edit: I just compiled the complex2.map with your new ufo2map (in the zip) and get the same old planenum>= 0 assertion failed in 2.3 (I cant test UFO2.4)
It seems I need to use the new ufo2map and the 2.4UFO, this is not working on my side right now.




Thanks for having a look,
Martin
« Last Edit: February 27, 2011, 08:31:59 am by mameister »

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #50 on: February 27, 2011, 09:46:30 am »
- can run 2.4 ufo2map but do not have console output which bothers me

I get this too, actually. It's not usually a problem though, just annoying that I can't get the usage help to print. Since I compiled this executable, it seems likely that my MinGW environment is somehow to blame. Maybe I should try getting rid of it and rebuilding it from scratch.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #51 on: February 27, 2011, 10:38:19 am »
complex2 compiles fine here: http://mattn.ninex.info/files/complex2.bsp.gz
complex3 does not - but it does not error out, but loop endless - i will check that

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #52 on: February 27, 2011, 10:42:31 am »
here is the bug tracker item for the problem with complex3: click me

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #53 on: February 27, 2011, 10:47:29 am »
btw. a big problem is still that the exporter does not create solid brushes, but hollows with surface brushes only. our pathfinding might not really like that.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #54 on: February 27, 2011, 04:45:27 pm »
http://mattn.ninex.info/files/complex2.jpg

the map has brushes > level 8 and there are some shadow artifacts (but that isn't your fault (resp the exporters fault) but an error in our renderer or mapcompiler)

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #55 on: February 27, 2011, 08:15:43 pm »
Wow, sorry for the level hickup! I just wrote a function that checks for all vertices to be in a height interval.

Surface brushes I switched to because of the following features not being representable with the "extruded" polys heightmap type:
- terrain overhangs/cliffs faces
- caves
- stalactites
- natural bridges


Thank you all for looking into this

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #56 on: February 27, 2011, 08:20:15 pm »
Just tried the level you compiled:
UFO2.3 simply quits, no error message, just complete crash when I try to load it