project-navigation
Personal tools

Author Topic: Problems with brush definition in blender and input in UFORadiant  (Read 20310 times)

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #30 on: February 12, 2011, 08:14:52 am »
i will try to find the reason. a quick guess could be floating point issues - due to your rather complex geometry.

edit
it looks like there are too many planes and the unsigned short is overflowing
« Last Edit: February 12, 2011, 08:26:53 am by Mattn »

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #31 on: February 12, 2011, 09:18:58 am »
try to not make the terrain as hollow - but as full brushes from ground (level1) to surface - your brushes are too small in some cases, resulting in so-called microbrushes.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #32 on: February 12, 2011, 09:36:13 am »
i've patched ufo2map a little bit to error out on compilation already.

removing some part of the map at least allowed me to compile it: http://mattn.ninex.info/screenshots/bigmap.jpg

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #33 on: February 12, 2011, 10:22:47 am »
now i found the bug - it was in the map loading, it isn't on your side. the fix is coming in a few minutes.
« Last Edit: February 12, 2011, 10:27:00 am by Mattn »

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #34 on: February 12, 2011, 12:03:53 pm »
Nice

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #35 on: February 12, 2011, 01:11:48 pm »
Wow !  :)

This looks impressive. Great to see your motivation, mameister !

I am excited to try out first maps built with this new technique !

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #36 on: February 12, 2011, 01:53:25 pm »
Hi guys,

thanks for having a look into this, Mattn! I will provide the tetra-converter (with height level separation) soonish in this place,

Martin

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #37 on: February 13, 2011, 08:19:26 am »
@Mattn:
just to understand you correctly: did you have the time to fix the bug and how can I get it to run at my place?
Do I need a git checkout + compile myself or has someone prepared a "pre-2.4" binary already?

cheers, Martin

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #38 on: February 13, 2011, 10:59:11 am »
you have several options:
  • download the night installer
  • checkout the git repo and download the nightly binaries (no ide and so on is needed - but you will always have access to the latest fixes and data)

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #39 on: February 13, 2011, 11:34:15 am »
mameister, please check out latest master & join the team, so you can work on the latest version of things  ;)

I think your input would be highly welcomed & I am sure your past work justifies enabling write access 4 u.

Here you can find detailed instructions on how to get up-to-date: http://ufoai.ninex.info/wiki/index.php/Getting_the_source

You can also join the IRC channel (#ufoai, irc://irc.freenode.org/ufoai) if you have questions or want to join discussions.
Here you can find the logs: http://colabti.org/irclogger/irclogger_logs/ufoai

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #40 on: February 13, 2011, 02:14:21 pm »
Hi guys,
thanks - right now I am really busy with the harbour map and the tetrahedrons :)
So its ok if I am oinly a geometry/mapping guy at the moment, let me finish those open ends first.

Then I will proceed with a wiki page to show how terrain can be made with Blender (either prisms or tetras with explanation what the difference is) and maybe I could be convinced to hack it into UFORadiant :)

But that's some weeks off ...


cheers for the nightly build hints, will check this out

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #41 on: February 13, 2011, 11:56:23 pm »
@Mattn
Downloaded "latest" but have problems since: ufo2map is started but without any console output it dissappears in the background. oes not return either. De-installed everything, downloaded the 800 Meg installer, still same phenomenon.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #42 on: February 14, 2011, 06:26:37 am »
that isn't your fault. does ufomodel.exe opens a console for you?

Offline mameister

  • Rookie
  • ***
  • Posts: 71
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #43 on: February 14, 2011, 06:27:41 pm »
No, it does not. ALso, when running ufo, it says (and aborts): "Item plasblade has invalid parameters"

I don't know what to do and will probably go back to 2.3 (.1?)
No idea what I should to to get this dev-version stable (Windows 7 , 64bits, Intel)

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Problems with brush definition in blender and input in UFORadiant
« Reply #44 on: February 14, 2011, 09:41:13 pm »
Here the latest git master version works on Windoze, so  ???

You could try this 2.4dev version from December: http://ufoai.ninex.info/forum/index.php?topic=2830.msg45575#msg45575

, but still I would encourage you to checkout latest master version to more easily stay up-to-date & on the cutting (& sometimes bleeding  ;)) edge of development in the future...