project-navigation
Personal tools

Author Topic: cant start UFO:AI  (Read 11622 times)

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
cant start UFO:AI
« on: January 28, 2011, 02:11:51 pm »
Hallo @all,

I can't start UFO.
Ofcourse I searched in the Forum but no solution was found :(
If I try to run the Program an error occurrs.
(btw the driver vor my GPU is the latest Version)
PLEASE can somebody help me.

Love the game!!! ;)

UFO:AI Console:

---- filesystem initialization -----
Adding game dir: ./base
Added packfile ./base/0base.pk3 (9 files)
Added packfile ./base/0maps.pk3 (544 files)
Added packfile ./base/0materials.pk3 (45 files)
Added packfile ./base/0media.pk3 (10 files)
Added packfile ./base/0models.pk3 (2015 files)
Added packfile ./base/0music.pk3 (49 files)
Added packfile ./base/0pics.pk3 (2114 files)
Added packfile ./base/0shaders.pk3 (26 files)
Added packfile ./base/0snd.pk3 (266 files)
Added packfile ./base/0ufos.pk3 (97 files)
Adding game dir: C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base
using C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base for writing
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.16.4 zlib/1.2.2 initialized.

------ server initialization -------
added 7 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.14
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1280x1024 1280x960 1280x768 1152x864 1024x768 800x600 640x480 640x400 512x384 400x300 320x240 320x200 (12)
I: video driver: windib
I: setting mode -1
I: set swap control to 0
I: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 16 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 1 multisample buffers
GL_VENDOR: Microsoft Corporation
GL_RENDERER: GDI Generic
GL_VERSION: 1.1.0
GL_EXTENSIONS: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
No hardware acceleration detected.
Update your graphic card drivers.
FS_RemoveFile: remove C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base/keys.cfg

Shutdown

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: cant start UFO:AI
« Reply #1 on: January 28, 2011, 02:14:58 pm »
Ofcourse I searched in the Forum but no solution was found :(
If I try to run the Program an error occurrs.
(btw the driver vor my GPU is the latest Version)

GL_VENDOR: Microsoft Corporation
GL_RENDERER: GDI Generic
GL_VERSION: 1.1.0

^ You have a Microsoft videocard? I didn't know there is any. ;)

-geever

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: cant start UFO:AI
« Reply #2 on: January 28, 2011, 02:20:45 pm »
I have a GPU: RADEON 9600.
I think it should be able to run UFO:AI
Am I wrong?
Sorry I do not know much about GPU and Grafik stuff :/

Thank you for your reply!!!

Offline bayo

  • Professional loser
  • Project Coder
  • Captain
  • ***
  • Posts: 733
    • View Profile
Re: cant start UFO:AI
« Reply #3 on: January 28, 2011, 03:02:36 pm »
It mean it is a software renderer.
You must install a driver for your card, and it must contain an opengl driver.

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: cant start UFO:AI
« Reply #4 on: January 28, 2011, 03:44:37 pm »
I already have instaled the latest version of the GPU driver.

Windows can not find a later version than instaled :/

So I do not know what to do. -.-

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: cant start UFO:AI
« Reply #5 on: January 28, 2011, 03:54:01 pm »
I already have instaled the latest version of the GPU driver.
Windows can not find a later version than instaled :/

So I do not know what to do. -.-

Don't use Microsoft's driver but the one from ATi:
http://support.amd.com/us/gpudownload/Pages/index.aspx

-geever

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: cant start UFO:AI
« Reply #6 on: January 29, 2011, 01:35:05 pm »
First THANKS!

Your Link takes me to this page:
http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=English

If I try to install the driver Windows tells me to stop(driver is NOT Windows compatibel)  ???

No Problem I searcht for the latest version:
http://www.chip.de/downloads/ATI-Catalyst-Suite-fuer-XP-32-Bit_13006507.html

I installed it. No trubel.

But UFO:AI still does not work  :'(


---- filesystem initialization -----
Adding game dir: ./base
Added packfile ./base/0base.pk3 (9 files)
Added packfile ./base/0maps.pk3 (544 files)
Added packfile ./base/0materials.pk3 (45 files)
Added packfile ./base/0media.pk3 (10 files)
Added packfile ./base/0models.pk3 (2015 files)
Added packfile ./base/0music.pk3 (49 files)
Added packfile ./base/0pics.pk3 (2114 files)
Added packfile ./base/0shaders.pk3 (26 files)
Added packfile ./base/0snd.pk3 (266 files)
Added packfile ./base/0ufos.pk3 (97 files)
Adding game dir: C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base
using C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base for writing
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.16.4 zlib/1.2.2 initialized.

------ server initialization -------
added 7 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.14
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1280x1024 1024x768 800x600 640x480 (4)
I: video driver: windib
I: setting mode -1
I: set swap control to 0
I: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 16 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 1 multisample buffers
GL_VENDOR: Microsoft Corporation
GL_RENDERER: GDI Generic
GL_VERSION: 1.1.0
GL_EXTENSIONS: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
No hardware acceleration detected.
Update your graphic card drivers.
FS_RemoveFile: remove C:\Dokumente und Einstellungen\Mo\Anwendungsdaten\UFOAI/2.3.1/base/keys.cfg

Shutdown


Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: cant start UFO:AI
« Reply #7 on: January 29, 2011, 01:48:47 pm »
GL_VENDOR: Microsoft Corporation
GL_RENDERER: GDI Generic
GL_VERSION: 1.1.0
GL_EXTENSIONS: GL_WIN_swap_hint GL_EXT_bgra GL_EXT_paletted_texture
No hardware acceleration detected.
Update your graphic card drivers.

still not the real amd drivers. maybe they have an option for this in the control panel of the driver - i don't know. i heard about nvidia game profiles - maybe amd has the same.

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: cant start UFO:AI
« Reply #8 on: January 29, 2011, 03:46:52 pm »
Again Thanks for your reply!  :)

Now I have installed the Version 10.2
( http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_xp.aspx?type=2.4.1&product=2.4.1.3.13&lang=German )

and WONDERFULL the Game starts!  8)

But my happy fellings were very short cause after I had chosen a Kampain Game.
I couldend see were I put my base  ???

I builded a Base. But I can not see the earth still.

Can somebody help me?

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: cant start UFO:AI
« Reply #9 on: January 29, 2011, 04:43:44 pm »
I couldend see were I put my base  ???
I builded a Base. But I can not see the earth still.
Can somebody help me?

A screenshot could help. Anyway you can try disabling GLSL shaders in video options menu.

-geever

Offline CHRi$

  • Cannon Fodder
  • **
  • Posts: 7
    • View Profile
Re: cant start UFO:AI
« Reply #10 on: January 29, 2011, 05:02:33 pm »
THANK YOU!

Now I can defend the earth!  8)

Offline xcom fan

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: cant start UFO:AI
« Reply #11 on: February 09, 2011, 12:28:34 am »
Hello! I can't start the ufoai. :( What the minimal system required this program? What servis pack need? This information not founded nowere. :(  I'm using windows xp. Somebodi help me please. Thanks.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: cant start UFO:AI
« Reply #12 on: February 09, 2011, 08:46:05 am »
Hello! I can't start the ufoai. :( What the minimal system required this program? What servis pack need? This information not founded nowere. :(  I'm using windows xp. Somebodi help me please. Thanks.

Ufoconsole.log can say more info about the problem at you. But if the game starts then immediately shuts down it's most probably incompatible videocard driver. Make sure you are using the drivers from your vendor (Forceware in case of NVidia, Catalyst in case of ATI/AMD), the default driver which is in Windows doesn't provide the OpenGL support we need.

-geever

Offline xcom fan

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: cant start UFO:AI
« Reply #13 on: February 09, 2011, 09:32:40 pm »
Ufoconsole.log can say more info about the problem at you. But if the game starts then immediately shuts down it's most probably incompatible videocard driver. Make sure you are using the drivers from your vendor (Forceware in case of NVidia, Catalyst in case of ATI/AMD), the default driver which is in Windows doesn't provide the OpenGL support we need.

-geever
My system is: intel celeron cpu e1400, 2 Ghz, 1 GB ram, graphick card: ATI radeon x1600 pro 256 MB gddr2 memory. this card and driver not problem. this game not first time installed my machine. I'm install first time on AMD processored machine and this graphick card,this driver and game is run good. The older motherboard is dead. :( I must changed, my machine go to BUTCHER, he formated my c particion, and lost evrything. I'm reinstall my older system changed something, the graphick card and graphic driver not changed. My xp version: professional 2002 with servicepack 2. After consol end, the game is crashed. If not started with short cut consol run, the monitor is black, game crashed and sand error message. Here ufo ai consol and error message.   

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: cant start UFO:AI
« Reply #14 on: February 09, 2011, 09:56:38 pm »
My system is: intel celeron cpu e1400, 2 Ghz, 1 GB ram, graphick card: ATI radeon x1600 pro 256 MB gddr2 memory. this card and driver not problem. this game not first time installed my machine. I'm install first time on AMD processored machine and this graphick card,this driver and game is run good. The older motherboard is dead. :( I must changed, my machine go to BUTCHER, he formated my c particion, and lost evrything. I'm reinstall my older system changed something, the graphick card and graphic driver not changed. My xp version: professional 2002 with servicepack 2. After consol end, the game is crashed. If not started with short cut consol run, the monitor is black, game crashed and sand error message. Here ufo ai consol and error message.   

Could you please upload the whole ufoconsole.log file to pastebin?

-geever