project-navigation
Personal tools

Author Topic: X server crash in tactical missions  (Read 1372 times)

Offline EOF

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
X server crash in tactical missions
« on: December 14, 2010, 07:06:11 pm »
Hello,

each time I start a tactical mission, my x server crashes within seconds.

I am trying to run UFO:AI with a laptop running Ubuntu 10.04 and an intel graphics card; lspci says
Code: [Select]
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
According to glxinfo, direct rendering is on:
Code: [Select]
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 965GM GEM 20091221 2009Q4

My UFO:AI version is 2.4-dev, with the hash of the latest commit being
9f4e83406a958fce1d101ccde90fb02e0043a33f
if that helps.

The ufo log file I attached looks quite innocuous to me, but I also get the following error message in my Xorg.0.log:
Code: [Select]
Fatal server error:
Failed to submit batchbuffer: Input/output error


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Does someone have any suggestions? Thanks in advance.

Offline bayo

  • Professional loser
  • Project Coder
  • Captain
  • ***
  • Posts: 733
    • View Profile
Re: X server crash in tactical missions
« Reply #1 on: December 14, 2010, 08:32:47 pm »
If your driver crash, i dont think we can do anything. Maybe u can test another driver. Or disable shader or thing like that...
 

Offline EOF

  • Cannon Fodder
  • **
  • Posts: 2
    • View Profile
Re: X server crash in tactical missions
« Reply #2 on: December 16, 2010, 06:17:28 pm »
Thanks a lot, disabling shaders did indeed help.

Offline nick87720z

  • Rookie
  • ***
  • Posts: 38
    • View Profile
Re: X server crash in tactical missions
« Reply #3 on: February 09, 2019, 02:39:08 pm »
Similar crash, but with different conditions, with 2.6-dev.
Exact error seems to be localized to russian:
i965: Failed to submit batchbuffer: ?????? ?????/??????
What i can understand as input/output error.

I believed long time it is driver bug unless found intereting statement:
https://www.reddit.com/r/opengl/comments/89twa8/how_to_work_around_graphics_driver_bugs_i965/
Quote
NVidia tends to have the most forgiving drivers, in my experience. AMD has less forgiving drivers. Intel can be downright cruel at times.

On my system it happens after longer time. I have no exact idea of reproducing - last time i played "village" map on very hard, starting game right from point when firebird headed to mission. I made 2 or 3 restarts due to some mistakes, at last managed to eliminate 2/4 enemies and find 3rd in far house, when i got killing freeze - i had another one on same attempt, but it did not crash, probably because i unintentionaly moved camera, because after unlock camera where in one of map corners.

Just before very hard gameplay (my first attempt... btw, whatever they say - unwounded soldier survives single plasma pistol hit even on v-hard) i made standard, trying new for me play order at geoscape, and sometimes i had several tactical missions before crash.
« Last Edit: February 09, 2019, 02:53:17 pm by nick87720z »