project-navigation
Personal tools

Author Topic: Help. Ufoai 2.3 crashes after initial screen  (Read 6319 times)

Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Help. Ufoai 2.3 crashes after initial screen
« on: October 01, 2010, 01:21:36 am »
Ufoai 2.3 on Ubuntu 10.04 crashes immediately after initial screen. My video card is ATIXpress 200M
Console log says this:


2010/10/01 02:16:23 ----- network initialization -------
2010/10/01 02:16:23 libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15 initialized.
2010/10/01 02:16:23 ------ server initialization -------
2010/10/01 02:16:23 added 7 maps to the mapcycle
2010/10/01 02:16:23 ----- console initialization -------
2010/10/01 02:16:23 Console initialized.
2010/10/01 02:16:23 ------- video initialization -------
2010/10/01 02:16:24 SDL version: 1.2.14
2010/10/01 02:16:24 I: desktop depth: 32bpp
2010/10/01 02:16:24 I: video memory: 0
2010/10/01 02:16:24 I: Available resolutions: 1280x800 1280x720 1152x768 1024x768 848x480 800x600 720x480 640x480 (8)
2010/10/01 02:16:24 I: video driver: x11
2010/10/01 02:16:24 I: setting mode -1
2010/10/01 02:16:24 I: set swap control to 0
2010/10/01 02:16:25 I: 1024x768 (fullscreen: no)
2010/10/01 02:16:25 I: got 8 bits of stencil
2010/10/01 02:16:25 I: got 24 bits of depth buffer
2010/10/01 02:16:25 I: got double buffer
2010/10/01 02:16:25 I: got 8 bits for red
2010/10/01 02:16:25 I: got 8 bits for green
2010/10/01 02:16:25 I: got 8 bits for blue
2010/10/01 02:16:25 I: got 0 bits for alpha
2010/10/01 02:16:25 I: got 0 multisample buffers
GL_VENDOR: DRI R300 Project2010/10/01 02:16:25 GL_RENDERER: Mesa DRI R300 (RS400 5955) 20090101 x86/MMX+/3DNow!+/SSE2 NO-TCL DRI22010/10/01 02:16:25 GL_VERSION: 1.5 Mesa 7.7.12010/10/01 02:16:25 GL_EXTENSIONS: GL_EXT_compiled_vertex_array GL_EXT_texture_env_add GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_provoking_vertex GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays2010/10/01 02:16:25 2010/10/01 02:16:25 using GL_ARB_framebuffer_object
2010/10/01 02:16:25 max draw buffers: 1
2010/10/01 02:16:25 max render buffer size: 4096
2010/10/01 02:16:25 max color attachments: 8
2010/10/01 02:16:25 Invalid value for cvar r_programs
2010/10/01 02:16:25 Invalid value for cvar r_postprocess
2010/10/01 02:16:25 max supported lights: 8
2010/10/01 02:16:25 max texture units: 8
2010/10/01 02:16:25 max texture coords: 8
2010/10/01 02:16:25 max vertex attributes: 16
2010/10/01 02:16:25 max texture size: detected 2048
2010/10/01 02:16:25 Using low resolution globe textures as requested.
2010/10/01 02:16:25 not using GLSL shaders
2010/10/01 02:16:25 SDL_image version 1.2.10
  2010/10/01 02:16:31 SDL_ttf version 2.0.9 - we need at least 2.0.7
2010/10/01 02:16:31 ------- sound initialization -------
2010/10/01 02:16:31 SDL_mixer version: 1.2.8
2010/10/01 02:16:31 ... requested audio rate: 44100
2010/10/01 02:16:31 ... driver: 'pulse'
2010/10/01 02:16:31 ... audio rate: 44100
2010/10/01 02:16:31 ... audio channels: 2
2010/10/01 02:16:31 Modified render related cvars
2010/10/01 02:16:31 not using GLSL shaders
2010/10/01 02:16:31 ------- input initialization -------
2010/10/01 02:16:31 0 possible joysticks
2010/10/01 02:16:31 no joystick found.
2010/10/01 02:16:31 ----------- parse scripts ----------
2010/10/01 02:16:31 50 script files
2010/10/01 02:16:32 47 ui script files
2010/10/01 02:16:38 Shared Client/Server Info loaded
2010/10/01 02:16:38 ... 99 items parsed
2010/10/01 02:16:38 ... 32 damage types parsed
2010/10/01 02:16:38 ... 80 map definitions parsed
2010/10/01 02:16:38 ... 29 equipment definitions parsed
2010/10/01 02:16:38 ... 10 inventory definitions parsed
2010/10/01 02:16:38 ... 20 team definitions parsed
2010/10/01 02:16:38 executing keys.cfg
2010/10/01 02:16:38 music change to van_theme (from PsymongN3)
2010/10/01 02:16:38 s_language has no value
2010/10/01 02:17:35 Could not find locale with id ''
2010/10/01 02:17:37 134 static models loaded
2010/10/01 02:17:39 ====== UFO Initialized ======
2010/10/01 02:17:39 =============================
2010/10/01 02:17:40 Could not find cinematic 'videos/intro'
2010/10/01 02:17:40 Switch grab input off

Thank you for your help!
 

Offline romanovzky

  • Rookie
  • ***
  • Posts: 23
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #1 on: October 01, 2010, 01:25:43 am »
How did you installed it?

Playdeb or SVN?

Edit
Do you have 3d acceleration in your machine? Type (in terminal)

Code: [Select]
glxinfo | grep render
It should show something like this

Code: [Select]
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 (RV515 7145) 20090101 x86/MMX/SSE2 TCL DRI2
[/s]
Wrote too soon, I can see from your log that that isn't the problem.

As long as I can guess (not dev...) you seem to lack SDL_ttf at least 2.0.7 (as far as I know it is a font something that the interface uses) see if you have the libsdl-ttf2.0-0 package installed (it is in ubuntu repo's, at least in mine...).


« Last Edit: October 01, 2010, 01:32:33 am by romanovzky »

Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #2 on: October 01, 2010, 07:41:26 am »
I looked up and I have the libsdl-ttf2.0-0 package installed. The game was installed via playdeb, but at the end of the installing process I got an error message that said something like ufoai server could not be installed.
Thanx for replying and for your help.

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #3 on: October 01, 2010, 07:45:37 am »
sdl_ttf 2.0.9 is installed (according to the logs)

what we need is a backtrace. i hope the getdeb build contains debug symbols. let's find out:
* open a terminal
* cd /path/to/ufoai/binary/not/shell/script
* gdb ufo
* run +set vid_fullscreen 0

once it crashed type:
* bt full
and post that output here.

Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #4 on: October 01, 2010, 12:19:02 pm »
I've tried the commands you've write me about, but they are not working: laptop:~$ bt full
bt: command not found; probably it's me (I'm not a linux genius as u can see)
I've started the game from terminal although. Here is the output:

 
noi@noi-laptop:~$ /usr/games/ufo

---- filesystem initialization -----
Adding game dir: /usr/share/games/ufoai/base
Added packfile /usr/share/games/ufoai/base/0base.pk3 (9 files)
Added packfile /usr/share/games/ufoai/base/0maps.pk3 (535 files)
Added packfile /usr/share/games/ufoai/base/0materials.pk3 (45 files)
Added packfile /usr/share/games/ufoai/base/0media.pk3 (10 files)
Added packfile /usr/share/games/ufoai/base/0models.pk3 (2015 files)
Added packfile /usr/share/games/ufoai/base/0music.pk3 (49 files)
Added packfile /usr/share/games/ufoai/base/0pics.pk3 (2114 files)
Added packfile /usr/share/games/ufoai/base/0shaders.pk3 (26 files)
Added packfile /usr/share/games/ufoai/base/0snd.pk3 (266 files)
Added packfile /usr/share/games/ufoai/base/0ufos.pk3 (97 files)
Adding game dir: ./base
Added packfile ./base/0base.pk3 (9 files)
Added packfile ./base/0maps.pk3 (535 files)
Added packfile ./base/0materials.pk3 (45 files)
Added packfile ./base/0media.pk3 (10 files)
Added packfile ./base/0models.pk3 (2015 files)
Added packfile ./base/0music.pk3 (49 files)
Added packfile ./base/0pics.pk3 (2114 files)
Added packfile ./base/0shaders.pk3 (26 files)
Added packfile ./base/0snd.pk3 (266 files)
Added packfile ./base/0ufos.pk3 (97 files)
Adding game dir: /home/noi/.ufoai/2.3/base
using /home/noi/.ufoai/2.3/base for writing
executing default.cfg
executing config.cfg

----- network initialization -------
libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15 initialized.

------ server initialization -------
added 7 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.14
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1280x800 1280x720 1152x768 1024x768 848x480 800x600 720x480 640x480 (8)
I: video driver: x11
I: setting mode -1
I: set swap control to 0
I: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 0 multisample buffers
GL_VENDOR: DRI R300 Project
GL_RENDERER: Mesa DRI R300 (RS400 5955) 20090101 x86/MMX+/3DNow!+/SSE2 NO-TCL DRI2
GL_VERSION: 1.5 Mesa 7.7.1
GL_EXTENSIONS: GL_EXT_compiled_vertex_array GL_EXT_texture_env_add GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_provoking_vertex GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_MESAX_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_APPLE_packed_pixels GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
using GL_ARB_framebuffer_object
max draw buffers: 1
max render buffer size: 4096
max color attachments: 8
max supported lights: 8
max texture units: 8
max texture coords: 8
max vertex attributes: 16
max texture size: detected 2048
Using low resolution globe textures as requested.
not using GLSL shaders
SDL_image version 1.2.10
SDL_ttf version 2.0.9 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.8
... requested audio rate: 44100
... driver: 'pulse'
... audio rate: 44100
... audio channels: 2
Modified render related cvars
not using GLSL shaders

------- input initialization -------
0 possible joysticks
no joystick found.

----------- parse scripts ----------
50 script files
47 ui script files
Shared Client/Server Info loaded
... 99 items parsed
... 32 damage types parsed
... 80 map definitions parsed
... 29 equipment definitions parsed
... 10 inventory definitions parsed
... 20 team definitions parsed
executing keys.cfg
music change to van_theme (from PsymongN3)
CL_LanguageInit: language settings are stored in configuration: en
...using language: en_ZW.utf8
SDL_ttf version 2.0.9 - we need at least 2.0.7
...registering 10 fonts
134 static models loaded
====== UFO Initialized ======
=============================
Switch grab input off
Change gametype to 'Campaign mode'

--- save subsystem initialization --
added base subsystem
added research subsystem
added campaign subsystem
added hospital subsystem
added market subsystem
added employee subsystem
added aliencont subsystem
added aircraft subsystem
added installation subsystem
added ufostores subsystem
added production subsystem
added messagesystem subsystem
added stats subsystem
added nations subsystem
added transfer subsystem
added alien base subsystem
added xvirate subsystem
added messageoptions subsystem
Campaign data loaded - size 4458784 bytes
...techs: 190
...buildings: 19
...ranks: 16
...nations: 8
...cities: 457

Sanity check for script data
...buildings ok
...tech ok
...aircraft ok
...items ok
...items ok
...... city 'ankara' can't be used in game: it has no map fitting parameters
      (No map fitting craft_ufo_harvester)
      (Terrain: mountain, Culture: oriental, Population: village)
...... city 'dushanbe' can't be used in game: it has no map fitting parameters
      (No map fitting craft_ufo_harvester)
      (Terrain: mountain, Culture: oriental, Population: suburban)
...... city 'konya' can't be used in game: it has no map fitting parameters
      (No map fitting craft_ufo_harvester)
      (Terrain: mountain, Culture: oriental, Population: village)
...... city 'mashhad' can't be used in game: it has no map fitting parameters
      (No map fitting craft_ufo_harvester)
      (Terrain: mountain, Culture: oriental, Population: village)
...... city 'tehran' can't be used in game: it has no map fitting parameters
      (No map fitting craft_ufo_harvester)
      (Terrain: mountain, Culture: oriental, Population: village)
...nations failed
music change to van_geoscape (from van_theme)
drmRadeonCmdBuffer: -12. Kernel failed to parse or rejected command stream. See dmesg for more info.

And dmesg says:

[drm] radeon defaulting to kernel modesetting.
[   22.619721] [drm] radeon kernel modesetting enabled.
[   22.619813] radeon 0000:01:05.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   22.625344] [drm] radeon: Initializing kernel modesetting.
[   22.625430] [drm] register mmio base: 0xC0100000
[   22.625433] [drm] register mmio size: 65536
[   22.625829] [drm] GPU reset succeed (RBBM_STATUS=0x00000140)
[   22.625849] [drm:rs400_gart_adjust_size] *ERROR* Forcing to 32M GART size (because of ASIC bug ?)
[   22.625899] [drm] Generation 2 PCI interface, using max accessible memory
[   22.625901] [drm] radeon: VRAM 128M
[   22.625903] [drm] radeon: VRAM from 0x18000000 to 0x1FFFFFFF
[   22.625905] [drm] radeon: GTT 32M
[   22.625907] [drm] radeon: GTT from 0x20000000 to 0x21FFFFFF
[   22.625946] [drm] radeon: irq initialized.
[   22.626065] [drm] Detected VRAM RAM=128M, BAR=128M
[   22.626071] [drm] RAM width 128bits DDR
[   22.626177] [TTM] Zone  kernel: Available graphics memory: 189252 kiB.
[   22.626199] [drm] radeon: 128M of VRAM memory ready
[   22.626202] [drm] radeon: 32M of GTT memory ready.
[   22.626226] [drm] GART: num cpu pages 8192, num gpu pages 8192
[   22.626759] [drm] radeon: 3 quad pipes, 1 z pipes initialized.
[   22.626773] [drm] radeon: cp idle (0x10000C03)
[   22.626823] [drm] Loading R300 Microcode
[   22.626829] platform radeon_cp.0: firmware: requesting radeon/R300_cp.bin



Offline Cyber Killer

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #5 on: October 01, 2010, 12:46:59 pm »
My guess: it's the driver.

Your GPU is ATIXpress 200M, which is basically Radeon X300 and as such uses the free/open radeon driver, which is good enough for desktop effects, but IMO is still not ready for games.

Since you can't use any other driver (fglrx requires currently at least Radeon HD2000 series), I would recommend getting some new hardware. Or wait till the new ubuntu release (which should be sometime next month), maybe a new driver version will help.
« Last Edit: October 01, 2010, 12:49:53 pm by Cyber Killer »

Offline romanovzky

  • Rookie
  • ***
  • Posts: 23
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #6 on: October 01, 2010, 06:16:17 pm »
It's a laptop, hard to upgrade the hardware :P

Well, try with compiz off.

How is your performance (type glxgears in command line and tell us the frames it shows)?

Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #7 on: October 01, 2010, 08:06:01 pm »
that's true: it is a laptop ;D
glxgears shows:

1744 frames in 5.0 seconds
1775 frames in 5.0 seconds
1698 frames in 5.0 seconds
1633 frames in 5.0 seconds
1541 frames in 5.0 seconds
1531 frames in 5.0 seconds
1487 frames in 5.0 seconds
1480 frames in 5.0 seconds
1552 frames in 5.0 seconds
1495 frames in 5.0 seconds
1622 frames in 5.0 seconds

Anyway thanks for your suggestions

Offline romanovzky

  • Rookie
  • ***
  • Posts: 23
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #8 on: October 02, 2010, 01:26:32 am »
Well, I've worse than that in my eeepc and it runs, have you tried with desktop effects off?

Offline romanovzky

  • Rookie
  • ***
  • Posts: 23
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #9 on: October 02, 2010, 02:00:26 am »
And reinstall it, playdeb updated the version in theier repo.

Offline Cyber Killer

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #10 on: October 02, 2010, 12:44:22 pm »
Well, I've worse than that in my eeepc and it runs, have you tried with desktop effects off?

You miss the point :-). This is not about the card performance.

In eee you got Intel GMAwhatever, with full opengl support.

totdragos has an old Ati GPU that's unable to use the properietary driver (Ati/AMD dropped support for every card older than HD2xxx some time ago), that's why he's using the open source radeon driver, which AFAIK doesn't support opengl to its full.

If totdragos would downgrade his xorg and kernel (not a good option) to the last version that's able to use fglrx I recon UFO would run fine.

Possible solutions: get new laptop (duh ;-P ) or wait for the next ubuntu release (10 oct), which will have a newer version of the radeon driver that maybe will have better opengl support.

Yes, I agree Ati showed it's users the middle finger by dropping support for older cards, but the new Radeons are just great (I got HD3850) ;-). Note the performance and compatibility of the open source drivers will get better with time (in 2D it's already better than the properietary).

Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #11 on: October 02, 2010, 10:53:34 pm »
I've installed Ubuntu 8.04. So far so good, meaning I've managed to get the ati driver
Now the glx gears shows, with visual effects set to high:

3655 frames in 5.0 seconds = 730.892 FPS
3714 frames in 5.0 seconds = 742.717 FPS
3715 frames in 5.0 seconds = 742.906 FPS
3715 frames in 5.0 seconds = 742.824 FPS
3715 frames in 5.0 seconds = 742.847 FPS
3710 frames in 5.0 seconds = 741.818 FPS


Offline totdragos

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #12 on: October 03, 2010, 10:34:43 am »
Last night I've installed ufoai 2.2.1 It runs fine, but it doesn't have skirmish mode, and I also was wondering if possible to install the 2.3 version on hardy?
Anyway, after reading your suggestions the most applicable in order to play ufoai was hardy 8.04 installation
Thanks again for your advices

Offline Cyber Killer

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Help. Ufoai 2.3 crashes after initial screen
« Reply #13 on: October 04, 2010, 08:16:50 am »
It is possible, but you'd probably have to compile it yourself + probably have to compile some of the libraries that need newer versions too. It's a bit of extra work, but it should be possible.