project-navigation
Personal tools

Author Topic: ATI rendering oddities  (Read 2195 times)

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
ATI rendering oddities
« on: November 19, 2010, 05:38:52 pm »
Some screenshots showing effects and current settings for the ATI rendering problems

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: ATI rendering oddities
« Reply #1 on: November 19, 2010, 05:42:26 pm »
with max dynamic lights set to 4 you should see a shader error log in ufoconsole.log. i suppose a limit is reached there. please also attach the ufoconsole.log

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: ATI rendering oddities
« Reply #2 on: November 19, 2010, 05:45:06 pm »
the first screenshot also shows black models for every model out there, no? please try to reduce the max dyn. lights to 2

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: ATI rendering oddities
« Reply #3 on: November 19, 2010, 05:50:32 pm »
2 max lights, no multisample buffer:

- Black models
- No glowmap on brushes or models
- Lines on material blends

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: ATI rendering oddities
« Reply #4 on: November 19, 2010, 08:11:09 pm »
is this the ufoconsole.log from the max lights 2 or 4?

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: ATI rendering oddities
« Reply #5 on: November 19, 2010, 08:16:39 pm »
2