project-navigation
Personal tools

Author Topic: Compiling 2.3.1 for PPC - maps?  (Read 2139 times)

Offline virag0

  • Rookie
  • ***
  • Posts: 48
    • View Profile
Compiling 2.3.1 for PPC - maps?
« on: August 10, 2011, 07:36:32 am »
Hi,
I have successfully compiled 2.3.1 on my Last Model G5 2.3 on 10.5.8.
But there is something wrong with the maps config.   I downloaded the 2.3.1 source as a tarball and then the maps from:

http://internode.dl.sourceforge.net/project/ufoai/UFO_AI%202.x/2.3.1/ufoai-2.3.1-data.tar

The maps dir looks like this:

Code: [Select]
[eros:~/ufoai/ufoai-2.3.1-source/base] root# ls -la
total 1042592
drwxr-xr-x@ 14 rachel  staff        476 10 Aug 15:12 .
drwxrwxr-x  32 rachel  staff       1088 10 Aug 15:23 ..
-rw-r--r--@  1 rachel  staff       4651 29 Nov  2010 0base.pk3
-rw-r--r--@  1 rachel  staff  136084567 25 Nov  2010 0maps.pk3
-rw-r--r--@  1 rachel  staff      13528 25 Nov  2010 0materials.pk3
-rw-r--r--@  1 rachel  staff   11034860 25 Nov  2010 0media.pk3
-rw-r--r--@  1 rachel  staff   78915743 25 Nov  2010 0models.pk3
-rw-r--r--@  1 rachel  staff  162768935 25 Nov  2010 0music.pk3
-rw-r--r--@  1 rachel  staff  134711881 25 Nov  2010 0pics.pk3
-rw-r--r--@  1 rachel  staff      14050 25 Nov  2010 0shaders.pk3
-rw-r--r--@  1 rachel  staff    9446428 25 Nov  2010 0snd.pk3
-rw-r--r--@  1 rachel  staff     191996 27 Nov  2010 0ufos.pk3
-rwxr-xr-x   1 rachel  staff     596620 10 Aug 15:08 game.dylib
drwxr-xr-x  28 rachel  staff        952 10 Aug 15:12 i18n
[eros:~/ufoai/ufoai-2.3.1-source/base] root# pwd
/Users/rachel/ufoai/ufoai-2.3.1-source/base

But when I do the following, according to the "documentation", I get these errors:

Code: [Select]
[eros:~/ufoai/ufoai-2.3.1-source] root# make maps
find: base/maps: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
make: Nothing to be done for `maps'.
[eros:~/ufoai/ufoai-2.3.1-source] root# make maps-sync
find: base/maps: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
contrib/scripts/map-get.py upgrade
make: contrib/scripts/map-get.py: Command not found
make: *** [maps-sync] Error 127
[eros:~/ufoai/ufoai-2.3.1-source] root# make pk3
find: base/maps: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
find: base/models: No such file or directory
make -f build/data.mk pk3
find: base/pics: No such file or directory
find: base/textures: No such file or directory
find: base/models: No such file or directory
find: base/sound: No such file or directory
find: base/music: No such file or directory
find: base/maps: No such file or directory
find: base/media: No such file or directory
find: base/shaders: No such file or directory
find: base/ufos: No such file or directory
find: base/materials: No such file or directory
make[1]: *** No rule to make target `base/mapcycle.txt', needed by `base/0base.pk3'.  Stop.
make: *** [pk3] Error 2
[eros:~/ufoai/ufoai-2.3.1-source] root#

So, the 508Mb data file download is not what I want.   Can someone please specify how to get the data so I can compile it?

I have both SVN and git, but do not know the correct URL for the map/pk3/data stuff.    So if someone has that,
I can do it. 

Remember this is for PPC 2.3.1 version - if I can get this up we will have a PPC version of 2.3.1 for the fans out there and I can
then get around to playing with 2.4.....

Please respond ASAP - I do not get a lot of time to work on this game ;)


rachel

Offline virag0

  • Rookie
  • ***
  • Posts: 48
    • View Profile
Re: Compiling 2.3.1 for PPC - maps?
« Reply #1 on: August 10, 2011, 09:01:01 am »
Trying to fix this myself.   I copied the src/contrib directory into the 2.3.1 src tree.   Since it doesn't exist in 2.3.1,
it can't hurt to try.   But when I run the map-sync make directive I now get:

Code: [Select]
[eros:~/ufoai/ufoai-2.3.1-source] root# ./contrib/scripts/map-get.py upgrade
map-get version 0.0.4.2
getting list of available maps
downloading http://static.ufo.ludwigf.org/maps/Maps
Line "" corrupted
WARNING ufo2map version mismatch
Continue? [Y|n]y
INFO write files into /Users/rachel/ufoai/ufoai-2.3.1-source
base/maps/africa/af_craft_drop_firebird.map not found
base/maps/africa/af_craft_drop_herakles.map not found
base/maps/africa/af_craft_drop_raptor.map not found
base/maps/africa/af_craft_ufo_fighter.map not found
base/maps/africa/af_craft_ufo_harvester.map not found
base/maps/africa/af_craft_ufo_scout.map not found
base/maps/africa/af_empty1.map not found
base/maps/africa/af_empty2.map not found
base/maps/africa/af_empty5.map not found
base/maps/africa/af_empty6.map not found
base/maps/africa/af_fence1.map not found
base/maps/africa/af_fence2.map not found
base/maps/africa/af_fence3.map not found
base/maps/africa/af_house1.map not found
base/maps/africa/af_house2.map not found
base/maps/africa/af_house3.map not found
base/maps/africa/af_house4.map not found
base/maps/africa/af_house5.map not found
...
...
...
base/maps/village/vil_s06.map not found
base/maps/village/vil_s07.map not found
base/maps/village/vil_s08.map not found
base/maps/village/vil_s15.map not found
base/maps/wilderness.map not found
0 upgraded, 0 version mismatched, 0 already up to date


So, it looks like the map repo has changed for the new release 2.4?   

Please can someone source me a bundle that will do the necessary, so I can
compile the maps for 2.3.1 etc? 

I think I have the app working in every other respect - sound, graphics etc..... ;)


rachel

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Compiling 2.3.1 for PPC - maps?
« Reply #2 on: August 10, 2011, 10:10:44 am »
Hi!

The data.tar contains compiled maps already (0maps.pk3), you don't need to compile them.

-geever

Offline virag0

  • Rookie
  • ***
  • Posts: 48
    • View Profile
Re: Compiling 2.3.1 for PPC - maps?
« Reply #3 on: August 10, 2011, 11:17:55 am »
Last time I did this on 2.3.0, I had the same problem.   The maps must have endian-ness for x86
and I am on PPC.   Recompiling the maps on my platform allowed the maps etc to load properly.

can someone please specify the exact URL method I need to use GIT to get the 2.3.1 repo,
specifically the base directory?

I am not very adept at git, yet.   In fact it is maddening as I am olde skoole rcs nerd.
When I followed the dpwnload source instructions, it keeps pulling back 2.4. which I do not want,
so if someone has a git rule to bring back 2.3.1base, that would be excellent.


rachel

Offline virag0

  • Rookie
  • ***
  • Posts: 48
    • View Profile
Re: Compiling 2.3.1 for PPC - maps?
« Reply #4 on: August 10, 2011, 01:02:09 pm »
OK!  I got the  maps working by extracting the tarball again and then recalled I had to disable
GL shading and realtime fx to get the maps up.
So now I can load a skirmish and kill aliens which appears to be OK thus far.

But now, I have the same save game problem as I had with 2.3.0:   When I save to a slot,
I type in a name and the game is ostensibly saved as slot0.savx. If I save and leave the game
running, then try to load the save file, there is firstly no text in the slot, but the game loads
the savefile correctly although the console says the file header is corrupted.

If I quit the game, restart and reload it, the slot text is empty and the game will not load, but prints
the "header corrupted" message again.

If I unpack the file, it looks like fully formed xml to me, so I have no idea now.

Same problems as previous version.....


Now someone has ported this to Android, who's working on the IOS port?  Ipads are screaming
for xcom!


rachel