project-navigation
Personal tools

Author Topic: 2.3 build won't start[Solved]  (Read 2617 times)

Offline gargy2002

  • Rookie
  • ***
  • Posts: 55
    • View Profile
2.3 build won't start[Solved]
« on: August 27, 2010, 08:25:09 pm »
Hi, I have bought a new SSD drive so I installed a fresh install of Sabayon 5.3 Gnome x64(gentoo based) and can't start the game. I have installed the game on my old hard drive on the same Sabayon 5.3 Gnome x64 using Portage/Entropy(emerge/equo install ufo-ai) and works well, except the reaction fire doesn't work. I installed the same game on the same linux but it doesn't work...
/home/user/.ufoai
Code: [Select]
2010/08/27 18:22:34 FS_RemoveFile: remove /home/pepe999/.ufoai/2.3/base/keys.cfgand
Code: [Select]
sabayon pepe999 # cd /usr/games/bin/
sabayon bin # ./ufo

---- filesystem initialization -----
Adding game dir: /usr/share/games/ufoai/base
Added packfile /usr/share/games/ufoai/base/0base.pk3 (9 files)
Added packfile /usr/share/games/ufoai/base/0maps.pk3 (535 files)
Added packfile /usr/share/games/ufoai/base/0materials.pk3 (45 files)
Added packfile /usr/share/games/ufoai/base/0media.pk3 (10 files)
Added packfile /usr/share/games/ufoai/base/0models.pk3 (2015 files)
Added packfile /usr/share/games/ufoai/base/0music.pk3 (49 files)
Added packfile /usr/share/games/ufoai/base/0pics.pk3 (2114 files)
Added packfile /usr/share/games/ufoai/base/0shaders.pk3 (26 files)
Added packfile /usr/share/games/ufoai/base/0snd.pk3 (266 files)
Added packfile /usr/share/games/ufoai/base/0ufos.pk3 (97 files)
Adding game dir: ./base
Added packfile ./base/0base.pk3 (9 files)
Added packfile ./base/0maps.pk3 (535 files)
Added packfile ./base/0materials.pk3 (45 files)
Added packfile ./base/0media.pk3 (10 files)
Added packfile ./base/0models.pk3 (2015 files)
Added packfile ./base/0music.pk3 (49 files)
Added packfile ./base/0pics.pk3 (2114 files)
Added packfile ./base/0shaders.pk3 (26 files)
Added packfile ./base/0snd.pk3 (266 files)
Added packfile ./base/0ufos.pk3 (97 files)
Adding game dir: /root/.ufoai/2.3/base
using /root/.ufoai/2.3/base for writing
executing default.cfg
couldn't execute config.cfg

----- network initialization -------
libcurl/7.20.1 GnuTLS/2.8.4 zlib/1.2.5 initialized.

------ server initialization -------
added 7 maps to the mapcycle

----- console initialization -------
Console initialized.

------- video initialization -------
SDL version: 1.2.14
I: desktop depth: 32bpp
I: video memory: 0
I: Available resolutions: 1366x768 1024x768 832x624 800x600 720x400 700x525 640x512 640x480 640x400 640x350 576x432 512x384 416x312 400x300 360x200 320x240 320x200 320x175 (18)
I: video driver: x11
I: setting mode -1
I: set swap control to 0
I: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
I: got 0 bits for alpha
I: got 0 multisample buffers
GL_VENDOR: Mesa Project
GL_RENDERER: Software Rasterizer
GL_VERSION: 2.1 Mesa 7.8.2
GL_EXTENSIONS: GL_ARB_copy_buffer GL_ARB_depth_texture GL_ARB_depth_clamp GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_120 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_array GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_3DFX_texture_compression_FXT1 GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_APPLE_object_purgeable GL_ATI_blend_equation_separate GL_ATI_envmap_bumpmap GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_fragment_shader GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_resize_buffers GL_MESA_texture_array GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fragment_program GL_NV_fragment_program_option GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_point_sprite GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texgen_reflection GL_NV_vertex_program GL_NV_vertex_program1_1 GL_OES_read_format GL_SGI_color_matrix GL_SGI_color_table GL_SGI_texture_color_table GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays
using GL_ARB_texture_non_power_of_two
using GL_ARB_shading_language_100
GLSL Version: 1.20
using GL_ARB_framebuffer_object
max draw buffers: 4
max render buffer size: 4096
max color attachments: 8
using GL_ARB_draw_buffers
max supported lights: 8
max texture units: 8
max texture coords: 8
max vertex attributes: 16
max texture size: detected 4096
...but using 2048 as requested
Using low resolution globe textures as requested.
R_PreprocessShader: Unknown hardwaretype
FS_RemoveFile: remove /root/.ufoai/2.3/base/keys.cfg
./ufo(Sys_Backtrace+0x15)[0x569735]
./ufo(Sys_Error+0x77)[0x569f07]
./ufo(Com_Error+0x129)[0x5048d9]
./ufo[0x55bfac]
./ufo(R_LoadProgram+0x2f0)[0x55ca50]
./ufo(R_InitPrograms+0x58)[0x55cba8]
./ufo(R_Init+0x11ca)[0x540d0a]
./ufo(CL_Init+0x134)[0x4388c4]
./ufo(Qcommon_Init+0x38e)[0x5051be]
./ufo(main+0x1e)[0x56946e]
/lib/libc.so.6(__libc_start_main+0xfd)[0x7f2d44ec4a3d]
./ufo[0x429b29]
Error: Shutdown
I have seen some threads with the same error but nothing helps.
Thx pepe999
« Last Edit: August 28, 2010, 12:36:14 am by gargy2002 »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: 2.3 build won't start..
« Reply #1 on: August 27, 2010, 08:30:13 pm »
Hi, I have bought a new SSD drive so I installed a fresh install of Sabayon 5.3 Gnome x64(gentoo based) and can't start the game. I have installed the game on my old hard drive on the same Sabayon 5.3 Gnome x64 using Portage/Entropy(emerge/equo install ufo-ai) and works well, except the reaction fire doesn't work. I installed the same game on the same linux but it doesn't work...
/home/user/.ufoai


Code: [Select]
GL_RENDERER: Software Rasterizer

must be your videocard driver^ ...

-geever

Offline gargy2002

  • Rookie
  • ***
  • Posts: 55
    • View Profile
Re: 2.3 build won't start..
« Reply #2 on: August 27, 2010, 08:47:55 pm »
Thanks for that quick reply but how I said this is exactly same distro and exactly same driver like on my old hdd. I have a nvidia graphics and 195.36.31 driver which matches the kernel 2.6.35 = nvidia-drivers-195.36.31#2.6.35-sabayon.

Quote
must be your videocard driver^ ...
You are right..
Code: [Select]
(EE) Aug 27 16:20:41 NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) Aug 27 16:20:41 NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) Aug 27 16:20:41 NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) Aug 27 16:20:41 NVIDIA(0):     you continue to encounter problems, Please try
(EE) Aug 27 16:20:41 NVIDIA(0):     reinstalling the NVIDIA driver.
As it says so I reinstalled the driver and it works!! I have declared war to Aliens already..:)
« Last Edit: August 28, 2010, 12:35:48 am by gargy2002 »