Development > Coding

function to list the inventory? (commandline)

<< < (2/2)

oxyXen:

--- Quote ---Since nearly every command in the console is a 'debug' function right now i don#t see a reason to use a special prefix for that.
--- End quote ---

The reason is consistency


--- Quote ---I don't see a reason to not let them stay in a release as well (bug-reports, etc...)
--- End quote ---


True. Quake3 hase some startup command for the server, to activate debugging-support.

ox

Hoehrer:

--- Quote from: "Mattn" ---
--- Code: ---
char* filter = NULL;
if (Cmd_Argc() == 2) // 2 because the first one it the actual command itself
{
   filter = Cmd_Argv(1);
}
if ( filter != NULL )
[,....]

--- End code ---

--- End quote ---

Thanks, i'll have a look into it.


--- Quote from: "oxyXen" ---
--- Quote ---Since nearly every command in the console is a 'debug' function right now i don#t see a reason to use a special prefix for that.
--- End quote ---

The reason is consistency
--- End quote ---

To be consitent with what? Are there already built-in commands that start with "dbg_"? Or do you mean consistent with the names in C-code?

And where do we draw the line between "dbg_" and the others? Some of the functions _should_ only be used for debugging, but some of them may become a frequently used command for the average player.

I'm do not want to make this a huge topic - since it's rather unimportant for the game itself - so i'm fine with any way we decide on.

Werner

oxyXen:
Hi

To be consistent with all the cl_ g_ sv_ mn_ and so on stuff. But i'm like you not interested in a huge discussion on the dopic ;)

ox

Navigation

[0] Message Index

[*] Previous page

Go to full version