project-navigation
Personal tools

Author Topic: R31032 , firemode failed - game crash in battlescape  (Read 5789 times)

Offline 8472

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
R31032 , firemode failed - game crash in battlescape
« on: July 16, 2010, 10:33:18 pm »
Hi all,

A long time passed away since I played UFOAI last time (the 2.3-dev).
Few days ago I've noticed the final 2.3 version release.

Thus I've compiled it, and tried the game.
My system: Ubuntu 9.10.

And straight the first mission (Location: Puebla ,Type: Terror mission, Objective: Industrial theme) is crashing back to desktop when I end my turn.
With this error on the output:
Quote
ufo: src/game/g_combat.c:1051: G_GetShotFromType: Assertion `firemode >= 0' failed.
./ufo(Sys_Backtrace+0x1f)[0x81a847b]
./ufo[0x81a84e6]
[0x906400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x675932]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x66b648]
./base/game.so[0x21da20e]
./base/game.so(G_ClientShoot+0x7b)[0x21da2a7]
./base/game.so(AI_ActorThink+0x23e)[0x21d04c0]
./base/game.so(AI_Run+0xf6)[0x21d06d7]
./base/game.so(G_RunFrame+0x156)[0x21e0114]
./ufo(SV_RunGameFrame+0x10)[0x8168b69]
./ufo(SV_Frame+0x5b)[0x816b60b]
./ufo[0x8148cf0]
./ufo(Qcommon_Frame+0x7b)[0x8149152]
./ufo(main+0x5c)[0x81a6fb3]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x65eb56]
./ufo[0x806ce01]
./ufo(Sys_Backtrace+0x1f)[0x81a847b]
./ufo(Sys_Error+0x22)[0x81a7385]
./ufo(Sys_InitSignals+0x0)[0x81a84f9]
[0x906400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x675932]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x66b648]
./base/game.so[0x21da20e]
./base/game.so(G_ClientShoot+0x7b)[0x21da2a7]
./base/game.so(AI_ActorThink+0x23e)[0x21d04c0]
./base/game.so(AI_Run+0xf6)[0x21d06d7]
./base/game.so(G_RunFrame+0x156)[0x21e0114]
./ufo(SV_RunGameFrame+0x10)[0x8168b69]
./ufo(SV_Frame+0x5b)[0x816b60b]
./ufo[0x8148cf0]
./ufo(Qcommon_Frame+0x7b)[0x8149152]
./ufo(main+0x5c)[0x81a6fb3]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x65eb56]
./ufo[0x806ce01]
Error: Received signal 6.


Offline 8472

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #1 on: July 17, 2010, 12:03:59 pm »
R31037 - crash/bug is still present.
I'm attaching the save.

thx for any reply guys.

Offline 8472

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #2 on: July 17, 2010, 01:33:54 pm »
As I've just found, this crash to desktop appears at each mission I try to perform on the battlescape.
Doesn't matter if it's a terror mission or shotted down ufo / crash site.

Can somebody pls confirm this?

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2550
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #3 on: July 17, 2010, 06:16:48 pm »
As I've just found, this crash to desktop appears at each mission I try to perform on the battlescape.
Doesn't matter if it's a terror mission or shotted down ufo / crash site.

Can somebody pls confirm this?


applies to this either:
http://ufoai.ninex.info/forum/index.php?topic=5161.msg41261#msg41261

-geever

Offline nonickch

  • Rookie
  • ***
  • Posts: 36
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #4 on: July 17, 2010, 07:05:53 pm »
check latest trunk and see if it's ok now. PM me directly if it's not.

Offline 8472

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #5 on: July 17, 2010, 07:24:16 pm »
Hi,


I've updated to the latest available R31039 , and still the same problem, crashed to desktop from battlescape with this error on the output:

EDIT: I forgot to mention, that it still crashes on the TERROR MISSION , other, like crashed UFO site seems to work.

Quote
ufo: src/game/g_combat.c:1051: G_GetShotFromType: Assertion `firemode >= 0' failed.
./ufo(Sys_Backtrace+0x1f)[0x81a84af]
./ufo[0x81a851a]
[0x856400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x3a2932]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x398648]
./base/game.so[0x23e320e]
./base/game.so(G_ClientShoot+0x7b)[0x23e32a7]
./base/game.so(AI_ActorThink+0x23e)[0x23d94c0]
./base/game.so(AI_Run+0xf6)[0x23d96d7]
./base/game.so(G_RunFrame+0x156)[0x23e9114]
./ufo(SV_RunGameFrame+0x10)[0x8168b9d]
./ufo(SV_Frame+0x5b)[0x816b63f]
./ufo[0x8148d24]
./ufo(Qcommon_Frame+0x7b)[0x8149186]
./ufo(main+0x5c)[0x81a6fe7]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x38bb56]
./ufo[0x806ce01]
./ufo(Sys_Backtrace+0x1f)[0x81a84af]
./ufo(Sys_Error+0x22)[0x81a73b9]
./ufo(Sys_InitSignals+0x0)[0x81a852d]
[0x856400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x3a2932]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x398648]
./base/game.so[0x23e320e]
./base/game.so(G_ClientShoot+0x7b)[0x23e32a7]
./base/game.so(AI_ActorThink+0x23e)[0x23d94c0]
./base/game.so(AI_Run+0xf6)[0x23d96d7]
./base/game.so(G_RunFrame+0x156)[0x23e9114]
./ufo(SV_RunGameFrame+0x10)[0x8168b9d]
./ufo(SV_Frame+0x5b)[0x816b63f]
./ufo[0x8148d24]
./ufo(Qcommon_Frame+0x7b)[0x8149186]
./ufo(main+0x5c)[0x81a6fe7]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x38bb56]
./ufo[0x806ce01]
Error: Received signal 6.
« Last Edit: July 17, 2010, 07:30:22 pm by 8472 »

Offline mattheus

  • Rookie
  • ***
  • Posts: 59
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #6 on: July 18, 2010, 02:01:33 pm »
I have also trouble with current revision on 2.3, svn info says:
Last Changed Author: geever
Last Changed Rev: 31036
Last Changed Date: 2010-07-17 11:30:22 +0300 (L, 17 juuli 2010)
But "svn up" says it's at 31040.

Ubuntu 10.04 is system.

I can play my first round on battlescape and then it crashes in alien turn.
Error on console:

Code: [Select]
Team 1 ended round
Team 7's round started!
ufo: src/game/g_combat.c:1051: G_GetShotFromType: Assertion `firemode >= 0' failed.
./ufo(Sys_Backtrace+0x1f)[0x81a8347]
./ufo[0x81a83b2]
[0x3e4400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x412a82]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x408718]
./base/game.so(+0x18212)[0x1527212]
./base/game.so(G_ClientShoot+0x7b)[0x15272ab]
./base/game.so(AI_ActorThink+0x23e)[0x151d4c6]
./base/game.so(AI_Run+0xf6)[0x151d6dd]
./base/game.so(G_RunFrame+0x156)[0x152d124]
./ufo(SV_RunGameFrame+0x10)[0x8168a45]
./ufo(SV_Frame+0x5b)[0x816b4e7]
./ufo[0x8148860]
./ufo(Qcommon_Frame+0x7b)[0x8148cc4]
./ufo(main+0x5c)[0x81a6e87]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x3fbbd6]
./ufo[0x806cd81]
./ufo(Sys_Backtrace+0x1f)[0x81a8347]
./ufo(Sys_Error+0x22)[0x81a7251]
./ufo(Sys_InitSignals+0x0)[0x81a83c5]
[0x3e4400]
/lib/tls/i686/cmov/libc.so.6(abort+0x182)[0x412a82]
/lib/tls/i686/cmov/libc.so.6(__assert_fail+0xf8)[0x408718]
./base/game.so(+0x18212)[0x1527212]
./base/game.so(G_ClientShoot+0x7b)[0x15272ab]
./base/game.so(AI_ActorThink+0x23e)[0x151d4c6]
./base/game.so(AI_Run+0xf6)[0x151d6dd]
./base/game.so(G_RunFrame+0x156)[0x152d124]
./ufo(SV_RunGameFrame+0x10)[0x8168a45]
./ufo(SV_Frame+0x5b)[0x816b4e7]
./ufo[0x8148860]
./ufo(Qcommon_Frame+0x7b)[0x8148cc4]
./ufo(main+0x5c)[0x81a6e87]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe6)[0x3fbbd6]
./ufo[0x806cd81]
Error: Received signal 6.

Offline nonickch

  • Rookie
  • ***
  • Posts: 36
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #7 on: July 18, 2010, 04:45:18 pm »
for 2.3, the fix patch was introduced as of 31041.
Sry for not mentioning that.

Offline 8472

  • Cannon Fodder
  • **
  • Posts: 6
    • View Profile
Re: R31032 , firemode failed - game crash in battlescape
« Reply #8 on: July 18, 2010, 06:56:45 pm »
@nonickch , thanks for the fix. Looks like to work fine.