project-navigation
Personal tools

Author Topic: Engine Slow and Crash with multisampling  (Read 4574 times)

Offline Snaphaan

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Engine Slow and Crash with multisampling
« on: July 15, 2010, 09:02:48 am »
I have posted this at the windows issue section but was informed by Mattn to move it here:

The game lags terribly on my system. I get about 5 fps on the city maps and when I zoom in I get about 20fps. Most maps between 10-25fps.

 I have a...

Pentium Core Duo 2.9
2Gb RAM
HD4890 Sapphire
Windows 7
latest drivers reinstalled after a total drive cleanup

Also, when I enable multisample buffering the game crashes when I enter the tactical screen. It seems when I disable GLSL shaders the game runs smoothly. I am told this is a ATI and OpenGL problem. ATI cards don't like OpenGL that much...




Offline Kobold

  • Rookie
  • ***
  • Posts: 95
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #1 on: July 15, 2010, 11:59:33 am »
Also, when I enable multisample buffering the game crashes when I enter the tactical screen.

the game crash only if you load to tactical screen (battlescape)??? i just remember that this multisample bug was fixed near completion to 2.3 stable. since that fix multisample works for my nvidia card but it crashed right after i changed the settings.

i think you need to restart the game after you activate multisampling in video-settings.

Offline Snaphaan

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #2 on: July 17, 2010, 09:28:25 am »
Thanks Kobold!

Yes. Multisample buffering works now. No crashes. I just had to restart the game.

Still... the OpenGL problem has now taken a new turn:
I posted this OpenGL problem at Tom's hardware (at the ATI section). They believe the problem is NOT OpenGL or my card but in fact something in the code that is not compliant with some ATI cards. I have run some older OpenGL games like Doom3 and all of them runs smooth.  ???

I think this is more of a glitch in the engine coding than a hardware compatibility issue - like ATI cards running OpenGL.

Hope someone will look into this.  ;D
« Last Edit: July 17, 2010, 09:30:55 am by Snaphaan »

Offline Kobold

  • Rookie
  • ***
  • Posts: 95
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #3 on: July 17, 2010, 02:17:52 pm »
Thanks Kobold!

Yes. Multisample buffering works now. No crashes. I just had to restart the game.

Still... the OpenGL problem has now taken a new turn:
I posted this OpenGL problem at Tom's hardware (at the ATI section). They believe the problem is NOT OpenGL or my card but in fact something in the code that is not compliant with some ATI cards. I have run some older OpenGL games like Doom3 and all of them runs smooth.  ???

I think this is more of a glitch in the engine coding than a hardware compatibility issue - like ATI cards running OpenGL.

Hope someone will look into this.  ;D

The problem is doom3 runs smooth on my PC too, but this game got low fps on my nvidia card 7600GT too cause my card dont support openGL 3.0. i dont think that there is a way to fix it. but anyways that game could get some performance optimization.

btw your card support now openGL 3.0? cause you said in a early post there is a problem...

Offline Snaphaan

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #4 on: July 20, 2010, 09:51:20 am »
Yes, from the ATI 4xxx and the current 5xxx series all support OpenGL 3.0. It seems there used to be a problem with the older ATI cards.

I did not have all my facts with my earlier post.  I am no coder so maybe I don't fully understand the difficulties involved with making the game's OpenGL 3.0 engine compatible with cureent ATI cards.

At least with GLSL shaders off I can play the game without too much hassle.

 


Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #5 on: July 20, 2010, 11:56:55 am »
Try to turn on GLSL Shaders, just turn off realtime-lighting, that should work, take a look here:
http://ufoai.ninex.info/forum/index.php?topic=4885.msg40007#msg40007

... or read the whole thread ;)

Offline Snaphaan

  • Cannon Fodder
  • **
  • Posts: 9
    • View Profile
Re: Engine Slow and Crash with multisampling
« Reply #6 on: July 21, 2010, 10:23:23 am »
Great!

Thanks MCR.