project-navigation
Personal tools

Author Topic: Initial run on new system: Serious errors  (Read 3645 times)

Offline keybounce

  • Sergeant
  • *****
  • Posts: 330
    • View Profile
Initial run on new system: Serious errors
« on: June 14, 2010, 08:00:25 pm »
When run initially on a new system, UfoAi does the following:

1. It alters the graphic settings to it's default, regardless of anything else. Those defaults are badly chosen. (Note that anything other than "OS default" is broken if the display is calibrated, and that includes at least OsX and Windows 7).

2. It plays music and the opening movie at maximum volume, with no opportunity for the user to set any other volume level.

3. It assumes a fixed sized window. On the mac at least, possibly on other systems, this does not permit room for fixed screen decorations. Is there any way to ask the graphical system for what size window can be opened? (That's a serious question -- do Mac, X, and Microsoft have any common "What size window can I open?" query?)

These aren't just trivial items. If I did not know anything about UfoAi, the combination of a horrific tint and brightness on my screen, the unbearably loud music, the window that doesn't fit on screen, and the very long load time would quickly give me a very negative view of the game.

4. On the mac, at least (PPC), the opening movie has nothing but static for the sound.


Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Initial run on new system: Serious errors
« Reply #1 on: June 14, 2010, 10:11:43 pm »
what is the resolution ufo starts with?

the video is removed from 2.3

Offline keybounce

  • Sergeant
  • *****
  • Posts: 330
    • View Profile
Re: Initial run on new system: Serious errors
« Reply #2 on: June 15, 2010, 05:52:30 am »
It chooses 1024x768. The screen did have 768 vertical pixels, but 21 are taken by the menu bar at the top of the screen.

There's a 720 pixel height available on this monitor (it's a widescreen), something like 1200 wide, that actually fits nicely. But that wasn't used.

(And annoyingly, the other machine doesn't have anything bigger than 1024x768, and the only size that fits is 800x600).

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Initial run on new system: Serious errors
« Reply #3 on: June 15, 2010, 06:23:54 am »
please post your ufoconsole.log of both machines.

Offline keybounce

  • Sergeant
  • *****
  • Posts: 330
    • View Profile
Re: Initial run on new system: Serious errors
« Reply #4 on: June 20, 2010, 10:53:10 pm »
Sorry, missed that.


Offline keybounce

  • Sergeant
  • *****
  • Posts: 330
    • View Profile
Re: Initial run on new system: Serious errors
« Reply #5 on: June 21, 2010, 07:44:17 am »
And here's the log from the 1024x768 system on the new release (just run).

It tries to open a 1024x768 window, even though that doesn't fit onscreen -- I changed it to 800x600.