project-navigation
Personal tools

Author Topic: r29535 - INVSH Error again.  (Read 10592 times)

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
r29535 - INVSH Error again.
« on: April 25, 2010, 12:05:52 pm »
I think you guys sorted this prob by reproducing the error, on reloading xxx times, but it happened again, almost exactly like it happened to me the first time, except on a different map. This time the map was the crashed Harvester in the wastelands, and the error occurred at the moment the last alien was killed... the game froze up and the console shows the red flashing error message on the title bar. I didn't take a screenshot, and couldn't when I went back to the game screen to try - it was unrefreshable and all I could see in the window was my desktop wallpaper.

I'm trying again to reproduce the problem, but it's not happening.  >:( :( (as before)


Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #1 on: May 03, 2010, 12:10:24 pm »
This savegame from r29672, locks out at various stages of the mission. Sometimes at the very beginning, other times after completing a few moves..

Compressed file (next post) also contains ufoconsole.log

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #2 on: May 03, 2010, 12:11:06 pm »
Savegame and ufoconsole.log:

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #3 on: May 05, 2010, 08:12:18 pm »
Should I make an entry on Bug Tracker? I just had this error again on another savegame.  :( ???

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: r29535 - INVSH Error again.
« Reply #4 on: May 05, 2010, 08:23:00 pm »
what exactly did you do? did you retry a game often? did you reload it often? someone died in battlescape? something sold in geoscape mode? please try to add some details - and yes, open a ticket.

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #5 on: May 05, 2010, 09:57:40 pm »
what exactly did you do? did you retry a game often? did you reload it often? someone died in battlescape? something sold in geoscape mode? please try to add some details - and yes, open a ticket.

The error happened exactly as I explained before and as in the game image.

The last alien death and as experience points are being allocated to the Dropship team. When the error happens, you are forced to close down the game.

The screenshot is a subsequent occurrence. (not the first) A soldier was sent up the left side of the screen to "reveal" close aliens. As soon as the LOS (red line) appeared the error happened.

The error repeats at different stages of the game after each re-load of the save just before the mission. Sometimes at the very start, before the first soldier is moved, other times at different stages during the mission and after reloading the from the save point each time.

I did supply the savegame and someone had a look, but maybe not had time to check it out yet?

Tracker Item Added.
« Last Edit: May 05, 2010, 10:11:21 pm by Gren »

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #6 on: May 06, 2010, 12:52:49 am »
This latest save game from build r29728 freezes and displays the error on console as soon as the game begins..

Loaded the save game and despatched team from base 01.. The map at the crash site is Oriental Medium
Dropship Team 01

Reloaded and despatched team from base 02 to same crash site
Dropship Team 02

Reladed and despatched team from base 04 to same crash site
Dropship Team 04

Reloaded and despatched team from base 05 to same crash site
Dropship Team 05

Reloaded and despatched team from base 06 to same crash site
Dropship Team 06

In case you are wondering... I have no troopships at base 03 ;)

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #7 on: May 10, 2010, 12:11:02 pm »
Any update on this problem? Anyone want to comment? Is anything else needed?

Thanks ;)



Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: r29535 - INVSH Error again.
« Reply #8 on: May 10, 2010, 08:54:26 pm »
a way to reproduce it in a reliable way

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #9 on: May 11, 2010, 12:48:25 am »
a way to reproduce it in a reliable way

I'm not able to identify the conditions that bring on the error - however, it doesn't seem to rely on any particular build. As it stands, If I load up this save game, I am unable to progress any further, as you can see from the screenies, even taking on the mission from different bases produces the error as soon as the mission is loaded up and the team spawn is completed.

Has anyone tried loading my savegame to test - or is that not possible?

I tried loading up from a few games before and can usually get through one or perhaps two missions, but eventually, the error re-presents itself.

Maybe it would help if I understood what "No free inventory space" means, but I'm no programmer/coder. Either way - I think it's a problem that really needs to be sorted once and for all, if possible.

Maybe a suggestion would be to re-visit the solution applied the last time the error condition was identified.  ::) ???

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: r29535 - INVSH Error again.
« Reply #10 on: May 11, 2010, 08:11:07 am »
« Last Edit: May 11, 2010, 08:17:36 am by Mattn »

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #11 on: May 11, 2010, 10:16:12 am »
please add your info and savegames to:

https://sourceforge.net/tracker/?func=detail&aid=2997280&group_id=157793&atid=805242

Savegame file slot(x).lint is too large to upload.. is the xml file still of use?

Sorted - compressed the .lint file and uploaded them separately.
« Last Edit: May 11, 2010, 10:30:11 am by Gren »

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
INVSH Error.
« Reply #12 on: June 11, 2010, 01:31:50 pm »
Anyone had time to look into this yet?  :)

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #13 on: June 11, 2010, 02:42:23 pm »
From the sourceforge, it looks like you're about 700 revisions back. Do you compile yourself? If so, try recompiling. I remember talk about inventory stuff a while ago, but I'm not involved in the coding side so I can't help you.

Also, if you haven't noticed 2.3 has been branched off in the SVN, so make sure if you compile you're compiling the latest 2.3 rather than trunk.

Offline Gren

  • Squad Leader
  • ****
  • Posts: 165
    • View Profile
Re: r29535 - INVSH Error again.
« Reply #14 on: June 11, 2010, 03:42:04 pm »
From the sourceforge, it looks like you're about 700 revisions back. Do you compile yourself? If so, try recompiling. I remember talk about inventory stuff a while ago, but I'm not involved in the coding side so I can't help you.

Also, if you haven't noticed 2.3 has been branched off in the SVN, so make sure if you compile you're compiling the latest 2.3 rather than trunk.

Thanks H-Hour ;) The problem was first reported on r29535 and logged into the tracker. It still exists even though I have started afresh with a new campaign. I have 7 bases built atm and I have become used to saving before a mission - after perhaps 4 or 5 successful sorties, the error appears. If I re-load from the last save - I'm good for another 4 or 5 missions.

I'm not clever enough to do the compiling thing myself, so I use Muton's fantastic building kit.

I build pretty frequently (r30445 latest 2.4) and I d/loaded Muton's last build of 2.3 Stable too - sorry to say that the same problem is still there.  :(

I just wondered if anyone had managed to look at the problem.  ;)