project-navigation
Personal tools

Author Topic: Texture don't load. [FIXED]  (Read 5301 times)

Offline O01eg

  • Rookie
  • ***
  • Posts: 73
    • View Profile
Re: Texture don't load. [FIXED]
« Reply #15 on: April 30, 2010, 09:32:13 am »
Now it's work. Options --disable-*-shared for sdl-image solved this problem.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Texture don't load. [FIXED]
« Reply #16 on: April 30, 2010, 09:52:29 am »
did you use the ebuild from our svn? or was it a problem on your side?

Offline O01eg

  • Rookie
  • ***
  • Posts: 73
    • View Profile
Re: Texture don't load. [FIXED]
« Reply #17 on: April 30, 2010, 09:58:38 am »
It need to use media-libs/sdl-image-1.2.10-r1 instead media-libs/sdl-image-1.2.10. There was added --disable-jpg-shared --diable-png-shared --disable-tif-shared options to ./configure.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Texture don't load. [FIXED]
« Reply #18 on: April 30, 2010, 10:18:11 am »
well - my question was more or less: do we have to fix the ebuild in our trunk?

Offline O01eg

  • Rookie
  • ***
  • Posts: 73
    • View Profile
Re: Texture don't load. [FIXED]
« Reply #19 on: April 30, 2010, 10:33:42 am »
I think, that will be better to use check at ./configure for correct loading images of usable formats.
In ebuild add >media-libs/sdl-image-1.2.10[jpeg,png].

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress