project-navigation
Personal tools

Author Topic: Texture missing (r29530)  (Read 1595 times)

Offline dodon

  • Rookie
  • ***
  • Posts: 48
    • View Profile
Texture missing (r29530)
« on: April 25, 2010, 08:45:54 am »

In Geoscape the texture for the earth is missing.  :(

excerpt from Console.log:

Quote
2010/04/25 08:16:00 R_LoadShader: world_vs.glsl: Vertex shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadShader: world_fs.glsl: Fragment shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadProgram: world: Warning: No shaders attached to current program

2010/04/25 08:16:00 R_LoadShader: mesh_vs.glsl: Vertex shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadShader: mesh_fs.glsl: Fragment shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadProgram: mesh: Warning: No shaders attached to current program

2010/04/25 08:16:00 R_LoadProgram: 'warp' loaded.
2010/04/25 08:16:00 R_LoadShader: geoscape_vs.glsl: Vertex shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadShader: geoscape_fs.glsl: Fragment shader failed to compile with the following errors:
ERROR: 0:10: '' :  #version must occur before any other statement in the program
ERROR: 1 compilation errors.  No code generated.


2010/04/25 08:16:00 R_LoadProgram: geoscape: Warning: No shaders attached to current program

The *.glsl files are OK but dependen on the detectet graphiccard in R_PreprocessShader (r_program.c) sometimes (with ATI, Intel and NVidea) defines are added at the beginning of the files.

As a quick fix i removed the #version line  from the files.