project-navigation
Personal tools

Author Topic: Crash to Geoscape from Battlescape  (Read 3386 times)

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Crash to Geoscape from Battlescape
« on: April 21, 2010, 10:45:48 am »
Build: 29482

Just moving a soldier along a wall in the battlescape crashed the battle to geoscape.

The relevant part of the ufoconsole log is as follows:


Code: [Select]
2010/04/21 11:35:53 ==== InitGame ====
2010/04/21 11:35:53 SV_AssembleMap: Sequential map assembly in 2 ms
2010/04/21 11:35:53 CM_LoadMap: "-oriental/or_ +craft_drop_firebird +house_b +house_c +house_e +house_f +craft_crash_fighter +house_c +trees_a +house_a +house_a +well +trees_b +trees_b +stand_b +stand_a" "-24 8 0 0 16 0 -8 0 0 0 -24 0 8 0 0 -24 -24 0 8 16 0 0 -8 0 8 -8 0 -24 0 0 16 -16 0 16 -24 0 -24 24 0 -16 24 0 -8 24 0"
2010/04/21 11:35:55 Rerouted for RMA in   1.0s
2010/04/21 11:35:55 checksum for the map '+oriental': 328065310
2010/04/21 11:35:55 ufo script checksum 3151923691
2010/04/21 11:35:55 Created AI player (team 0)
2010/04/21 11:35:55 Created AI player (team 7)
2010/04/21 11:35:55 -------------------------------------
2010/04/21 11:35:55 Connecting to localhost...
2010/04/21 11:35:55 connection attempt from loopback connection
2010/04/21 11:35:55 load material file: 'materials/oriental.mat'
2010/04/21 11:36:00 R_ParseStage: Failed to resolve texture: tex_material/desert001
2010/04/21 11:36:04 R_ModLoadTags: found 100 frames in models/objects/vegi/palm_a/palm1.tag but model has 101 frames
2010/04/21 11:36:04 Starting the game...
2010/04/21 11:36:04 Edi has joined team 1
2010/04/21 11:36:04 music change to David01 (from van_geoscape)
2010/04/21 11:36:04 music change to ufo2 (from David01)
2010/04/21 11:36:04 (player 0) It's team 1's round
2010/04/21 11:36:04 Edi has taken control over team 1.
2010/04/21 11:36:05 MN_ExecuteSetAction: node "root.team_selection.bt_actor8@disabled" doesn't exist (source: hud.hudenable)
2010/04/21 11:36:05 MN_ExecuteSetAction: node "root.team_selection.bt_actor8@disabled" doesn't exist (source: hud.hudenable)
2010/04/21 11:36:05 MN_ExecuteSetAction: node "root.team_selection.bt_actor8@disabled" doesn't exist (source: hud.hudenable)
2010/04/21 11:36:23 Shutdown gametype 'Campaign mode'
2010/04/21 11:36:23 Shutdown server: Quitting server.
2010/04/21 11:36:23 ==== ShutdownGame ====


From that, if you wanted me to pick the likely culprit, it would be

Code: [Select]
2010/04/21 11:36:00 R_ParseStage: Failed to resolve texture: tex_material/desert001
2010/04/21 11:36:04 R_ModLoadTags: found 100 frames in models/objects/vegi/palm_a/palm1.tag but model has 101 frames

On the same map, one of the house components has a bug on the first floor where you can't move past a table even though there should be space between it and the wall. So to get to the stairs going up, you have to go all the way around.

I will upload a screenshot later, right now I have to go.

Offline H-Hour

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1923
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #1 on: April 21, 2010, 12:04:34 pm »
A screenshot would be good, but it would be even better if you added it to the bug tracker on Sourceforge. That way we can track work on the problem easier. And there's a "Maps" category that helps non-coders like me focus on problems I can resolve.

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #2 on: April 21, 2010, 12:06:05 pm »
I'll open up tracker items for these later in the afternoon. I posted about them in the same thread for convenience now.

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #3 on: April 21, 2010, 04:34:47 pm »
Hmm, turns out it was the actor out of sync crash when I took a closer look. But there is now a tracker item for the map bug here.

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #4 on: April 23, 2010, 11:09:24 pm »
Okay, time to resurrect this thread. I had another crash from battlescape to geoscape that was NOT due to actor out of sync, but something else:

Code: [Select]
2010/04/24 00:04:26 ==== InitGame ====
2010/04/24 00:04:55 SV_AssembleMap: Sequential map assembly in 29747 ms
2010/04/24 00:04:55 CM_LoadMap: "-farm/f_ +craft_drop_firebird +wind +craft_ufo_harvester +road_h1 +road_hs +field_b +field_a +farmhouse_b +stables_a +farmhouse_a +farmhouse_c +barn_a +filler_l_b +barn_b +stables_b +filler_m_a +silo +silo +road_h +road_h +road_h +filler_l_a +filler_l_a +filler_l_b +filler_m_b +filler_l_a +filler_m_a +filler_m_b +road_h +road_h +filler_m_b +filler_m_b +road_h +road_h +road_h +road_h +road_h +filler_s +filler_s +filler_s +filler_m_a +filler_m_a" "0 16 0 0 8 0 -8 -40 0 -16 -48 0 32 -48 0 -48 -40 0 -48 -8 0 32 -40 0 -16 -8 0 8 -8 0 32 -16 0 32 0 0 -16 -40 0 -16 8 0 24 16 0 16 8 0 40 16 0 -16 -16 0 -24 -48 0 40 -48 0 -48 -48 0 -48 24 0 -24 24 0 40 24 0 16 32 0 -48 32 0 -48 40 0 -24 32 0 -40 -48 0 -32 -48 0 -16 32 0 -8 32 0 -8 -48 0 0 -48 0 8 -48 0 16 -48 0 24 -48 0 -32 40 0 0 32 0 8 32 0 0 40 0 24 40 0"
2010/04/24 00:04:59 Rerouted for RMA in   0.0s
2010/04/24 00:04:59 checksum for the map '+farm': 747261986
2010/04/24 00:04:59 ufo script checksum 3151923691
2010/04/24 00:04:59 Created AI player (team 0)
2010/04/24 00:04:59 Created AI player (team 7)
2010/04/24 00:04:59 -------------------------------------
2010/04/24 00:04:59 Connecting to localhost...
2010/04/24 00:04:59 connection attempt from loopback connection
2010/04/24 00:04:59 ********************
2010/04/24 00:04:59 ERROR: Server is not reachable
2010/04/24 00:04:59 ********************
2010/04/24 00:04:59 Shutdown server: Server crashed.
2010/04/24 00:04:59 ==== ShutdownGame ====
2010/04/24 00:04:59 music change to karlmacklin_geoscape (from van_geoscape)
2010/04/24 00:05:09 Shutdown gametype 'Campaign mode'
2010/04/24 00:05:09 Cvar 'mn_uforecovery_actualufo' wasn't found
2010/04/24 00:05:09 music change to van_theme (from karlmacklin_geoscape)
2010/04/24 00:05:09 Wrote config.cfg.
2010/04/24 00:05:09 Wrote keys.cfg

The game crashed when still in the loading screen for battlescape, just tossed me right back into geoscape and I guess I could have just tried to send the firebird back to the mission. It says server not reachable when it's trying to access the local machine, so is this just a bona fide crash with no discernible cause?

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #5 on: April 24, 2010, 10:28:34 am »
Damned timeout...

-geever

Offline balasar

  • Rookie
  • ***
  • Posts: 78
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #6 on: April 24, 2010, 10:43:33 am »
I have a similar situation, but in skirmish mode. Crashad from battlescape to main menu, when the actor moved on the map. rev29527\WinXPsp3
« Last Edit: April 24, 2010, 10:46:45 am by balasar »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Crash to Geoscape from Battlescape
« Reply #7 on: April 24, 2010, 08:31:06 pm »
I have a similar situation, but in skirmish mode. Crashad from battlescape to main menu, when the actor moved on the map. rev29527\WinXPsp3

it's not similar but a completely different issue:
Code: [Select]
2010/04/24 11:04:58 ERROR: LE_DoEndPathMove: Actor movement is out of sync: 122:146:0 should be 121:146:0 (step 6 of 6) (team 1)

-geever