project-navigation
Personal tools

Author Topic: Geoscape is transparent  (Read 4098 times)

Offline balasar

  • Rookie
  • ***
  • Posts: 78
    • View Profile
Geoscape is transparent
« on: April 11, 2010, 08:44:39 am »
Geoscape is transparent if glsl shaders turned off in game.
rev 29329
PhII/2G/Gf7900GS/winXP_sp3/nforce 197.13

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Geoscape is transparent
« Reply #1 on: April 11, 2010, 11:24:06 am »
please retry with latest trunk

Offline balasar

  • Rookie
  • ***
  • Posts: 78
    • View Profile
Re: Geoscape is transparent
« Reply #2 on: April 11, 2010, 08:52:40 pm »
All good. :)

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Geoscape is transparent
« Reply #3 on: April 11, 2010, 09:19:46 pm »
...Or you can wait until tomorrow when I should have a new installer up, if you're on Windows.

Offline balasar

  • Rookie
  • ***
  • Posts: 78
    • View Profile
Re: Geoscape is transparent
« Reply #4 on: April 11, 2010, 11:28:55 pm »
I use Muton's utility for compiling and checked in rev. 29343. All right. Thanx.

Offline DiDiT

  • Squad Leader
  • ****
  • Posts: 149
  • Your local Flame-thrower wielding Furry.
    • View Profile
Re: Geoscape is transparent
« Reply #5 on: April 13, 2010, 01:38:40 pm »
I'm still getting this, even with daves new build.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Geoscape is transparent
« Reply #6 on: April 13, 2010, 01:46:40 pm »
Try to decompress 0pics.pk3 (in yourufoaiinstallationdir/base). If you have a CRC error, something went wrong with your download.

Offline DiDiT

  • Squad Leader
  • ****
  • Posts: 149
  • Your local Flame-thrower wielding Furry.
    • View Profile
Re: Geoscape is transparent
« Reply #7 on: April 13, 2010, 01:53:49 pm »
nope, decompresses fine.

i also just reinstalled it from scratch, and it still has the issue.

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Geoscape is transparent
« Reply #8 on: April 13, 2010, 08:40:33 pm »
nope, decompresses fine.

i also just reinstalled it from scratch, and it still has the issue.
Same here. I even deleted my old profile so it created a new one and the problem persisted.

However, playing around with the settings, I found what triggers the problem and how to work around it, but the workaround disables other things.

Namely, the problem is caused by the GLSL Shaders. Turn that off from the video options and the 3D Geoscape is visible. Unfortunately, turning the shaders off necessarily means turning off post-processing shader effects so you can't make the political borders visible. You can make the radar range circles visible with the shaders off, but it doesn't show the grayed out radar shadow areas outside detection range.

Interestingly enough, the political map makes the continents and islands visible even on a transparent map, so you can play, but terrain details are naturally missing. The view is pretty surreal. And very, very neon.

Hopefully this helps in pinpointing where the problem is.

I'm running Windows XP Pro SP3 with 4 GB RAM and an ATI HD4870 256MB graphics card.

My ATI drivers are not the very latest yet, but within half an hour they will be and I'll post the results then. I don't think that will do very much, however.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Geoscape is transparent
« Reply #9 on: April 13, 2010, 08:55:16 pm »
Your gfx-card should not be the problem  ;)
Try the new drivers & if the problem persists you should post the log file, maybe someone has time to take a look.
You can also wait for the next version or compile a new one, because currently there is heavy development going on on this field & other users also reported issues which disappeared in later dev-versions ;)

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Geoscape is transparent
« Reply #10 on: April 13, 2010, 09:12:30 pm »
I can live with it for now. The new drivers did not help any.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Geoscape is transparent
« Reply #11 on: April 13, 2010, 10:24:07 pm »
please retry with latest trunk and post your ufoconsole.log, too

Offline GPS51

  • Rookie
  • ***
  • Posts: 77
    • View Profile
Re: Geoscape is transparent
« Reply #12 on: April 13, 2010, 11:13:35 pm »
I had this problem as well but I turned on colored nation groups and it's quite colorful. Reminds me of lots of neon lights with the night sky as a background. BTW the game has come a huge way visually in the last couple of months. Congrats on the way it's looking/playing.

Offline balasar

  • Rookie
  • ***
  • Posts: 78
    • View Profile
Re: Geoscape is transparent
« Reply #13 on: April 15, 2010, 08:48:42 pm »
I again got this problem (but if glsl shaders turned on in game)
PhII/2G/Gf7900GS/winXP_sp3/nforce 197.13/rev29402

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Geoscape is transparent
« Reply #14 on: April 15, 2010, 09:07:26 pm »
please open a bugtracker item for this - with the screenshot and the ufoconsole.log please - easier to keep track ;)