project-navigation
Personal tools

Author Topic: r28869 Flamethrower appears to do no damage  (Read 5109 times)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: r28869 Flamethrower appears to do no damage
« Reply #15 on: March 12, 2010, 09:22:16 pm »
Well I fixed it, but only to find out that Mattn had it fixed earlier this day in r28922.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: r28869 Flamethrower appears to do no damage
« Reply #16 on: March 12, 2010, 10:52:17 pm »
i'm sorry duke ;)

but did you also look at the "unable-to-move-the-first-selected-soldier-until-i-reselect-him"-bug?

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: r28869 Flamethrower appears to do no damage
« Reply #17 on: March 13, 2010, 12:22:31 am »
Not yet. Been working on the "actor movement different to displayed path"-bug.
Figured it out, but need your help there.
Plz take a look...

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: r28869 Flamethrower appears to do no damage
« Reply #18 on: March 13, 2010, 09:21:14 am »
... where? tell me more please - what is the cause of the problem? and where exactly do you need my help?

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: r28869 Flamethrower appears to do no damage
« Reply #19 on: March 15, 2010, 09:04:00 pm »
Mattn,
you found my post to that tracker item, but did you also see my recent post to that item ?
« Last Edit: March 15, 2010, 09:56:27 pm by Mattn »

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: r28869 Flamethrower appears to do no damage
« Reply #20 on: March 15, 2010, 10:04:19 pm »
not until i've read this - sorry. but now i've added a new comment, too

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: r28869 Flamethrower appears to do no damage
« Reply #21 on: March 15, 2010, 10:43:54 pm »
No problem :)
It's fixed in r29019.

.... so i suppose CL_ActorConditionalMoveCalc is doing the Grid_MoveCalc too early for the first actor (though i don't know what is missing there)
No. Some debugging showed that CL_ActorConditionalMoveCalc isn't called at all at that time.
Investigating.
Is it correct that we don't have a tracker item for this issue (ie. nobody except me complained) or did I just overlook it ?

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: r28869 Flamethrower appears to do no damage
« Reply #22 on: March 16, 2010, 12:57:15 am »
Correction:
CL_ActorConditionalMoveCalc is called before the Tus of the LE are set.
Had to go back to MAX_ROUTE to fix the prob in r29020.