project-navigation
Personal tools

Author Topic: Vista  (Read 3169 times)

Offline Pangorin

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Vista
« on: March 09, 2010, 10:44:47 am »
Hello,
I dont know if this is the right section, so excuse me if not...
I have Windows Vista. When I run UFO:AI (2.3latest devel.) everything runs fine, but- when i start battle and it is Alien turn, game is slow, sometimes freezing for few seconds etc...
In v2.2 and 2.1 ... no problem.
But in v2.3... horrible.
Help please!

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: Vista
« Reply #1 on: March 09, 2010, 10:21:30 pm »
we can't

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Vista
« Reply #2 on: March 09, 2010, 10:35:19 pm »
2.3 is a little more resource-intensive than 2.2.x from my experience, and Vista is a resource hog of an operating system, which can cause UFO: AI to sometimes run slow - fortunately there are ways to turn off many of the unnecessary and ridiculous services:

- Turn off Areo.

- Turn off themes and run in "basic" mode.

- If you can find the advanced settings under control panel, change performance from all the eye-candy to "adjust for best performance."

Research on the internet can also provide other hints - these are just off the top of my head.

Also, what video card drivers do you use?  The ones you get from Windows Update, or direct from the manufacturer?  That also makes a big difference.  (The latter choice is much better.)

Aside from that, if we're going to give any real help though, we'll at least need some system specs.

Offline Pangorin

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Vista
« Reply #3 on: March 10, 2010, 10:37:07 am »
okey i tried it on windows seven on my daddy's PC :P
same... slow,, freezing... :(
i have VGA Ati radeon hd 4570/3200 its good i think...
i have drivers from www.asus.cz (.com) so they are specially for my card...
i have Audio drivers, usb, all drivers so... but i dont know why its so slow :(
and i have direct x 10
aero off
:-((

Offline Lysozyme

  • Cannon Fodder
  • **
  • Posts: 4
    • View Profile
Re: Vista
« Reply #4 on: March 10, 2010, 06:59:25 pm »
okey i tried it on windows seven on my daddy's PC :P
same... slow,, freezing... :(
i have VGA Ati radeon hd 4570/3200 its good i think...
i have drivers from www.asus.cz (.com) so they are specially for my card...
i have Audio drivers, usb, all drivers so... but i dont know why its so slow :(
and i have direct x 10
aero off
:-((

You say you've downloaded your video-drivers from asus.com? In my opinion, that's not correct. You should download your video drivers from http://support.amd.com/us/gpudownload/Pages/index.aspx, this is the official website for downloading ati video drivers. Asus.com is just the manufacturer of your pc/laptop. Propably they've adjusted some settings.

Offline Edi

  • Squad Leader
  • ****
  • Posts: 296
    • View Profile
Re: Vista
« Reply #5 on: March 18, 2010, 01:12:52 pm »
Try running the game in compatibility mode. Right click icon > Properties > Compatibility tab, check the box that says Compatibility mode and select Windows XP SP3 from the list. That could help with Vista and Windows 7. Of course, all drivers etc should be updated to the latest possible.