project-navigation
Personal tools

Author Topic: Reaction Fire?  (Read 2803 times)

Offline slippycurb

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Reaction Fire?
« on: February 27, 2010, 05:58:05 pm »
has anyone else suffered from having no reaction fire?

Offline Mungojerrie

  • Rookie
  • ***
  • Posts: 18
    • View Profile
Re: Reaction Fire?
« Reply #1 on: February 27, 2010, 11:18:50 pm »
Well, i did not test it thoroughly, but I yes - the same problem.

Offline j4l

  • Rookie
  • ***
  • Posts: 24
    • View Profile
Re: Reaction Fire?
« Reply #2 on: February 28, 2010, 07:39:47 pm »
did you read that topic? http://ufoai.ninex.info/forum/index.php?topic=4431.0

and it still doesn't work?

Offline WyerByter

  • Cannon Fodder
  • **
  • Posts: 3
    • View Profile
Re: Reaction Fire?
« Reply #3 on: March 01, 2010, 01:45:39 pm »
did you read that topic? http://ufoai.ninex.info/forum/index.php?topic=4431.0

and it still doesn't work?

The issue, at least for me, is not turning it on. Neither side, the aliens or the soldiers, do reaction fire. There are some strange pauses when my soldiers are walking, but no fire.

This is in campaign on any map, and I rebuild often from the latest in the dev version.

I just realized I don 't think I've started a new game recently, well since the last saved game compatablility announcement.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Reaction Fire?
« Reply #4 on: March 01, 2010, 06:08:03 pm »
it works here - please try it in a skirmish game, too

Offline thunktone

  • Rookie
  • ***
  • Posts: 17
    • View Profile
Re: Reaction Fire?
« Reply #5 on: March 02, 2010, 12:42:07 pm »
It works for me in skirmish but not in the campaign.

Offline Muton

  • Sergeant
  • *****
  • Posts: 496
    • View Profile
Re: Reaction Fire?
« Reply #6 on: March 02, 2010, 06:32:35 pm »
It would be fine to know if Linux/BSD/MAC/Win

My build Win32
its not working not in campaign or skirmish

Selected the firemode fist than try to activate reaction fire
but the result is onscreen "No fire mode selected for reaction fire."

2010/03/01 22:27:25 Priority changed to NORMAL
2010/03/01 22:27:25 Found 2 processors
2010/03/01 22:27:25 Use both cores
2010/03/01 22:27:25 Switch grab input off
2010/03/01 22:27:28 s_language has no value
2010/03/01 22:27:31 SDL_ttf version 2.0.9 - we need at least 2.0.7
2010/03/01 22:27:31 ...registering 10 fonts
2010/03/01 22:27:32 Wrote config.cfg.
2010/03/01 22:27:37 Change gametype to 'Skirmish mode'
2010/03/01 22:28:06 ==== InitGame ====
2010/03/01 22:28:07 checksum for the map 'fighter_crash': 2840538076
2010/03/01 22:28:07 ufo script checksum 1889789577
2010/03/01 22:28:07 Created AI player (team 0)
2010/03/01 22:28:07 Created AI player (team 7)
2010/03/01 22:28:07 -------------------------------------
2010/03/01 22:28:07 Connecting to localhost...
2010/03/01 22:28:07 connection attempt from loopback connection
2010/03/01 22:28:10 Starting the game...
2010/03/01 22:28:10 zelli has joined team 1
2010/03/01 22:28:10 music change to van_mission2 (from van_theme)
2010/03/01 22:28:14 (player 0) It's team 1's round
2010/03/01 22:28:14 zelli has taken control over team 1.
2010/03/01 22:28:26 No fire mode selected for reaction fire.
2010/03/01 22:28:29 No fire mode selected for reaction fire.
2010/03/01 22:28:31 No fire mode selected for reaction fire.
2010/03/01 22:28:39 No fire mode selected for reaction fire.
2010/03/01 22:28:41 No fire mode selected for reaction fire.
2010/03/01 22:28:42 No fire mode selected for reaction fire.
2010/03/01 22:28:52 No fire mode selected for reaction fire.
2010/03/01 22:28:55 No fire mode selected for reaction fire.
2010/03/01 22:28:58 No fire mode selected for reaction fire.
2010/03/01 22:29:00 Wrote config.cfg.
2010/03/01 22:29:00 Shutdown server: Server quit.
2010/03/01 22:29:00 ==== ShutdownGame ====
2010/03/01 22:29:00 Shutdown gametype 'Skirmish mode'
2010/03/01 22:29:00 Wrote keys.cfg



Offline slippycurb

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Reaction Fire? More detail
« Reply #7 on: March 02, 2010, 07:53:48 pm »
Sorry about the lack of detail there, and the fact that im a shotgun poster, I do not have my own internet connection...............:-~
Im using the svn linux version, and usually update it every couple of days, and occasionly start a new game.(I started one last thurs/fri). 
It seems the RF very rarely actually works, as in , my soldiers will actually fire, normally they just get blasted when the aliens walk into view and paint the scenery with my mens/womens brains. Since I started the new game ive seen my soldiers fire once or twice, maybe they are just not that good yet?
To enable RF, I would first tick the circle, then reserve Tus for the same level of shot, then then set the RF(the shield) to 1.  That seems alot of Tus? I bet im doing something wrong whatever it is............iv'e tried enabling just the RF with the ticked circle and the shield button, but never got my soldiers to fire during the aliens turn like that either, maybe im just crap and the aliens know it. Sometimes i hear them laughing at me.

Oh yeah, I recompile everytime after an update.
Maybe someone could post a youtube vid of how to set this correctly til the manual is finished?

ps thanks for working on this great game, and i hope this post creates more work for you.

Offline thunktone

  • Rookie
  • ***
  • Posts: 17
    • View Profile
Re: Reaction Fire?
« Reply #8 on: March 03, 2010, 12:28:25 pm »
I'm also using linux svn. I don't get the message "No fire mode selected for reaction fire", it seems to set up ok and reserve TU's. To get some reaction fire in skirmish I had to use a soldier as bait to draw a knife wielding alien out of hiding. I got no reaction fire when the gun wielders were popping out of cover and firing several shots at my soldiers.

I've played through the early stages of the campaign despite this problem and seen no reaction fire from my guys or the aliens in over a dozen missions.

Offline MCR

  • PHALANX veteran
  • ******
  • Posts: 1244
    • View Profile
Re: Reaction Fire?
« Reply #9 on: March 04, 2010, 12:33:52 pm »
The RF-Selection-Mode is really not very intuitive @ the moment  ::)
@Muton: To get rid of this message, you have first to check the round circle (see screenshot).
I did not get it for a long time also, even after reading the posts concerning this, so I decided a screenshot would explain it best.
I am running XP, ufoai-2.3-dev-28776-Debug-full-win32 & even after many clicks for activating the reaction fire none of my soldiers would ever shoot @ an alien... I suppose this is not the way it should be...

Offline slippycurb

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: Reaction Fire?
« Reply #10 on: March 04, 2010, 03:03:35 pm »
I have a feeling it will all be changed when "The Dudes" get round to it anyway....we shouldnt fret too much;-)

Offline Stedevil

  • Rookie
  • ***
  • Posts: 10
    • View Profile
Re: Reaction Fire?
« Reply #11 on: March 12, 2010, 12:54:21 pm »
RF was fixed at some point before 28860. Working fine now. :)