project-navigation
Personal tools

Author Topic: ufo ai window is flickering  (Read 2740 times)

Offline gtludwig

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
ufo ai window is flickering
« on: January 04, 2010, 01:31:04 pm »
Hey all,

After a long time I'm on Linux again and have a little spare play time. Since I always loved the x-com games I decided to give another shot at this game.

I have downloaded ufoai-2.2.x from SVN and have built it via
Code: [Select]
$ ./configure
$ make
$ make lang
$ make maps
$ cd base
$ ./archives.sh
$ cd ..
$ su
# make install

It is installed and runs, but the video is flickering. I imagine it might be related to a "poor" installation of video drivers. This box is running Slackware64-current and has ATi video. The video drivers were (amazingly!) installed without any kernel tweaking. Any thoughts?

Thanks in advance!

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: ufo ai window is flickering
« Reply #1 on: January 04, 2010, 05:02:35 pm »
which drivers did you install? the open source or the original by ati? the open source drivers are not yet working for ufoai with all cards.

Offline gtludwig

  • Cannon Fodder
  • **
  • Posts: 5
    • View Profile
Re: ufo ai window is flickering
« Reply #2 on: January 04, 2010, 05:54:18 pm »
I'm using original ATi:
ati-driver-installer-9-11-x86.x86_64.run

Offline QkiZ

  • Rookie
  • ***
  • Posts: 20
    • View Profile
Re: ufo ai window is flickering
« Reply #3 on: January 21, 2010, 10:57:11 pm »
Are you using Compiz? Is Compiz is running while you play the game?