project-navigation
Personal tools

Author Topic: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp  (Read 2284 times)

Offline criusmac

  • Squad Leader
  • ****
  • Posts: 168
    • View Profile
ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« on: October 24, 2009, 10:07:34 am »
  Version

    * Where did you download the version of the game and what version(-number) is it. Please be as verbose as possible here.
"version" is "UFO: Alien Invasion 2.3-dev x86 Oct 23 2009 Win32 DEBUG"
Updated via svn as requested.

    * SVN users please state the branch of the svn tree you use (e.g. "trunk" or one of the version-branches) and the revision number. You can get both by using the "svn info" command.
svn info -
'svn' is not recognized as an internal or external command,
operable program or batch file.

System

    * What operating system do you run UFO:AI on?
Version   5.1.2600 Service Pack 3 Build 2600

    * What computer and graphics card do you have? (graphic driver version if you know)
Name   Radeon X1600/X1650 Series
Driver Version   6.14.10.6925

    * What architecture does your system use (e.g. like i386, x86_64)
Processor   x86 Family 15 Model 55 Stepping 2 AuthenticAMD ~2205 Mhz

This is especially useful for everything from graphics bugs, setup problems, performance issues, os dependent errors, etc...
What happened before the bug occurred? Is the bug reproducible?
Game behaved normally, upon attempting to enter the first map, the screen flashes, then returns to the geoscape. Bug happens every time.

The bug itself is often just a symptom of things that happened right before (or often even a long time ago).

Some things to check:

    * The first thing we ask you is to check if you can reproduce the bug. The simpler the reproduction-steps are, the better.
Start new game, advance time, send firebird to crash site, click "Enter". Nothing else needs be done.

    * Does the bug also happen when starting a new game or only after loading a saved game (most likely a bug in the load/save system)
Both. You can start a new game or load a saved game.

    * Please attach the output console file ufoconsole.log. If possible when running the game with ufo +set developer 1 (see cvar for more).
Attached as requested.

Offline criusmac

  • Squad Leader
  • ****
  • Posts: 168
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #1 on: October 24, 2009, 10:13:18 am »
I should also note that even older dev versions I downloaded via Odie's binary links do not work due to other reasons. So, basically, every single dev version I have does not work, and I do not have the bandwidth remaining to download more. 1.5 gigs have been used up this month on these downloads.

As another note, I did find
\base\maps\oriental\or_craft_drop_firebird.map

but no .bsp files exist anywhere.

Offline Kildor

  • Project Artist
  • Captain
  • ***
  • Posts: 757
  • Project mapper and some other stuff`er
    • View Profile
    • http://ufoai.nx0.ru
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #2 on: October 24, 2009, 11:37:29 am »
You use windows, right?
You need to try to compile maps for yourself, if you compile game and took it via SVN, you may use contrib/scripts/compile_maps.bat (just run script and wait some time to finish, time will be really large).

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #3 on: October 24, 2009, 07:58:39 pm »
Did you mix SVN and pre-built binary installers in the same folder?  If you did, that would cause problems.


Offline criusmac

  • Squad Leader
  • ****
  • Posts: 168
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #4 on: October 26, 2009, 03:55:23 pm »
I did not mix svn and pre-built binary installers in the same location.

This was pulled into an empty directory via TortoiseSVN. It was around a 700 meg download.

Thank you for the help, I will try to compile the maps myself.

Luck seems to be with me so far. Almost every map is taking 0 seconds to compile so far...

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #5 on: October 26, 2009, 05:09:41 pm »
Luck seems to be with me so far. Almost every map is taking 0 seconds to compile so far...

Is that luck? Expect them to be corrupt.... unless they're small pieces on RMAs and/or you have a supercomputer. :)

-geever

Offline criusmac

  • Squad Leader
  • ****
  • Posts: 168
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #6 on: October 26, 2009, 06:03:13 pm »
It's a median, not an average.

I've noticed this board doesn't always tell me when new posts appear that are unread. I was checking the unread posts since last visit every time I come here, and I didn't even notice there was a reply here until I went to look at it personally.

Although, I was sorta sitting on a web page on the forum the entire time, does that count?

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: ERROR: Couldn't load maps/oriental/or_craft_drop_firebird.bsp
« Reply #7 on: October 26, 2009, 06:25:05 pm »
Map compile time can vary quite a bit depending on if you compile "windows" or "windows debug" as a target.  The release version ("windows"), runs much faster - both ufo2map.exe and the game itself, although the game has certain debug commands (including cheat codes) and bug-hunting functionality that only works if it is compiled with "windows debug."  And yes, with the release-version compiled, my old dual-core XP machine can compile many of the smaller, simpler maps in a flash, although some other maps take a while.

I've noticed this board doesn't always tell me when new posts appear that are unread. I was checking the unread posts since last visit every time I come here, and I didn't even notice there was a reply here until I went to look at it personally.

Although, I was sorta sitting on a web page on the forum the entire time, does that count?

If you go to your account settings, there should be an option to receive email notifications when someone posts a reply to a topic you've started or posted in.  I do this myself so I get email when someone replies, the option is just off by default.  Alternatively you can click on "Additional Options..." below the text where you type a post and select "Notify me of replies."

I would offer screenshots, but because I'm an admin my screens/options would look different than yours.
« Last Edit: October 26, 2009, 06:27:19 pm by Destructavator »