project-navigation
Personal tools

Author Topic: radiant refuses to load new maps  (Read 2351 times)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
radiant refuses to load new maps
« on: October 18, 2009, 11:26:57 am »
For a couple of days now, radiant loads the four most recently used maps fine, but refuses to load other maps from the same dir (base/maps).
It gives me a popup "Error during load of map." and two msgs in the console:
**-Message: Loading map from C:/UFO/
**-WARNING **: Model type not supported: 'C:/UFO/'

What am I doing wrong ?

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: radiant refuses to load new maps
« Reply #1 on: October 18, 2009, 11:33:46 am »
i suppose you are doing nothing wrong - i will have a look

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: radiant refuses to load new maps
« Reply #2 on: October 18, 2009, 12:17:45 pm »
should be fixed now - thanks for reporting

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: radiant refuses to load new maps
« Reply #3 on: October 18, 2009, 09:48:29 pm »
Just came home to test it (r26676):
The popup has changed a bit, but still contains the same text.
Also the 2 msgs are still the same.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: radiant refuses to load new maps
« Reply #4 on: October 18, 2009, 11:07:10 pm »
did you try a make clean? the affected function was in a header file - and the radiant build is not prepared for this in a nice way. not sure how c::b handles this.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: radiant refuses to load new maps
« Reply #5 on: October 19, 2009, 12:54:17 am »
Damn. I *planned* to test with build first, then rebuild. Somehow I got over the rebuild step. Sorry :(
And yes, it now works as intended. Thx :)

Do you know why we have to rebuild that often ? I never experienced that with M$VC, and it also knows about 'precompiled header files'. I might have turned that feature off, though.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: radiant refuses to load new maps
« Reply #6 on: October 19, 2009, 08:10:11 am »
i don't know - for our makefiles this is because the headers are just missing in the deps - but for c::b... no idea.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: radiant refuses to load new maps
« Reply #7 on: October 19, 2009, 09:47:45 pm »
i don't know - for our makefiles this is because the headers are just missing in the deps .
Are you kidding ? I always thought that that was one of the main purposes of makefiles.
Does that mean whenever you change a header you'll do a full rebuild just to be sure ? I can hardly believe that.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: radiant refuses to load new maps
« Reply #8 on: October 20, 2009, 08:27:11 am »
you should ;) - it's not the case for ufo, game, ufo2map, ufoded ... but for radiant.