project-navigation
Personal tools

Author Topic: "too many particles" -> small lags on "oriental medium"  (Read 1635 times)

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
"too many particles" -> small lags on "oriental medium"
« on: September 14, 2009, 07:48:43 pm »
i've eperienced some small "lags" on the above mentioned map (mostly after the start, and no, other maps didn't have those lags), a look into the ufoconsole.log showed hundrets of error messages like this:
"Too many particles (don't add burnFlame2) - exceeded 2048
PC_SPAWN: Could not spawn child particle for 'crashsite_fire'"

r26164

Win 7 x86 RC, Geforce 9600M GT, Core 2 Duo P8400, 4GB RAM (or 3.xGB <- 32-bit)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: "too many particles" -> small lags on "oriental medium"
« Reply #1 on: September 14, 2009, 08:24:52 pm »
I can confirm this flooding for fighter_crash.map and a different configuration (i7, Vista).

Doesn't happen all the time, but very often on this map.


Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: "too many particles" -> small lags on "oriental medium"
« Reply #2 on: September 15, 2009, 05:47:02 pm »
maybe a bug in the particle definition for burnFlame or burnFlame2

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: "too many particles" -> small lags on "oriental medium"
« Reply #3 on: October 24, 2009, 01:06:54 am »
Seems I don't get that anymore on fighter_crash.map :)
Did anyone solve it ?

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: "too many particles" -> small lags on "oriental medium"
« Reply #4 on: October 24, 2009, 07:14:22 am »
the particle was tweaked - maybe that already fixed the problem