project-navigation
Personal tools

Author Topic: Missing/bugged textures on map crashed ufo  (Read 2166 times)

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Missing/bugged textures on map crashed ufo
« on: September 12, 2009, 02:51:53 am »
or perhaps... it's supposed to be snow - it was in russia :D

it's been that way in all retries of that mission. I'd be glad to add a save, but somehow my quicksave doesn't always work right :/

r26082 by Devastator

edit: ok, posted here it really does look like snow *g*, but ingame it doesn't...
Is there a way to make the game save the screenshots at 100% quality instead of 75%?
« Last Edit: September 12, 2009, 02:54:44 am by Tlactar »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #1 on: September 12, 2009, 04:28:34 am »
It looks to me like the lighting is uneven or a little messed up, not like textures are really missing, but its hard for me to tell from those screen shots.

I'm actually uploading a new build right now with fully re-built maps - It should be ready in ~1 hour.

Upp! Scratch that first statement (Sorry, its late at night where I am right now) - I see a few textures that look like they could be the wrong ones for snow...

...Another reason we could use more people working on maps!  (I would myself, but I'm working a lot on so many other things for UFO: AI at the moment.)
« Last Edit: September 12, 2009, 04:31:15 am by Destructavator »

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #2 on: September 12, 2009, 01:00:36 pm »

Upp! Scratch that first statement (Sorry, its late at night where I am right now) - I see a few textures that look like they could be the wrong ones for snow...

...Another reason we could use more people working on maps!  (I would myself, but I'm working a lot on so many other things for UFO: AI at the moment.)

as i said: it doesn't look like it did ingame ;) Probably because the screenshots get saved only at 75% quality.
what exactly do you mean by "working on maps"? ;) I've played with radiant a bit a few years ago, but can't get the one to run that's in the build  :-\

Offline bayo

  • Professional loser
  • Project Coder
  • Captain
  • ***
  • Posts: 733
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #3 on: September 12, 2009, 03:32:08 pm »
Thats imo RMA problem. And we can't do anything for it. But well, i am to sure about that.

For screenshot uv got cvar:
* r_screenshot_jpeg_quality: to change the quality (default 75)
* r_screenshot_format: to change the format (tga|png|jpg)

Then you also can use lossless format.

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #4 on: September 13, 2009, 01:01:10 am »
Quote
I've played with radiant a bit a few years ago, but can't get the one to run that's in the build

Can you please elaborate with details (error messages, etc.)?  We need people who can make and update maps, and if the custom map-editor isn't working, that makes that goal very difficult.

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #5 on: September 13, 2009, 02:15:20 am »
Can you please elaborate with details (error messages, etc.)?  We need people who can make and update maps, and if the custom map-editor isn't working, that makes that goal very difficult.
got that working now, it runs fine with a clean new installation of your latest build.
But... i'm lost already :D Guess it's really been a while...
To which paths do i have to set the preferences to again? The wiki isn't really helpful on that or at least i'm unable to find that information ^^ I'm supposed to use the uforadiant.exe, right?
« Last Edit: September 13, 2009, 02:19:34 am by Tlactar »

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #6 on: September 13, 2009, 05:51:33 am »
Yes, uforadiant.exe is correct.

I'm not positive as I don't do mapping, but I think you want the main engine path to be the top UFO AI directory where the game is installed, and the compiler binary to be "ufo2map.exe"

Mattn or one of the coders could probably clarify better than I could, as well as tell you what map-work is needed the most.

Edit: We also have a "mapping" section in this forum, I'd ask more questions there.
« Last Edit: September 13, 2009, 05:53:42 am by Destructavator »

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Missing/bugged textures on map crashed ufo
« Reply #7 on: September 13, 2009, 12:44:12 pm »
works fine, thanks! Now i just got to refresh my mapping skills... a lot! :D