project-navigation
Personal tools

Author Topic: Why is my lost base still operational (partially at least? :D)  (Read 1857 times)

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Why is my lost base still operational (partially at least? :D)
« on: September 12, 2009, 04:23:30 am »
Just went into fast forward mode and lost a battle for my main Base using auto mode ;)

Now i wonder... why can i still launch Aircraft from it? All the buildings are still there, too...
At least research/production/storage won't work anymore :D

In the Aircraft screen it says they were on red alert - great... but i can't end it / capture my base back...

attached are a save and the log

Version is r26082 by Destructavator

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: Why is my lost base still operational (partially at least? :D)
« Reply #1 on: September 12, 2009, 10:04:49 am »
You didn't lost it yet, the mission not finished. Are you sure, you selected auto mission?
Anyway you shouldn't be able to enter a base which being attacked. I'll check this.

-geever

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: Why is my lost base still operational (partially at least? :D)
« Reply #2 on: September 12, 2009, 11:13:30 am »
Further investigations revealed that the mission was finished but the base didn't destroy. That was caused by this critical bug I found in your ufoconsole.log:
Code: [Select]
ERROR: AL_ChangeAliveAlienNumber: Can't add/remove -6 live aliens, (capacity: 10/10, Alien Containment Status: 0)

I fixed the bug caused this but your save is corrupted. You can fix it by running the following command from game console but only on version r26186 or greater:
Code: [Select]
debug_destroybase 0

Thanks for reporting.
-geever

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Why is my lost base still operational (partially at least? :D)
« Reply #3 on: September 12, 2009, 12:56:06 pm »
no problem ;)

What exactly is supposed to happen when i lose a base? I guess it should completely disappear from the map, right? In other bases without alien containment i lose some buildings when i get attacked and lose, but the bases always stay on the map. Or is that caused by the same bug?
Oh, and yes, i did use Auto Mission for sure.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: Why is my lost base still operational (partially at least? :D)
« Reply #4 on: September 12, 2009, 09:40:31 pm »
What exactly is supposed to happen when i lose a base?

For know, every other building than entrance destroyed, employee killed, etc.
Later it will be completely destroyed, but there is still a problem why I haven't enable that...

-geever

Offline Tlactar

  • Rookie
  • ***
  • Posts: 60
    • View Profile
Re: Why is my lost base still operational (partially at least? :D)
« Reply #5 on: September 13, 2009, 02:55:48 am »
ok, got my base destroyed the way it's meant to be ;) Now there's only one glitch left: it does still store the antimatter, even without the antimatter containment :D

in addition: the losing screen makes the game freeze... r26164
« Last Edit: September 13, 2009, 03:03:02 am by Tlactar »