project-navigation
Personal tools

Author Topic: Game Crash: Equip Soldier  (Read 2136 times)

Offline Nightknight

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Game Crash: Equip Soldier
« on: August 26, 2009, 08:59:16 am »
Version
Code: [Select]
Game Downloaded via "svn co https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk"
Output of "svn info"
Path:
URL: https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk
Repository Root: https://ufoai.svn.sourceforge.net/svnroot/ufoai
Repository UUID: 39b98707-f80d-0410-bc7e-c6b02f5409da
Revision: 25831
Node Kind: directory
Schedule: normal
Last Changed Author: geever
Last Changed Rev: 25831
Last Changed Date: 2009-08-24 16:50:50 -0430 (Mon, 24 Aug 2009)
System
Code: [Select]
OS: Ubuntu 9.04 "Jaunty Jackalope"
Kernel "2.6.28-15-generic"
GPU: nVIDIA Gforce 8800gt 512mb DDR3
"01:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)" Driver: NVIDIA Accelerated Graphics Driver (Version 180)
Arch: AMD64
What happened before the bug occurred? Is the bug reproducible?
Code: [Select]
Crash occurred on a loaded "Savegame".
Crash is reproducible (Hardly, but possible)
Just before the crash occurred, my "Firebird" was returning from a Mission (Crashed UFO - Fighter).
(Outcome of Mission: 1 Unit (of 8) lost / All Aliens deceased / UFO Captured and sent to UFO Yard.
-Waited ~1:39 game hours for ship to return to Base
-"Entered" the base that hosts the Aircraft
-Selected "Aircraft" UI Option.
-Selected the Aircraft "Firebird" (Base hosts 2) -> "Soldiers" Tab -> Added one soldier to the Aircraft crew -> Pressed "Equip Soldiers": Game Crashed.
These are the last lines of the Terminal output.
http://pastebin.com/ma2fef04 (Stored for a Month)
These are some lines from "ufoconsole.log"
http://pastebin.com/m557303e (Stored for a Month)

Offline O01eg

  • Rookie
  • ***
  • Posts: 73
    • View Profile
Re: Game Crash: Equip Soldier
« Reply #1 on: August 27, 2009, 03:54:38 am »
Yes, I also got this bug, but haven't yet analysed it.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Game Crash: Equip Soldier
« Reply #2 on: August 27, 2009, 10:17:37 am »
It usually happen if you retry a mission and later open inventory in base. A workaround is to save&&load before opening it, but of course it's a bug and must be fixed.

-geever

Offline polyvios

  • Cannon Fodder
  • **
  • Posts: 8
    • View Profile
Re: Game Crash: Equip Soldier
« Reply #3 on: August 28, 2009, 03:02:11 am »
I submitted a tracker at sourceforge that I think fixes the bug.  Also description of why it happens.  Please test it and let me know.

Offline O01eg

  • Rookie
  • ***
  • Posts: 73
    • View Profile
Re: Game Crash: Equip Soldier
« Reply #4 on: August 28, 2009, 07:46:25 pm »
A workaround is to save&&load before opening it,
It's my saved game. It crashed if go to "Equip Soldiers"
Code: [Select]
Program received signal SIGABRT, Aborted.
[Switching to Thread 0x7f6ebbc3e7a0 (LWP 2710)]
0x00007f6eb8c6a5d6 in raise () from /lib/libc.so.6
(gdb) backtrace
#0  0x00007f6eb8c6a5d6 in raise () from /lib/libc.so.6
#1  0x00007f6eb8c6b7c3 in abort () from /lib/libc.so.6
#2  0x00007f6eb8c63bc9 in __assert_fail () from /lib/libc.so.6
#3  0x0000000000456ee3 in CL_AddWeaponAmmo (ed=0x7fff1d390790, item=
      {a = 16, m = 0x0, t = 0x61a5f60, amount = 1, rotated = 0})
    at src/client/cl_team.c:477
#4  0x0000000000481707 in CL_CleanupAircraftCrew (aircraft=0x3175dc8,
    ed=0x7fff1d390790) at src/client/campaign/cp_team.c:84
#5  0x0000000000482274 in CL_UpdateEquipmentMenuParameters_f ()
    at src/client/campaign/cp_team_callbacks.c:241
#6  0x00000000004fb760 in Cmd_ExecuteString (
    text=0x7fff1d390ac0 "team_updateequip") at src/common/cmd.c:912
#7  0x00000000004fa5c2 in Cbuf_Execute () at src/common/cmd.c:229
#8  0x000000000044ec92 in CL_SendCommand () at src/client/cl_main.c:941
#9  0x000000000044f18e in CL_Frame (now=44765, data=0x0)
    at src/client/cl_main.c:1115
#10 0x0000000000509f99 in tick_timer (now=44765, data=0x1052c248)
    at src/common/common.c:1046
#11 0x000000000050a28e in Qcommon_Frame () at src/common/common.c:1127
#12 0x0000000000562425 in main (argc=1, argv=0x7fff1d3910d8)
    at src/ports/linux/linux_main.c:53
(gdb) frame 3
#3  0x0000000000456ee3 in CL_AddWeaponAmmo (ed=0x7fffd2c7fbc0, item=
      {a = 16, m = 0x0, t = 0x61a5f60, amount = 1, rotated = 0})
    at src/client/cl_team.c:477
477 assert(item.m);
(gdb) print *item.t
$2 = {idx = 87, name = "Laser Rifle", '\0' <repeats 52 times>,
  id = "laserrifle", '\0' <repeats 53 times>,
  model = "weapons/laserrifle/laserrifle", '\0' <repeats 34 times>,
  image = '\0' <repeats 63 times>, type = "rifle", '\0' <repeats 58 times>,
  armourPath = '\0' <repeats 63 times>,
  extends_item = '\0' <repeats 63 times>, shape = 3871, sx = 5 '\005',
  sy = 2 '\002', scale = 1.25999999, center = {4.5, 0, 0.5},
  animationIndex = 49 '1', weapon = qtrue, holdTwoHanded = qfalse,
  fireTwoHanded = qtrue, extension = qfalse, headgear = qfalse,
  thrown = qfalse, price = 2500, size = 35, isPrimary = qtrue,
  isSecondary = qfalse, isHeavy = qfalse, isMisc = qfalse, isUGVitem = qfalse,
  isDummy = qfalse, doNotAddWeaponToHand = qfalse, notOnMarket = qfalse,
  ammo = 16, reload = 12, oneshot = qfalse, deplete = qfalse, useable = 0,
  ammos = {0x61b5e60, 0x0, 0x0, 0x0}, numAmmos = 1, weapons = {0x0, 0x0, 0x0,
    0x0}, fd = ...
    ... shotOrg = {0, 0}, spread = {0, 0}, delay = 0, bounce = 0,
        bounceFac = 0, crouch = 0, range = 0, shots = 0, ammo = 0,
        delayBetweenShots = 0, time = 0, damage = {0, 0}, spldmg = {0, 0},
        splrad = 0, weaponSkill = 0, irgoggles = 0}, {
        name = '\0' <repeats 63 times>, projectile = '\0' <repeats 63 times>,
        impact = '\0' <repeats 63 times>, hitBody = '\0' <repeats 63 times>,
        fireSound = '\0' <repeats 63 times>,
        impactSound = '\0' <repeats 63 times>,
        hitBodySound = '\0' <repeats 63 times>, fireAttenuation = 0,
        impactAttenuation = 0, bounceSound = '\0' <repeats 63 times>,
        obj = 0x0, weapFdsIdx = 0, fdIdx = 0, soundOnce = qfalse,
        gravity = qfalse, launched = qfalse, rolled = qfalse,
        reaction = qfalse, throughWall = 0, dmgweight = 0 '\0', speed = 0,
        shotOrg = {0, 0}, spread = {0, 0}, delay = 0, bounce = 0,
        bounceFac = 0, crouch = 0, range = 0, shots = 0, ammo = 0,
        delayBetweenShots = 0, time = 0, damage = {0, 0}, spldmg = {0, 0},
        splrad = 0, weaponSkill = 0, irgoggles = 0}}}, numFiredefs = {0, 0, 0,
    0}, numWeapons = 0, tech = 0x3101540, extension_tech = 0x0, protection = {
    0 <repeats 64 times>}, ratings = {0 <repeats 64 times>}, dmgtype = 0 '\0',
  craftitem = {type = MAX_ACITEMS, stats = {0, 0, 0, 0, 0, 0, 0, 0},
    weaponDamage = 0, weaponSpeed = 0, weaponDelay = 0, installationTime = 0,
    bullets = qfalse, beam = qfalse, beamColor = {0, 0, 0, 0},
    unlimitedAmmo = qfalse}}

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2555
    • View Profile
Re: Game Crash: Equip Soldier
« Reply #5 on: August 28, 2009, 08:36:14 pm »
It's my saved game. It crashed if go to "Equip Soldiers"

Laser rifle ammo...
http://ufoai.ninex.info/forum/index.php?topic=3963.msg29852#msg29852

-geever