project-navigation
Personal tools

Author Topic: Maploading Freeze Bug (version r26431)  (Read 3052 times)

Offline Viento

  • Rookie
  • ***
  • Posts: 96
    • View Profile
Maploading Freeze Bug (version r26431)
« on: October 07, 2009, 10:15:25 pm »
Good news: Bug is gone in ver 26563


Hello again!

I've been encountering a bug when loading maps of crashed ufos.

1. Sometimes (not reproduceable) a map of a crashed ufo won't load. The progress bar freezes some at some point. I have to use task the manager to shut down the program.

2. Retrying a mission: The map "Harvester_crashed" loads perfectly but every time I retry the mission, it freezes at some point. I even got as far as to the "battle scape" but no content in the "mainframe" appeared, only the consoles, etc. The music keeps playing. Most often I get frozen while loading. The progress bar just stops and that's it. I have to use taskmanager to shut UFO down.  

Version: r26431, Windows XP

Andreas
« Last Edit: October 16, 2009, 11:08:49 pm by Viento »

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2560
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #1 on: October 07, 2009, 10:39:10 pm »
Hello again!

I've been encountering a bug when loading maps of crashed ufos.

1. Sometimes (not reproduceable) a map of a crashed ufo won't load. The progress bar freezes some at some point. I have to use task the manager to shut down the program.

2. Retrying a mission: The map "Harvester_crashed" loads perfectly but every time I retry the mission, it freezes at some point. I even got as far as to the "battle scape" but no content in the "mainframe" appeared, only the consoles, etc. The music keeps playing. Most often I get frozen while loading. The progress bar just stops and that's it. I have to use taskmanager to shut UFO down. 

Version: r26431, Windows XP

Andreas

You should run the game from a debugger (gdb) and at the point it freezes, go to the debugger window, break the running with Crtl+C , ask for a backtrace with bt full and send the backtrace log to us. More info about Debugging is on the wiki.

-geever

Offline Viento

  • Rookie
  • ***
  • Posts: 96
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #2 on: October 08, 2009, 11:35:48 pm »
Tnx for the info and the link. I'll read the article and do that. Sorry, I'm just a newbie on the field of error-reporting. :)

Andreas

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #3 on: October 09, 2009, 12:11:24 am »
Viento,
there's no need to be sorry for being a *user*. The devs will tell and teach you what to do :)
Many of them tend to be a little non-verbose, and you'll have to deal with that ;)
But we *need* your input, so keep on reporting.

Offline LuckyLindy

  • Rookie
  • ***
  • Posts: 40
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #4 on: October 09, 2009, 04:06:18 pm »
I have been working around this problem by saving, exiting the game, restarting, and reloading.  The ufo maps will then load normally.  There seems to be an issue when you clear one ufo, hours or days later, go and investigate a new ufo and it will go into "non-responding" mode.  Some kind of flag?  I haven't tried the debugger, however, you probably need the report.

Offline Viento

  • Rookie
  • ***
  • Posts: 96
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #5 on: October 11, 2009, 04:47:59 pm »
Okay, I tried to understand the Wiki entry on debugging but - to be honest - I don't get what I should do. The information given there may be enough for an expert on game designing, it isn't for a "user only" like me.

Sorry, if there is no more detailed step-by-step description of what to do, I fear I won't be able to help. :(

Andreas

Offline Viento

  • Rookie
  • ***
  • Posts: 96
    • View Profile
Re: Maploading Freeze Bug (version r26431)
« Reply #6 on: October 16, 2009, 11:08:04 pm »
Good news:

I installed the newer version 26563 and the maploading retry freeze bug has never occured since then.

Whatever you've changed... it works now. ;)

Andreas