project-navigation
Personal tools

Author Topic: trying to compile latest svn (version 28638)  (Read 1845 times)

Offline smlacc

  • Rookie
  • ***
  • Posts: 11
    • View Profile
trying to compile latest svn (version 28638)
« on: February 20, 2010, 04:56:40 pm »
have followed all the steps in the wiki article on compiling but cannot get it to compile.  Theres a lot missing there though, so if I can get this to work I will update the wiki with the missing stuff.  The stuff I had to add included adding a bunch of missing libraries for ogg, theora etc.

I installed sdl, sdl_mixer and sdl_ttf after downloading the dmg's as per the instructions.  I copied them into /library/frameworks.

I got a ton of errors about missing libraries, so i compiled and installed gettext, jpeg, libogg, libpng, libtheora and libvorbis.  This seems to have cleared most of the missing library errors, except for one (sdl_ttf, even though i installed it already!).  To eliminate problems i read about on the forum etc, i use the following configure command:

./configure LDFLAGS='-L/sw/lib' CFLAGS='-I/sw/include' CPPFLAGS="-I/sw/include" --disable-uforadiant --disable-universal --without-curses

all the missing libraries i compiled are installed under /sw, hence the extra flag declarations.  I disabled uforadiant, universal and ncurses to try to get past the problem I have.  The problem is the following error message when I run the above configure:

checking SDL_ttf.h usability... yes
checking SDL_ttf.h presence... no
configure: WARNING: SDL_ttf.h: accepted by the compiler, rejected by the preprocessor!
configure: WARNING: SDL_ttf.h: proceeding with the compiler's result
checking for SDL_ttf.h... yes
checking for library containing TTF_Init... no
configure: error: You must have the SDL_ttf development libraries

Does this mean that copying the framework folder isnt enough, and that I need to do a full recompile of sdl_ttf?  And help appreciated.  I  can also post the full result of the ./configure if thats any help.  I have an intel macbook pro, running 10.6.2.

Thanks,
Smil


Offline smlacc

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: trying to compile latest svn (version 28638)
« Reply #1 on: February 21, 2010, 10:32:51 pm »
this might be related to 32 bit/64 bit issues.  Apparently sdl_ttf is 32 bit only, and by default xcode 2.3 defaults to compiling 64 bit apps.  So all the libraries etc I compiled will be 64 bit, while sdl_ttf, installed from the .dmg, will be 32 bit.  I'm guessing UFOAI will also be compiled 64 bit.

http://www.gamedev.net/community/forums/topic.asp?topic_id=557504

Anyone had any luck getting this to compile on 10.6.2?

Smlacc

Offline ovvldc

  • Rookie
  • ***
  • Posts: 59
    • View Profile
Re: trying to compile latest svn (version 28638)
« Reply #2 on: February 23, 2010, 07:42:37 pm »
I doubt that UFO:AI will see much benefit from 64-bit compilation. Perhaps switching to 32-bit will makes compilation go more smoothly?

Offline smlacc

  • Rookie
  • ***
  • Posts: 11
    • View Profile
Re: trying to compile latest svn (version 28638)
« Reply #3 on: February 24, 2010, 12:09:01 am »
The problem is that 64 bit is the default on xcode 2.3.  I -could- recompile all the libraries I already compiled to 32 bit, then try and force compilation of ufoai in 32 bit mode.  But this may not even be the problem, hence my question about whether anyone else had successfully compiled ufoai and required libraries on 10.6.2 with xcode 2.3

Smlacc