project-navigation
Personal tools

Author Topic: UFO:AI 2.21 - The HUD suddenly disappear  (Read 2671 times)

DarkIgor

  • Guest
UFO:AI 2.21 - The HUD suddenly disappear
« on: June 30, 2009, 01:19:14 am »
Hello,

I'm using linux (Fedora 11: Leonidas) and I tried to install UFO:AI again (I already had when I was using Fedora 10).
But when I tried to play, when I entered the first map, I got surprised when the HUD disappeared and I couldn't do any action except move the characters. When something happens (like find some alien in the map) the HUD appears but just after I click in somewhere, the HUD disappear again. I already tried to use the alternative HUD and to select and unselect all posibles video settings and nothing.
I don't know what to do to solve the problem, so I ask your help.

I'm a intel video card user (and I never had problem with UFO:AI).

Thanks for the attention,
DarkIgor

Offline Mattn

  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4831
  • https://github.com/mgerhardy/vengi
    • View Profile
    • Vengi Voxel Tools
Re: UFO:AI 2.21 - The HUD suddenly disappear
« Reply #1 on: June 30, 2009, 07:48:00 am »
you should activate the developer cvar on the game console and see what exactly is executed when you click the mouse. maybe you bound the nohud command to the mousebutton ;)

DarkIgor

  • Guest
Re: UFO:AI 2.21 - The HUD suddenly disappear
« Reply #2 on: July 05, 2009, 05:31:43 am »
I've tried doing what you told me, but when I tried to open the terminal in game, it disappeared too...So I realized that the problem maybe could be mine graphic card... But if you put in mind that before updating my Fedora 10 to Fedora 11 the game was running right and after the update this bug appeared, you can guess that the problem could be the Fedora itself... Maybe the KMS to Intel graphic cards could be creating some conflict with UFO:AI (the KMS to intel graphic cards was one of the new stuff in Fedora 11)...

I really don't know what to do...Someone know what could be? If there is some conflict between Fedora 11, Intel graphic card and UFO:AI?

Thanks,
DarkIgor

DarkIgor

  • Guest
Re: UFO:AI 2.21 - The HUD suddenly disappear
« Reply #3 on: July 05, 2009, 06:44:13 am »
I don't know what the hell is going on, but as the way that the problem appeared, it disappeared o.o
The game returned to run properly!
I don't know how neither why... But I'm playing UFO:AI while I type this post...

Thanks Mattn for helping me!

Sorry for the wasted time ;P

Greetings,
DarkIgor