project-navigation
Personal tools

Author Topic: LOF in R24498  (Read 2435 times)

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
LOF in R24498
« on: May 31, 2009, 05:33:33 am »
Well, finally got Odies build downloaded, and on the very first mission, my troops are firing when they shouldnt, like in the screen posted.

Also, soldiers were loosing TUs for moving, without moving, and I was forced into the global view mid-mission, and had to close the game

[attachment deleted by admin]

Offline Destructavator

  • Combination Multiple Specialty Developer
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 1908
  • Creater of Scorchcrafter, knows the zarakites...
    • View Profile
Re: LOF in R24498
« Reply #1 on: May 31, 2009, 05:56:30 am »
I remember that particular map - every time I play that specific map in a development build things just don't work right, although other maps don't give me as many headaches.  (Might just be my luck.)

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: LOF in R24498
« Reply #2 on: May 31, 2009, 07:22:13 am »
I see what caused the kick from the mission. An actor goe sout on sync (Thats all I could see from what console that would comeout)
I got that on the Africa map. My medic decided, rather than go where I told him to go, to walk through the wall of the UFO the squad was storming

EDIT: Managed to get the console to remain open long enough for a screenie
Edit2: Its getting to the point where I cant even do a mission. Got another one on the farm map

Edit3: Jeeze...Well, got a Visual C++ Runtime error on the fightercrash map. See third screenie

Edit4: Gad jookes! Same map as edit3, but this time I got a sync issue as well as a missing model

[attachment deleted by admin]
« Last Edit: May 31, 2009, 09:09:28 am by vedrit »

ralthor

  • Guest
Re: LOF in R24498
« Reply #3 on: May 31, 2009, 08:14:24 pm »
FYI that same information can be obtained from the ufoconsole.log file (so you don't have to try and grab a screenshot), located at

C:\Documents and Settings\<user>\Application Data\UFOAI\2.3-dev\base on windows, not sure where on linux.

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: LOF in R24498
« Reply #4 on: May 31, 2009, 09:33:52 pm »
thanks. I kept looking in the program file folder and, ofcourse, not finding it.

So, anyone know why its doing this? Character out of sync, C++ errors, etc

EDIT: Heres one of the logs

[attachment deleted by admin]
« Last Edit: June 01, 2009, 01:42:58 am by vedrit »

odie

  • Guest
Re: LOF in R24498
« Reply #5 on: June 02, 2009, 09:53:11 am »
"ERROR: Negative TU costs while walking (team: 1)"

If i did not read this log wrongly, it seemed that this occurs on the 3rd round of your turn (1st being the round u first came on). [This info from here]

Code: [Select]
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/farm.mat'
music change to David02 (from van_geoscape)
Retracing for model *1 in   0.0s
Retracing for model *2 in   0.0s
Retracing for model *3 in   0.0s
Retracing for model *4 in   1.0s
Retracing for model *5 in   0.0s
Retracing for model *6 in   0.0s
Retracing for model *7 in   0.0s
Retracing for model *8 in   0.0s
Starting the game...
Vedrit has joined team 0
(player 0) It's team 1's round
Vedrit has taken control over team 1.
music change to PsymongN3 (from David02)
Retracing for model *1 in   0.0s
Retracing for model *2 in   0.0s
Retracing for model *3 in   0.0s
Retracing for model *4 in   0.0s
Retracing for model *5 in   0.0s
Retracing for model *6 in   0.0s
Retracing for model *7 in   0.0s
Retracing for model *8 in   0.0s

Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!
Team 1 ended round, team 7's round started!
Team 7 ended round, team 0's round started!
Team 0 ended round, team 1's round started!

********************
ERROR: Negative TU costs while walking (team: 1)
********************
Shutdown server: Server crashed.
==== ShutdownGame ====
Server crashed.
********************

I usually see my server crashed in console during my 3rd rounds (if they do crash). How is it that we end up with -ve TU btw??

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Re: LOF in R24498
« Reply #6 on: June 03, 2009, 01:38:16 am »
Im more concerned about models being out of sync. Is there a command to check and force models to sync?

Offline vedrit

  • Sergeant
  • *****
  • Posts: 438
    • View Profile
Bad message in R24552
« Reply #7 on: June 03, 2009, 03:02:05 am »
Yeah, latest Odie build. Just killed the last alien on Farm map, harvestor drop mission, and I get kicked out of the mission. I checked the console and it said something about a bad message, and closed the server. See attached log

[attachment deleted by admin]