project-navigation
Personal tools

Author Topic: cannot find -ltheora  (Read 25698 times)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
cannot find -ltheora
« on: May 05, 2009, 12:45:00 am »
I get the above ERROR when compiling ufo rev 24341 with C::B on Win XP.
« Last Edit: May 05, 2009, 12:47:48 am by Duke »

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: cannot find -ltheora
« Reply #1 on: May 05, 2009, 01:58:17 am »
You need to download a new C::B package. Use the download link on the wiki.

Offline Muton

  • Sergeant
  • *****
  • Posts: 496
    • View Profile
Re: cannot find -ltheora
« Reply #2 on: May 05, 2009, 08:57:37 pm »
Whats the difference

Are we downloading the whole thing for just that   :-\

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: cannot find -ltheora
« Reply #3 on: May 05, 2009, 09:05:29 pm »
the whole c::b package please - as i've added some new libraries to the mingw setup that is used in the c::b archive

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: cannot find -ltheora
« Reply #4 on: May 05, 2009, 09:06:01 pm »

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: cannot find -ltheora
« Reply #5 on: May 05, 2009, 09:49:30 pm »
Thx for the link.
I extracted it over the CB installation, updated to rev 24349, cleaned and built:
Quote
Linking executable: ..\..\ufo.exe
d:/cb/codeblocks/mingw/bin/../lib/gcc/mingw32/4.3.3/../../../../mingw32/bin/ld.exe: cannot find -ltheora
collect2: ld returned 1 exit status
Process terminated with status 1 (0 minutes, 49 seconds)
1 errors, 0 warnings

ufo.cbp == snv.

What is -ltheora ?

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: cannot find -ltheora
« Reply #6 on: May 05, 2009, 11:27:04 pm »
There must be something wrong with your C::B settings, because it's compiling fine here (r24357).

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: cannot find -ltheora
« Reply #7 on: May 05, 2009, 11:57:36 pm »
BTAxis, I don't think so. Because after you mentioned it, it was actually the first time that I ever entered the settings menu. So everything there is default.

I found my ufo.cbp was NOT original svn. So I restored it form svn (and updated to r24358) and things have gotten worse. I now also get compile errors :(

Is there anything I have to do that is not in the C::B package nor in the svn ??

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: cannot find -ltheora
« Reply #8 on: May 06, 2009, 12:12:50 am »
If everything is default, then there's something wrong. Read the wiki page about setting up C::B and make sure everything is set as described.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: cannot find -ltheora
« Reply #9 on: May 06, 2009, 12:52:31 am »
I checked it again. Everything *is* set as described.
(plz keep in mind that I have been using CB for more than half a year now *without* such problems).

The real question is: do I need to do something *manually* for this update ?

btw if it works for you, which OS are you using ?

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: cannot find -ltheora
« Reply #10 on: May 06, 2009, 12:58:56 am »
I'm using Windows XP SP2 32-bit.

I've also been using the old C::B for ages, and I had no problems updating to the new package. What I did was extract C::B itself from the archive over my old C::B, overwriting everything. I then removed my old MinGW installation and replaced it with the one from the archive. I didn't change anything else.

Mind you, C::B itself isn't the problem here, it's the updated MinGW that's acting up for you.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: cannot find -ltheora
« Reply #11 on: May 06, 2009, 01:10:46 am »
Found one part of the problem:
The #defines settings contain
Quote
HAVE_VORBIS_CODEC_H
HAVE_XVID_H
HAVE_THEORA_THEORA_H
...mentioned in the Coding->OGM thread.
Removed them and got rid of the compile errors. Leaves me mith the linker error...investigating.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2550
    • View Profile
Re: cannot find -ltheora
« Reply #12 on: May 06, 2009, 10:59:43 am »
did you copy the dll from contrib dir (or whatever) to the ufo:ai root dir?

-geever

Offline Muton

  • Sergeant
  • *****
  • Posts: 496
    • View Profile
Re: cannot find -ltheora
« Reply #13 on: May 06, 2009, 02:57:17 pm »
after replacing C::B with the new one
nothing is working anymore!

-------------- Clean: windows in ufo2map ---------------

Cleaned "ufo2map - windows"

-------------- Build: windows in ufo2map ---------------

Compiling: ..\..\src\tools\ufo2map\common\bspfile.c
mingw32-gcc.exe: CreateProcess: No such file or directory
Process terminated with status 1 (0 minutes, 0 seconds)
0 errors, 0 warnings

file exists
v:\mingw\bin\mingw32-gcc.exe

open C::B
go to Settings->Compiler and debugger
Toolchain executables
mingw32-gcc.exe
mingw32-g++.exe
mingw32-g++.exe
ar.exe
gdb.exe
windres.exe
make.exe

Offline BTAxis

  • Administrator
  • PHALANX Commander
  • *******
  • Posts: 2607
    • View Profile
Re: cannot find -ltheora
« Reply #14 on: May 06, 2009, 02:59:08 pm »
Try pointing it to gcc.exe and g++.exe instead.