project-navigation
Personal tools

Author Topic: rev 24266 can't start any battle  (Read 4227 times)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
rev 24266 can't start any battle
« on: April 28, 2009, 10:08:51 pm »
When trying to start any battle, I get the screenshot screen, then the game exits to desktop.
The log looks like the game isn't aware of a problem:
Code: [Select]
...
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/estate.mat'
Shutdown gametype 'Skirmish mode'
Shutdown server: Quitting server.
...

Happens with both freshly compiled maps and older compiles ie. before Mike's and my latest fixes.

odie

  • Guest
Re: rev 24266 can't start any battle
« Reply #1 on: April 29, 2009, 05:31:51 am »
When trying to start any battle, I get the screenshot screen, then the game exits to desktop.
The log looks like the game isn't aware of a problem:
Code: [Select]
...
Created AI player (team 0)
Created AI player (team 7)
-------------------------------------
Connecting to localhost...
load material file: 'materials/estate.mat'
Shutdown gametype 'Skirmish mode'
Shutdown server: Quitting server.
...

Happens with both freshly compiled maps and older compiles ie. before Mike's and my latest fixes.


Duke, curious, which version were u on??
I seemed to be able to start the game in norm game mode.... were u on skirmish?

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: rev 24266 can't start any battle
« Reply #2 on: April 29, 2009, 07:24:56 am »
exists to desktop and no segfault ... is the ufo console windows still alive?

odie

  • Guest
Re: rev 24266 can't start any battle
« Reply #3 on: April 29, 2009, 08:13:31 am »
exists to desktop and no segfault ... is the ufo console windows still alive?
Oh, tat i did not notice. I go back and check again..... aniwae, today i have a new Revision again.

Btw, which revision is yours? I might get a close to it SVN and try..... but tonite tat is. I need to visit a friend's mother who is going thru a major operation today..... need to be wif her....

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: rev 24266 can't start any battle
« Reply #4 on: April 29, 2009, 08:28:29 pm »
Duke, curious, which version were u on??
Uhm...the one in the title of my post...
I seemed to be able to start the game in norm game mode.... were u on skirmish?
Yes.

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: rev 24266 can't start any battle
« Reply #5 on: April 29, 2009, 08:31:41 pm »
exists to desktop and no segfault ... is the ufo console windows still alive?
No.
I also noticed it does NOT exit normally because the gamma setting is not reset.

So it's just me on Windoze XP ?

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: rev 24266 can't start any battle
« Reply #6 on: April 29, 2009, 08:38:04 pm »
Forget it, I found out.
It doesn't happen with all the maps, only those that have few levels eg. fighter_crash or excavation.

And I know where to look for the bug ;)

odie

  • Guest
R24273 Battle Start Issues
« Reply #7 on: April 30, 2009, 04:26:32 am »
Hi Duke,

I have went back and started up loading an old game which has a ready battle.
My OS = WinXP SP3.
Revision as of 24273.

I can run a normal game mode - save for some mail errors, and portrait of those commanders submitting proposals = missing face and stuff (some only).

When i enter the battle, it will crash out. Console will also be closed out.

However, when i loaded a new game, and chance upon another map (i thnk was a flat ground map in the forest or something, cant remember the map name, sorry), it seemed to load and then crashed out when i hit certain things......

Did not managed to get a thread out of it..... cos was like 1 2 am in the nite. lol. If u wan, i can compile today's version and get it up again to try. :)

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: rev 24266 can't start any battle
« Reply #8 on: May 01, 2009, 12:00:03 am »
Hmm...it's very different from what I thought it was.

rev 24256 deals with 'few-level-maps' eg. fighter_crash.map, so I thought that was the culprit.
But I found out that it's actually rev 24257 that introduces the CTD for those maps !

@Mattn:
The fact the CTD depends on the # of levels a map has implies a connection to routing. Not sure though.
Anyway, I need your help here.

@Odie:
No need to recompile the maps. At least not now.

odie

  • Guest
Re: rev 24266 can't start any battle
« Reply #9 on: May 01, 2009, 03:32:00 pm »
Hmm...it's very different from what I thought it was.

rev 24256 deals with 'few-level-maps' eg. fighter_crash.map, so I thought that was the culprit.
But I found out that it's actually rev 24257 that introduces the CTD for those maps !

@Mattn:
The fact the CTD depends on the # of levels a map has implies a connection to routing. Not sure though.
Anyway, I need your help here.

@Odie:
No need to recompile the maps. At least not now.


Checking in back for the end of day.... Thanks for letting me know abt the recompilation.

Yes, This seems to be the kinda of thing tat is happening to my current built. Yupz.

I guess i will let u folks work out the issue until monday when i be back in office to redo a new version then. :)

Wish u all, all the best! Off for the wkend! :D

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: rev 24266 can't start any battle
« Reply #10 on: May 03, 2009, 06:54:51 pm »
i might have been the bsp light loading issue that i've fixed a few days ago. please retry with latest trunk and report back.

odie

  • Guest
Re: rev 24266 can't start any battle
« Reply #11 on: May 04, 2009, 07:05:22 am »
i might have been the bsp light loading issue that i've fixed a few days ago. please retry with latest trunk and report back.

Noted! Am recompiling the maps and all today. Will go back tonite and try it out....

odie

  • Guest
Re: rev 24266 can't start any battle
« Reply #12 on: May 04, 2009, 08:10:50 pm »
i might have been the bsp light loading issue that i've fixed a few days ago. please retry with latest trunk and report back.

Hi Mattn,

I realised that combat maps are enter-able again. (As of my current R24322)
Noticeably bug are:

1) Battlescape cannot be "RETRY" when u press the ESC key and clicking it - would result in game hang and u would need to force shutdown app.

2) Battlescape can crash halfway in battle.... not much time to provide a backtrace..... but will see if there's anyone who can do the backtrace b4 i do....

Otherwise, i have tested sniper rifle, rocket launcher (with AP rounds), assault rifle, laser rifle all works so far. They shoots enemies. I even managed to fire a rocket and kill an alien. Though 3 rounds into game, i am forced to ALT+CTRL+DEL (ACD) force shutdown app, as it crashed back to geoscape 1/2way into battle and hangs there..... (Console still there though.)