project-navigation
Personal tools

Author Topic: Pathing error in farm-map  (Read 10609 times)

Offline richlv

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Re: Pathing error in farm-map
« Reply #15 on: April 25, 2009, 10:21:29 am »
i think the intensity of the lines can depend on resolution, yes.
looking at them, it seems to be slight misalignment of individual tiles, but that's just a guess :)

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #16 on: April 25, 2009, 11:16:17 am »
This would explain, why the area behind this lines is unreachable. But on the other hand, the map wasn't touched for a long time, so why should there a misalignment NOW? Have there been changes in the way maps are "interpreted"?

There's only a few things I can think of:
  • Due to some kind of standardization some edges haven't the same coordinates as before (rounding issue)
  • The "geographical" and the "routing" map component sometimes (but why and where?) get an offset (e.g. one starts counting with 0, the other wit 1) so they don't match in the result
  • different rounding algorithms in components above

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: Pathing error in farm-map
« Reply #17 on: April 26, 2009, 12:02:32 am »
I just tested with +farm and rev 24154.

1. I couldn't find a place where I couldn't walk (exept some stairs)

2. I saw those lines sometimes, especially when zooming out. When I zoomed in at them, they disappeared.
I could even make them disappear by scrolling. So the maptiles are properly aligned. What we see is a visual effect of two irregular textures side by side. Similar to the effect you get if your tapestry is not properly aligned.

Conclusion: plz retest with latest trunk and see if you any blocking.

Offline Muton

  • Sergeant
  • *****
  • Posts: 496
    • View Profile
Re: Pathing error in farm-map
« Reply #18 on: April 26, 2009, 07:32:14 am »
24182

Pahtfinding +farm is working well
but most other maps just crash the game

> What we see is a visual effect of two irregular textures side by side
But then we shouldnt see a black line

I think the texture is set up to high
If ground is pixel 0 the texture seams to be set on pixel 3
'Couse if you change the angle of view the black line disappear.


[attachment deleted by admin]

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #19 on: April 26, 2009, 12:48:36 pm »
In my tests yesterday I can confim all of the above:
- lines still visible, but not blocking
- unable to change the level / stairs don't work
- maps often crashed without any message

Updated to latest trunk a few minutes ago (24205), now compiling all maps agin (to be sure)...

Offline richlv

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Re: Pathing error in farm-map
« Reply #20 on: April 26, 2009, 08:25:23 pm »
I think the texture is set up to high
If ground is pixel 0 the texture seams to be set on pixel 3

from the mapping point of view, that's not possible - textures are applied to brush faces, so texture _is_ brush face (or ground in this case).

if there is no alignment error for the tiles themselves, then this is some rendering glitch or so.

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #21 on: April 26, 2009, 08:28:40 pm »
again an update: Stairs work, but not those in the UFO?!

Offline Duke

  • Administrator
  • PHALANX veteran
  • *****
  • Posts: 1037
    • View Profile
Re: Pathing error in farm-map
« Reply #22 on: April 26, 2009, 10:03:49 pm »
- maps often crashed without any message
Do those crashes still happen after you recompiled all the maps ?
Do they happen with both RMA and non-RMA maps ?
If so, please give me 2-3 names of non-RMA maps that crash.

Offline Mattn

  • CaveExpress
  • Administrator
  • PHALANX Commander
  • *****
  • Posts: 4830
  • www.caveproductions.org
    • View Profile
    • CaveExpress
Re: Pathing error in farm-map
« Reply #23 on: April 27, 2009, 08:09:46 am »
please also define "crashing". ufo is shut down completely? you just return to the menu (if so - what is the console output)

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #24 on: April 27, 2009, 01:09:28 pm »
Duke,

there was another crash, but I'm not sure what it was exactly (not reproducible). I'll have to do some more tests.
The latest one happened, when I tried to fire a grenade to an alien which was out of range. Strangely I've got no message about that, on screen simply nothing happened, so i left-clicked again - and found myself on the Windows-desktop... After that I checked the console-log: THERE was logged that I tried shooting. But that was the last message on console, nothing else (Mattn, this answers your question?).

uhm... I'm not very well versed in abbreviations, what's an RMA map?

Offline richlv

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Re: Pathing error in farm-map
« Reply #25 on: April 27, 2009, 01:23:06 pm »
1. mattn recently fixed some segfault with shooting at empty space or something - maybe you can try latest trunk (and always run trunk in gdb... see wiki for details)
also, that's not connected to pathfinding ;)

2. rma = random map assembly. essentially, maps that are compiled from multiple tiles. they appear in your console log as +name (having '+' in front of the mapname)

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2553
    • View Profile
Re: Pathing error in farm-map
« Reply #26 on: April 27, 2009, 02:53:00 pm »
1. mattn recently fixed some segfault with shooting at empty space or something - maybe you can try latest trunk (and always run trunk in gdb... see wiki for details)
also, that's not connected to pathfinding ;)

Some segfault on shooting was still alive after that fix, that one is on the tracker and yesterday's IRC log.

-geever

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #27 on: April 27, 2009, 08:14:10 pm »
always run trunk in gdb... see wiki for details)
Which wiki? ufo:ai-wiki gives no result when searching for "gdb".  :P
At least I can start a debugging session from c::b, but this is quite inconvenient. I'd rather have a link in my start menu...

Quote
2. rma = random map assembly.
ah, thanks. Haven't seen any others yet, at least I wasn't aware of if. ;D

Well, updated to 24247, waited for the first mission (+farm) and it crashed right after starting the battle view.

Code: [Select]
Starting debugger:
done
Registered new type: wxString
Registered new type: STL String
Registered new type: STL Vector
Setting breakpoints
Debugger name and version: GNU gdb 5.2.1
Program received signal SIGSEGV, Segmentation fault.
At C:/Programme/Spiele/ufoai-2.3_dev/src/client/renderer/r_model_brush.c:894

Stack:
Code: [Select]
#0 004CD9EB R_LoadBspLights(mod=0x4bf06cc) (C:/Programme/Spiele/ufoai-2.3_dev/src/client/renderer/r_model_brush.c:894)
#1 004CF0C5 R_ModAddMapTile(name=0x22f480 "farm/f_silo", day=qfalse, sX=-40, sY=24, sZ=0) (C:/Programme/Spiele/ufoai-2.3_dev/src/client/renderer/r_model_brush.c:1098)
#2 004CFCEA R_ModBeginLoading(tiles=0x2eebdef "", day=qfalse, pos=0x2eed6b4 "", mapName=0x2eead24 "+farm") (C:/Programme/Spiele/ufoai-2.3_dev/src/client/renderer/r_model_brush.c:1190)
#3 00491A75 V_LoadMedia() (C:/Programme/Spiele/ufoai-2.3_dev/src/client/cl_view.c:215)
#4 004822A5 CL_RequestNextDownload() (C:/Programme/Spiele/ufoai-2.3_dev/src/client/cl_main.c:516)
#5 004DB07F Cbuf_Execute() (C:/Programme/Spiele/ufoai-2.3_dev/src/common/cmd.c:228)
#6 00482E0B CL_SendCommand() (C:/Programme/Spiele/ufoai-2.3_dev/src/client/cl_main.c:898)
#7 00483433 CL_Frame(now=97006, data=0x0) (C:/Programme/Spiele/ufoai-2.3_dev/src/client/cl_main.c:1048)
#8 004E49F8 tick_timer(now=97006, data=0x1117ae84) (C:/Programme/Spiele/ufoai-2.3_dev/src/common/common.c:1039)
#9 004E4BA5 Qcommon_Frame() (C:/Programme/Spiele/ufoai-2.3_dev/src/common/common.c:1120)
#10 0050F217 WinMain(hInstance=0x400000, hPrevInstance=0x0, lpCmdLine=0x251f1f "", nCmdShow=10) (C:/Programme/Spiele/ufoai-2.3_dev/src/ports/windows/win_main.c:368)
#11 00000000 0x0051c70a in main() (??:??)

Do I need to give more info in such a case, or is that all what's important?
Best way would be to load it to pastebin and ask via IRC while the debugger is still active, right? ;)

Offline richlv

  • Rookie
  • ***
  • Posts: 25
    • View Profile
Re: Pathing error in farm-map
« Reply #28 on: April 27, 2009, 08:26:01 pm »
http://ufoai.ninex.info/wiki/index.php/Debugging

stack trace might be enough as it stands, but i don't code, so you might be required to provide 'bt full' output from within gdb :)

Offline Borsti67

  • Squad Leader
  • ****
  • Posts: 164
    • View Profile
Re: Pathing error in farm-map
« Reply #29 on: April 27, 2009, 09:00:03 pm »
Thanks richlv, in the meantime I managed to create a link by myself (found some docs about gdb-paramaters within the mingw-directory).

Anyway, the page you cited contains the word "gdb" literally, but searching the wiki doesn't bring it up. Strange.

Seemingly this is not my day. :P
The first flight to Sydney brought the above crash. The 2nd did work, but I couldn't find the 4th alien (probably in the upper level of the UFO where I can't go), so I needed to abort it. The 3rd one hung after "waiting for players", had to kill it via Task Manager. *sigh*

I'd better go to bed and try it another day... :(