project-navigation
Personal tools

Author Topic: Cant start UFO:AI  (Read 13530 times)

MipSpec109

  • Guest
Re: Cant start UFO:AI
« Reply #15 on: April 04, 2009, 04:18:18 pm »
I apologize for my lack of common sense in computers, I am completely new to Linux so I know how frustrated you all must be.

After using the "cd ufoai" command in Terminal, I got all the contents of the directory. No problems so far.
I then used the "./ufo" command to run the shell script. However, instead of running, I recieve the following message...
"./ufo: error while loading shared libraries: libSDL_ttf-2.0.so.0: cannot open shared object file: No such file or directory"

I also attempted the "./ufoai/ufo" command. Instead I got "bash: ./ufoai/ufo: Not a directory"

I suspect there is an issue with the installation because I reinstalled the game multiple times and even when I chose the "Start" option after the install completes, the game does not initialize.

Again, thank you all, and I apologize for the confusion.
 

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Cant start UFO:AI
« Reply #16 on: April 04, 2009, 07:57:14 pm »
please do a:
Code: [Select]
sudo apt-get install libsdl1.2-dev libsdl-ttf2.0-dev libvorbis-dev zlib1g-dev gettext libjpeg62-dev libpng12-dev libncurses5-dev libcurl3-dev libsdl-mixer1.2-dev libxml2-dev

this will install packages you need.
(The file "libSDL_ttf-2.0.so.0" it's missing now is in "libsdl-ttf2.0-0" package which will be installed with "libsdl-ttf2.0-dev")

-geever

MipSpec109

  • Guest
Re: Cant start UFO:AI
« Reply #17 on: April 05, 2009, 04:52:39 pm »
Geever, I copied the code given and entered it into Terminal. I received the following.

Code: [Select]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
zlib1g-dev is already the newest version.
zlib1g-dev set to manually installed.
libpng12-dev is already the newest version.
libpng12-dev set to manually installed.
Package libcurl3-dev is a virtual package provided by:
  libcurl4-openssl-dev 7.18.0-1ubuntu2.1
You should explicitly select one to install.
E: Package libcurl3-dev has no installation candidate

I don't believe I have libcurl because I received an error message when I was compiling the data that I needed libcurl to perform a certain task in Terminal.

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Cant start UFO:AI
« Reply #18 on: April 05, 2009, 05:22:25 pm »
Try
Code: [Select]
apt-get install libcurl4-openssl-dev
then.

-geever

MipSpec109

  • Guest
Re: Cant start UFO:AI
« Reply #19 on: April 05, 2009, 06:48:37 pm »
after getting libcurl, i used your given code as got...
Code: [Select]
Reading package lists... Done
bash: Reading: command not found
benjamin@benjamin-Neptune:~$ Building dependency tree       
bash: Building: command not found
benjamin@benjamin-Neptune:~$ Reading state information... Done
bash: Reading: command not found
benjamin@benjamin-Neptune:~$ zlib1g-dev is already the newest version.
bash: zlib1g-dev: command not found
benjamin@benjamin-Neptune:~$ zlib1g-dev set to manually installed.
bash: zlib1g-dev: command not found
benjamin@benjamin-Neptune:~$ libpng12-dev is already the newest version.
bash: libpng12-dev: command not found
benjamin@benjamin-Neptune:~$ libpng12-dev set to manually installed.
bash: libpng12-dev: command not found
benjamin@benjamin-Neptune:~$ Package libcurl3-dev is a virtual package provided by:
bash: Package: command not found
benjamin@benjamin-Neptune:~$   libcurl4-openssl-dev 7.18.0-1ubuntu2.1
bash: libcurl4-openssl-dev: command not found
benjamin@benjamin-Neptune:~$ You should explicitly select one to install.
bash: You: command not found
benjamin@benjamin-Neptune:~$ E: Package libcurl3-dev has no installation candidate

Andrew

  • Guest
Re: Cant start UFO:AI
« Reply #20 on: April 05, 2009, 10:29:33 pm »
MipSpec109, you copied your own text and pasted that into the terminal, not geever's :)

So you tried:
Code: [Select]
sudo apt-get install libcurl4-openssl-devand it worked?  That should get you libcurl.
After that, make sure you have all the other requirements before running the game:
Code: [Select]
sudo apt-get install libsdl1.2-dev libsdl-ttf2.0-dev libvorbis-dev zlib1g-dev gettext libjpeg62-dev libpng12-dev libncurses5-dev libsdl-mixer1.2-dev libxml2-dev
Once that works, try to start the game.

MipSpec109

  • Guest
Re: Cant start UFO:AI
« Reply #21 on: April 06, 2009, 04:29:06 pm »
andrewusu, you have successfully fixed the launch problem!  :D
After using your code, I managed to initialize the game using the "./ufoai/ufo" command. However there is a new issue.

The game window loads but it gets stuck in this red and black phase which I suspect is the loading screen.
I also noticed some funky messages in the Terminal

Code: [Select]
benjamin@benjamin-Neptune:~$ ./ufoai/ufo

---- filesystem initialization -----
Adding game dir: ./base
using /home/benjamin/.ufoai/2.2/base for writing
Adding game dir: /home/benjamin/.ufoai/2.2/base
couldn't exec default.cfg
couldn't exec config.cfg
couldn't exec keys.cfg

----- network initialization -------
libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.1 initialized.

------ server initialization -------
...using language: en_US.UTF-8

----- console initialization -------
couldn't load history
Console initialized.

------- video initialization -------
SDL version: 1.2.11
I: desktop depth: 32bpp
I: setting mode 6: 1024x768 (fullscreen: no)
I: got 8 bits of stencil
I: got 24 bits of depth buffer
I: got double buffer
I: got 8 bits for red
I: got 8 bits for green
I: got 8 bits for blue
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce2 MX/AGP/SSE2
GL_VERSION: 1.5.8 NVIDIA 96.43.05
GL_EXTENSIONS: GL_ARB_imaging GL_ARB_multitexture GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SUN_slice_accum
ignoring GL_EXT_LockArrays
using GL_ARB_multitexture
using GL_EXT_texture_env_combine
GL_SGIS_multitexture deprecated in favor of ARB_multitexture
ignoring GL_ARB_texture_compression
using GL_EXT_texture_filter_anisotropic [ 2 max] [ 1 selected]
using GL_EXT_texture_lod_bias
using GL_EXT_stencil_wrap
using GL_EXT_fog_coord
GL_ATI_separate_stencil not found
GL_EXT_stencil_two_side not found
max texture size: detected 2048
R_FindImage: Can't find pics/sfx/shadow (pics/sfx/shadow) - file: src/renderer/r_draw.c, line 156
R_FindImage: Can't find pics/sfx/blood (pics/sfx/blood) - file: src/renderer/r_draw.c, line 159
R_FindImage: Can't find pics/conchars (pics/conchars) - file: src/renderer/r_draw.c, line 168
R_FindImage: Can't find pics/conchars_small (pics/conchars_small) - file: src/renderer/r_draw.c, line 171
SDL_ttf version 2.0.9 - we need at least 2.0.7

------- sound initialization -------
SDL_mixer version: 1.2.6
...audio rate: 44100
...audio channels: 2
...driver: 'alsa'
R_FindImage: Can't find pics/wait (pics/wait) - file: src/renderer/r_draw.c, line 276
R_FindImage: Can't find pics/ducked (pics/ducked) - file: src/renderer/r_draw.c, line 276
R_FindImage: Can't find pics/cursor1 (pics/cursor1) - file: src/renderer/r_draw.c, line 276
R_FindImage: Can't find pics/loading (pics/loading) - file: src/renderer/r_draw.c, line 276

--- save subsystem initialization --
added size subsystem (check ff)
added base subsystem (check 0)
added campaign subsystem (check 1)
added hospital subsystem (check 2)
added market subsystem (check 3)
added research subsystem (check 4)
added employee subsystem (check 5)
added aliencont subsystem (check 6)
added production subsystem (check 7)
added aircraft subsystem (check 8)
added messagesystem subsystem (check 9)
added stats subsystem (check a)
added nations subsystem (check b)
added transfer subsystem (check c)

mr.spaceman

  • Guest
Re: Cant start UFO:AI
« Reply #22 on: April 18, 2009, 03:23:14 am »
Are you using a 64bit Linux?

The way I got mine to work which may work for you is:

-editing the ufoai file (the one that is in the ufoai folder)
-changing the GAME BINARY field to read "ufo.x86_64"; ie.:

# The game binary
GAME_BINARY="ufo.x86_64"

-saving the file
-using the ufoai script to launch the game - this can be done in the terminal by navigating to the install folder ("cd ~[whatever]~/ufoai") and typing "./ufoai"


Only do this if you have 64bit Linux - and it might be the case that you wont have the ufo.x86_64 file if you don't and didn't install the 64bit binaries.

This, as I say, might work. It worked for me, though I never had any red/black screen.  It's a different approach to the launching problem.  If it doesn't apply to you, then ignore this - it may help someone though!

MipSpec109

  • Guest
Re: Cant start UFO:AI
« Reply #23 on: April 29, 2009, 02:27:33 am »
No dice.
Thanks anyways though mr.spaceman

Offline Godmonkey

  • Rookie
  • ***
  • Posts: 17
    • View Profile
Re: Cant start UFO:AI
« Reply #24 on: April 29, 2009, 02:29:20 am »
SO I'm sorry to say I IS a linux noob... and i messed with the linux build for about an hour... well i gave up, I was never able to get past this vary issue...... But in only 12 minuets I was playing the game using the windows build through wine... only slight issues with sound but nothing I wasn't able to tweak in wine settings...

Again I'm sorry for my linux nooby-ness... But at least I got to play the game...
GM

Offline geever

  • Project Coder
  • PHALANX Commander
  • ***
  • Posts: 2561
    • View Profile
Re: Cant start UFO:AI
« Reply #25 on: April 29, 2009, 01:51:44 pm »
I suggest not to give up. We can help if you tell us where it stuck.

-geever

Offline Godmonkey

  • Rookie
  • ***
  • Posts: 17
    • View Profile
Re: Cant start UFO:AI
« Reply #26 on: April 30, 2009, 07:32:51 pm »
I DID IT!!! i got my linux build working... This was a huge step for me because I figured it out my self... It was simple really... I video drivers were not set up right... all I did was change from nvidia driver (version 96) to (version 180) and it worked fine... then I realized on my other slightly older computer that uses the on board video that It cannot run the game due to hardware suckyness...