Personal tools

Author Topic: Assertion Failure (R22305)  (Read 2098 times)


  • Guest
Assertion Failure (R22305)
« on: February 05, 2009, 06:06:45 am »
Hi again!

On WinXP Sp3, fully patched.
Recently SVN updated and compiled again R22305. (Last nite).
Went back and realised that i faced the same issue as when i compiled R22265 and R22242.

What i did was a compilation of WINDOWS-based compiler by:
1) TortiseSVN-ing the latest files.
2) Did a Clean Workspace build using CB.
3) Tried compiling the maps (\contrib\scripts\compile_maps.bat) and tried again when failed with (/clean).
4) Redoing the archives of pk3s (maps and all) (\base\archives.bat).
5) Compiling the installer (\src\ports\windows\installer.nsi)

The game formally was compiled with -
R22242 - 359568kb
R22265 - 359580kb
R22305 - 535076kb

All 3 of them can be successfully installed into my laptop, but came back with missing fonts error (\base\media\DejaVuSans.ttf) or (\base\media\FreeSans.ttf)

So, i manually transferred those files in and all 3 revisions can start up the game.... that is until the load-complete page, and where the in-game start menu should appear.

The game freezes there. I have previously enabled the FPS on the top right hand corner, and that is all that appears on my game screen.....

I have an assertion failure, of which i cant make sense, hence here to seek help.

I am trying a new compilation again later and see if it works whilst waiting for help here.... but since the 3 revisions all failed (which i suspect the ufoworkspace file might not have compiled everything needed)..... i guess this one might not work as well.....

[attachment deleted by admin]